Hoarder Standard Library

Overview

The Orthogonal.Hoarder.Stdlib library and NuGet package contains classes and interfaces that are the public face of the Hoarder database and application suite. The cornerstone class is HoarderServiceClient which is a comprehensive strongly-typed proxy between .NET clients and the web service.

The Hoarder suite is a software developer's playground to test new platforms, kits and techniques. The complete source code of the Hoarder solution and projects is available in case it contains useful demonstration code.

Hoarder manages the Nancy Street Collections database which is stored in a free tier Cosmos DB database in an Azure Storage Account.

For more information, follow these links:

Hoarder DevOps Project Repository

https://dev.azure.com/orthogonal/Hoarder

Collections Database History

Collections Database History

Blazing Hoarder

http://www.orthogonal.com.au/hoarderblaze/

Hoarder REST-Style Web API

http://www.orthogonal.com.au/hoarderapi/

The author's hobby home page

http://www.orthogonal.com.au/

The author's software development home page

https://www.orthogonal.net.au/

Visio Flowchart

Send comments on this topic to Orthogonal Programming


Orthogonal.Hoarder.StdLib Namespace

Base namespace for the Trona Standard Library classes and interfaces.
Classes
Class | Description
Public class HoarderConfiguration

Encapsulates all possible configuration values for the Hoarder suite. The static LoadAsync(String) method can be used to deserialize an instance from a JSON file accessible at a specified Uri (which may be a http:// address or a local file:// address). The JSON file must have exactly the same schema as the fields in this class. A sample JSON file is provided in this project.

Five of the configuration values are secrets known only to the person testing or hosting the Hoarder suite. The secret values are deserialized from the JSON file if it defines them, then an overriding value for each secret is taken from an Environment variable if one exists. Environment variables can be used to provide the secrets for the suite when it is hosted in a trusted environment such as a local PC or web hosting.

Public class | HoarderServiceClient | A .NET client class for the Hoarder web service API. All methods, request bodies and response bodies are mapped to strongly-typed C# shared library classes.
Public class | TestHelper | A base class of helper methods for unit tests.
Public class | Utility | A static class of utility methods that may be useful anywhere within the Hoarder suite.
Public class | WikiPageInfo | Represents Wikipedia page information (just the Uri at the moment).
Public class | WikiSearchResult | Represents a short summary of Wikipedia search results.
Public class | XmlSerializeHelper | A helper class to serialize and deserialize Title documents and their sub-documents to and from XML.
Delegates
 | Delegate | Description
Public delegate | HoarderServiceClientLoggerDelegate | Defines a method signature that the client class can use as a logging sink.
Enumerations
 | Enumeration | Description
Public enumeration | Role | Enumeration of official authorisation roles recognised by the application suite.


HoarderConfiguration Class

Encapsulates all possible configuration values for the Hoarder suite. The static LoadAsync(String) method can be used to deserialize an instance from a JSON file accessible at a specified Uri (which may be a http:// address or a local file:// address). The JSON file must have exactly the same schema as the fields in this class. A sample JSON file is provided in this project.

Five of the configuration values are secrets known only to the person testing or hosting the Hoarder suite. The secret values are deserialized from the JSON file if it defines them, then an overriding value for each secret is taken from an Environment variable if one exists. Environment variables can be used to provide the secrets for the suite when it is hosted in a trusted environment such as a local PC or web hosting.

Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLibHoarderConfiguration

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public sealed class HoarderConfiguration : ICloneable

The HoarderConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | HoarderConfiguration | Initializes a new instance of the HoarderConfiguration class
Top
Properties
 | Name | Description
Public property | BackupConnect | SECRET -- Connection string to an Azure Storage Account where Hoarder stores backup data.
Public property | BackupContainerName | Name of the Azure Container that contains backup files.
Public property | BlobPathSeparator | Path separator for pseido-folders in Azure blob containers.
Public property | DatabaseCollectionId | The Cosmos database collection Id as defined in the Azure portal.
Public property | DatabaseEndpoint | The Uri endpoint of the Cosmos database containing the collections database.
Public property | DatabaseId | The Cosmos database Id as defined in the Azure portal.
Public property | DbKey | SECRET -- The key to access the Azure Cosmos Database containing the Hoarder collections database records.
Public property | HomeOwners | SECRET -- Comma joined list of Nancy Steet home owners.
Public property | KeyRoles | An optional array of strings in the format "key,role,role,..." that assign role(s) to a request header authorisation key.
Public property | PartitionKey | The Partition Key for the collection database. Because the collection only contains several thousand documents and multi-partition high-performance queries are not needed, the PK is set to the constant value "P1".
Public property | PhotosContainerName | Name of the Azure Container that contains original full-size photo image blobs.
Public property | PhotosContainerUri | Public Uri of the original full-size photo blobs Azure Container.
Public property | PicExtensions | A set of file-system file extensions (with leading dot) that the app recognises as containing parsable images.
Public property | PicMetaExtensions | A set of Azure blob file extensions (with leading dot) that the app recognises as containing parsable images.
Public property | StorageConnect | SECRET -- Connection string to an Azure Storage Account where Hoarder stores picture blobs and other general non-backup data.
Public property | ThumbnailExtension | The extension (with leading dot) to be used on thumbnail files and blobs. Every thumbnail currently has a '.jpg' extension because they are the easier to create with the .NET media and image classes.
Public property | ThumbnailQuality | JPEG image encoder quality for thumbnail images.
Public property | ThumbnailsContainerName | Name of the Azure Container that contains thumnail photo image blobs.
Public property | ThumbnailsContainerUri | Public Uri of the thumbnail photo blobs Azure Container.
Public property | ThumbnailSize | The default thumbnail image width and height constraint size square. Images are proportionally resized to fit inside the width and height size constraints.
Public property | TruthPhotosFolder | The file-system folder containing 'master' images (aka the source of 'truth' images).
Public property | TruthThumbnailsFolder | The file-system folder containing thumnail images.
Public property | WebPictureColumnCount | Number of columns in tables of images inserted into web pages.
Public property | WebRootFolder | The file-system root folder of the website containing pages that contain special delimiters that accept data exported from the collections database.
Top
Methods
 | Name | Description
Public method | Clone | Creates a shallow clone of the configuration (which is sufficient).
Public method | GetRolesForKey | Gets the role names that are assigned to an API Key.
 | LoadAsync | Deserializes the Hoarder configuration values from a JSON document at a specified local or remote Uri. Some 'secret' values in the config document may be overriden by environment variables with the same name as the properties, which is useful in testing. Top-level apps using the Hoarder web service will typically call this method very early in app lifetime so the configuration values are loaded.
Top
Fields
Name | Description
ApplicationContainerName |
CacheKeyContribPick |
CacheKeyContributorList |
CacheKeyExplorerList |
DefaultNewContributorRole |
HOARDER_CONFIG_URI |
HOARDER_SERVICE_KEY |
HOARDER_SERVICE_URI |
MockSortUpper |
WorkerLogsVdirPrefix |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration Constructor

Initializes a new instance of the HoarderConfiguration class

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public HoarderConfiguration()
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration Properties

The HoarderConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | BackupConnect | SECRET -- Connection string to an Azure Storage Account where Hoarder stores backup data.
Public property | BackupContainerName | Name of the Azure Container that contains backup files.
Public property | BlobPathSeparator | Path separator for pseido-folders in Azure blob containers.
Public property | DatabaseCollectionId | The Cosmos database collection Id as defined in the Azure portal.
Public property | DatabaseEndpoint | The Uri endpoint of the Cosmos database containing the collections database.
Public property | DatabaseId | The Cosmos database Id as defined in the Azure portal.
Public property | DbKey | SECRET -- The key to access the Azure Cosmos Database containing the Hoarder collections database records.
Public property | HomeOwners | SECRET -- Comma joined list of Nancy Steet home owners.
Public property | KeyRoles | An optional array of strings in the format "key,role,role,..." that assign role(s) to a request header authorisation key.
Public property | PartitionKey | The Partition Key for the collection database. Because the collection only contains several thousand documents and multi-partition high-performance queries are not needed, the PK is set to the constant value "P1".
Public property | PhotosContainerName | Name of the Azure Container that contains original full-size photo image blobs.
Public property | PhotosContainerUri | Public Uri of the original full-size photo blobs Azure Container.
Public property | PicExtensions | A set of file-system file extensions (with leading dot) that the app recognises as containing parsable images.
Public property | PicMetaExtensions | A set of Azure blob file extensions (with leading dot) that the app recognises as containing parsable images.
Public property | StorageConnect | SECRET -- Connection string to an Azure Storage Account where Hoarder stores picture blobs and other general non-backup data.
Public property | ThumbnailExtension | The extension (with leading dot) to be used on thumbnail files and blobs. Every thumbnail currently has a '.jpg' extension because they are the easier to create with the .NET media and image classes.
Public property | ThumbnailQuality | JPEG image encoder quality for thumbnail images.
Public property | ThumbnailsContainerName | Name of the Azure Container that contains thumnail photo image blobs.
Public property | ThumbnailsContainerUri | Public Uri of the thumbnail photo blobs Azure Container.
Public property | ThumbnailSize | The default thumbnail image width and height constraint size square. Images are proportionally resized to fit inside the width and height size constraints.
Public property | TruthPhotosFolder | The file-system folder containing 'master' images (aka the source of 'truth' images).
Public property | TruthThumbnailsFolder | The file-system folder containing thumnail images.
Public property | WebPictureColumnCount | Number of columns in tables of images inserted into web pages.
Public property | WebRootFolder | The file-system root folder of the website containing pages that contain special delimiters that accept data exported from the collections database.
Top
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.BackupConnect Property

HoarderConfigurationBackupConnect Property

SECRET -- Connection string to an Azure Storage Account where Hoarder stores backup data.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string BackupConnect { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.BackupContainerName Property

HoarderConfigurationBackupContainerName Property

Name of the Azure Container that contains backup files.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string BackupContainerName { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.BlobPathSeparator Property

HoarderConfigurationBlobPathSeparator Property

Path separator for pseido-folders in Azure blob containers.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public char BlobPathSeparator { get; set; }

Property Value

Char
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.DatabaseCollectionId Property

HoarderConfigurationDatabaseCollectionId Property

The Cosmos database collection Id as defined in the Azure portal.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string DatabaseCollectionId { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.DatabaseEndpoint Property

HoarderConfigurationDatabaseEndpoint Property

The Uri endpoint of the Cosmos database containing the collections database.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string DatabaseEndpoint { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.DatabaseId Property

HoarderConfigurationDatabaseId Property

The Cosmos database Id as defined in the Azure portal.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string DatabaseId { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.DbKey Property

HoarderConfigurationDbKey Property

SECRET -- The key to access the Azure Cosmos Database containing the Hoarder collections database records.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string DbKey { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.HomeOwners Property

HoarderConfigurationHomeOwners Property

SECRET -- Comma joined list of Nancy Steet home owners.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string HomeOwners { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.KeyRoles Property

HoarderConfigurationKeyRoles Property

An optional array of strings in the format "key,role,role,..." that assign role(s) to a request header authorisation key.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string[] KeyRoles { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.PartitionKey Property

HoarderConfigurationPartitionKey Property

The Partition Key for the collection database. Because the collection only contains several thousand documents and multi-partition high-performance queries are not needed, the PK is set to the constant value "P1".

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string PartitionKey { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.PhotosContainerName Property

HoarderConfigurationPhotosContainerName Property

Name of the Azure Container that contains original full-size photo image blobs.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string PhotosContainerName { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.PhotosContainerUri Property

HoarderConfigurationPhotosContainerUri Property

Public Uri of the original full-size photo blobs Azure Container.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string PhotosContainerUri { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.PicExtensions Property

HoarderConfigurationPicExtensions Property

A set of file-system file extensions (with leading dot) that the app recognises as containing parsable images.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string[] PicExtensions { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.PicMetaExtensions Property

HoarderConfigurationPicMetaExtensions Property

A set of Azure blob file extensions (with leading dot) that the app recognises as containing parsable images.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string[] PicMetaExtensions { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.StorageConnect Property

HoarderConfigurationStorageConnect Property

SECRET -- Connection string to an Azure Storage Account where Hoarder stores picture blobs and other general non-backup data.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string StorageConnect { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.ThumbnailExtension Property

HoarderConfigurationThumbnailExtension Property

The extension (with leading dot) to be used on thumbnail files and blobs. Every thumbnail currently has a '.jpg' extension because they are the easier to create with the .NET media and image classes.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string ThumbnailExtension { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.ThumbnailQuality Property

HoarderConfigurationThumbnailQuality Property

JPEG image encoder quality for thumbnail images.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int ThumbnailQuality { get; set; }

Property Value

Int32
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.ThumbnailsContainerName Property

HoarderConfigurationThumbnailsContainerName Property

Name of the Azure Container that contains thumnail photo image blobs.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string ThumbnailsContainerName { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.ThumbnailsContainerUri Property

HoarderConfigurationThumbnailsContainerUri Property

Public Uri of the thumbnail photo blobs Azure Container.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string ThumbnailsContainerUri { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.ThumbnailSize Property

HoarderConfigurationThumbnailSize Property

The default thumbnail image width and height constraint size square. Images are proportionally resized to fit inside the width and height size constraints.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int ThumbnailSize { get; set; }

Property Value

Int32
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.TruthPhotosFolder Property

HoarderConfigurationTruthPhotosFolder Property

The file-system folder containing 'master' images (aka the source of 'truth' images).

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string TruthPhotosFolder { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.TruthThumbnailsFolder Property

HoarderConfigurationTruthThumbnailsFolder Property

The file-system folder containing thumnail images.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string TruthThumbnailsFolder { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.WebPictureColumnCount Property

HoarderConfigurationWebPictureColumnCount Property

Number of columns in tables of images inserted into web pages.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int WebPictureColumnCount { get; set; }

Property Value

Int32
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.WebRootFolder Property

HoarderConfigurationWebRootFolder Property

The file-system root folder of the website containing pages that contain special delimiters that accept data exported from the collections database.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string WebRootFolder { get; set; }

Property Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration Methods

The HoarderConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a shallow clone of the configuration (which is sufficient).
Public method | GetRolesForKey | Gets the role names that are assigned to an API Key.
 | LoadAsync | Deserializes the Hoarder configuration values from a JSON document at a specified local or remote Uri. Some 'secret' values in the config document may be overriden by environment variables with the same name as the properties, which is useful in testing. Top-level apps using the Hoarder web service will typically call this method very early in app lifetime so the configuration values are loaded.
Top
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.Clone Method

HoarderConfigurationClone Method

Creates a shallow clone of the configuration (which is sufficient).

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Object Clone()

Return Value

Object

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.HoarderConfiguration.Clone"]

Implements

ICloneableClone
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.GetRolesForKey Method

HoarderConfigurationGetRolesForKey Method

Gets the role names that are assigned to an API Key.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Role[] GetRolesForKey(
    string key
)

Parameters

key String
The API Key.

Return Value

Role
A non-null array of role enumerations. Zero length if the key is not registered.
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.LoadAsync Method

HoarderConfigurationLoadAsync Method

Deserializes the Hoarder configuration values from a JSON document at a specified local or remote Uri. Some 'secret' values in the config document may be overriden by environment variables with the same name as the properties, which is useful in testing. Top-level apps using the Hoarder web service will typically call this method very early in app lifetime so the configuration values are loaded.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static Task<HoarderConfiguration> LoadAsync(
    string configJsonUri
)

Parameters

configJsonUri String
The JSON document Uri may be a local file:// address or a remote http:// address.

Return Value

Task HoarderConfiguration
An instance of the configuration class with all fields loaded from corresponding named values in the JSON document.
Exceptions
Exception | Condition
ApplicationException | Thrown if there are any errors in the configuration values.
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration Fields

The HoarderConfiguration type exposes the following members.

Fields
Name | Description
ApplicationContainerName |
CacheKeyContribPick |
CacheKeyContributorList |
CacheKeyExplorerList |
DefaultNewContributorRole |
HOARDER_CONFIG_URI |
HOARDER_SERVICE_KEY |
HOARDER_SERVICE_URI |
MockSortUpper |
WorkerLogsVdirPrefix |
Top
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.ApplicationContainerName Field

HoarderConfigurationApplicationContainerName Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.ApplicationContainerName"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string ApplicationContainerName = "hoarder"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.CacheKeyContribPick Field

HoarderConfigurationCacheKeyContribPick Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.CacheKeyContribPick"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string CacheKeyContribPick = "contributor-pick"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.CacheKeyContributorList Field

HoarderConfigurationCacheKeyContributorList Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.CacheKeyContributorList"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string CacheKeyContributorList = "contributor-list"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.CacheKeyExplorerList Field

HoarderConfigurationCacheKeyExplorerList Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.CacheKeyExplorerList"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string CacheKeyExplorerList = "explorer-list"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.DefaultNewContributorRole Field

HoarderConfigurationDefaultNewContributorRole Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.DefaultNewContributorRole"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string DefaultNewContributorRole = "Performer"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.HOARDER_CONFIG_URI Field

HoarderConfigurationHOARDER_CONFIG_URI Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.HOARDER_CONFIG_URI"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string HOARDER_CONFIG_URI = "Hoarder:ConfigUri"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.HOARDER_SERVICE_KEY Field

HoarderConfigurationHOARDER_SERVICE_KEY Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.HOARDER_SERVICE_KEY"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string HOARDER_SERVICE_KEY = "Hoarder:ServiceApiKey"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.HOARDER_SERVICE_URI Field

HoarderConfigurationHOARDER_SERVICE_URI Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.HOARDER_SERVICE_URI"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string HOARDER_SERVICE_URI = "Hoarder:ServiceBaseAddress"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.MockSortUpper Field

HoarderConfigurationMockSortUpper Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.MockSortUpper"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string MockSortUpper = "zzzzzzzzz"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderConfiguration.WorkerLogsVdirPrefix Field

HoarderConfigurationWorkerLogsVdirPrefix Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.HoarderConfiguration.WorkerLogsVdirPrefix"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string WorkerLogsVdirPrefix = "WorkerLogs/"

Field Value

String
See Also

Reference

HoarderConfiguration Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient Class

A .NET client class for the Hoarder web service API. All methods, request bodies and response bodies are mapped to strongly-typed C# shared library classes.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLibHoarderServiceClient

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class HoarderServiceClient : IDisposable

The HoarderServiceClient type exposes the following members.

Constructors
 | Name | Description
Public method | HoarderServiceClient | Constructs a strongly-typed .NET client to the Hoarder REST-style web service.
Top
Properties
 | Name | Description
Public property | ServiceUri | Gets the Uri of the base endpoint of the web service.
Public property | Token | Gets the authorization token (JSON Web Token) of the web service.
Top
Methods
 | Name | Description
Public method | AddVisitorBookEntry | Adds an entry to the visitor book.
Public method | AssignSource | Assigns a source title in a set of titles.
Public method | BulkAssign | Bulk assigns the property values of many Titles to the same values.
Public method | CheckApiKey | Checks an ApiKey to gain application permissions.
Public method | ClearTitleGenres | Clears all genres from Titles with Ids that match an argument set of Ids.
Public method | DataFixup | Performs a custom fixup (repair) of certain information in Titles, and then updates the configuration document to ensure it is synchronised with the Titles.
Public method | DeletePictureBlob | Deletes a picture blob.
Public method | DeleteTitle | Deletes a title.
Public method | DeleteWorkerLog | Deletes a worker log.
Public method | Dispose | Releases all resources used by the HoarderServiceClient
Public method | ExportCollectionToJsonBlob | Starts an export of the entire database to a JSON document in the backup container.
Public method | ExportCollectionToXmlBlob | Starts an export of the entire database to an XML document in the backup container.
Public method | ExportToAzureTables | Starts an exports the entire database to Azure Tables in the backup storage account.
Public method | ExportToTsvNormalised | Starts an export of the entire database to normalized TSV files in the backup container.
Public method | GetDatabaseStats | Retrieves database query statistics and performance information.
Public method | GetDatabaseSummary | Retreives a summary of the counts of different types and values in the database.
Public method | GetGlobalConfig | Returns the Hoarder application suite configuration values.
Public method | GetMetadata | Lists metadata about the web service and the data manager.
Public method | GetWorkerLogLines | Gets the lines of a specific worker log.
Public method | GlobalNameSearch | Runs a global search for a string in Title titles, Picture names, Track names, File names and Contributor names.
Public method | ListBlobVDirMetadata | Gets metadata for picture blobs with a virtual directory prefix -- WARNING LARGE RESPONSE BODY.
Public method | ListContributorsInverted | Gets an array of inverted contributors.
Public method | ListDuplicateTitles | Lists duplicate titles.
Public method | ListPicMetaShort | Gets short metadata for picture blobs.
Public method | ListPicturesInverted | Gets an array of inverted pictures.
Public method | ListRandomTitles | Lists random titles.
Public method | ListThumbMetaShort | Gets short metadata for picture blobs.
Public method | ListTitleItems |
Public method | ListTitles | This is a special method to convert a previous POST into a new GET.
Public method | ListTitlesByContributorName | Lists titles containing a specified name as one of the contributors.
Public method | ListTitlesByLegacyId | Lists titles with a legacy Int32 Id from previous databases.
Public method | ListTitlesByPictureBlobName | Lists titles containing a specified blob name as one of the pictures.
Public method | ListUniqueContributorNames | Lists unique constributor names in all titles in the database.
Public method | ListVisitorBookEntries | Lists all visitor book entries.
Public method | ListWorkerLogs | Lists the short blob names of all worker logs.
Public method | Login | Converts an API Key into a JWT.
Public method | PurgeGenre | Purges a genre from the database and removes it from all titles.
Public method | ReadBlobMetadata | Gets metadata attached to the picture blob.
Public method | ReadConfig | Reads the Hoarder database configuration record.
Public method | ReadGlobalConfig | Returns the Hoarder application configuration.
Public method | ReadTitle | Retrieves a single title by Id.
Public method | RenameContributor | Renames a contributor and all Title references to the contributor.
Public method | RenameLocation | Renames a Location in all titles that reference the name.
Public method | RenameMedia | Renames a Media in all titles that reference the name.
Public method | RenameOwner | Renames an Owner in all titles that reference the name.
Public method | RenameTag | Renames a Tag in all titles that reference the name.
Public method | RepairMissingPhotos | Scans the Pictures references in Titles to see if they exist as a blob.
Public method | RepsertTitle | Replaces or inserts a title.
Public method | SetPictureMetadata | Sets picture metadata.
Public method | UpdateConfig | Updates the Hoarder database configuration record.
Public method | UpdateTitleFromItem | Updates a title with values from a title list item.
Public method | UploadPicture | Uploads a picture.
Public method | UseCountGenre | Gets a count of titles with a specified genre name.
Public method | UseCountLocation | Gets a count of titles with a specified location name.
Public method | UseCountMedia | Gets a count of titles with a specified media name.
Public method | UseCountOwner | Gets a count of titles with a specified owner name.
Public method | UseCountRole | Gets a count of titles with a specified role name.
Public method | UseCountTag | Gets a count of titles with a specified tag name.
Top
Fields
Name | Description
AuthHeaderName | This is the name of the custom request header that the Hoarder web service recognises as providing an authorisation key to access features that update the database or retrieve private information. Failure to provide the key causes the service to redact selected private information from responses or reject some operations.
Top
Remarks

The Hoarder web service only returns response codes 200, 403 and 404. This client class handles these codes as follows:

200 (OK) | Corresponds to a web service successful call. The type documented for the method is returned.
403 (Unauthorized) | Corresponds to a service failure due to lack of authorization. A valid authorization token must be placed in the Token property for the call to succeed. The absence of an authorization token will cause some service calls to return redacted data, but some calls require the token and in these cases the 403 status code is converted into a UnauthorizedAccessException.
404 (NotFound) | Only two service endpoints return status 404 (ReadTitle(String) and ReadBlobMetadata(String)), and in both cases the 404 is converted into a null return value indicating to the client caller that the requested data was not found.
Other | Any other status code is interpreted as an unhandled error and it converted in to an Exception. The main causes of this condition might be a 'bug' in the Hoarder code or data, or an external problem such as a network failure that is unrelated to the Hoarder code.
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient Constructor

Constructs a strongly-typed .NET client to the Hoarder REST-style web service.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public HoarderServiceClient(
    string serviceUri = null,
    HoarderServiceClientLoggerDelegate logger = null
)

Parameters

serviceUri String (Optional)
The optional override base address of the Hoarder web service endpoint. If this value is null then the default of http://www.orthogonal.com.au/hoarderapi/ is used.
logger HoarderServiceClientLoggerDelegate (Optional)
An optional delegate to receive logging callbacks from the client.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient Properties

The HoarderServiceClient type exposes the following members.

Properties
 | Name | Description
Public property | ServiceUri | Gets the Uri of the base endpoint of the web service.
Public property | Token | Gets the authorization token (JSON Web Token) of the web service.
Top
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ServiceUri Property

HoarderServiceClientServiceUri Property

Gets the Uri of the base endpoint of the web service.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Uri ServiceUri { get; }

Property Value

Uri
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.Token Property

HoarderServiceClientToken Property

Gets the authorization token (JSON Web Token) of the web service.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Token { get; set; }

Property Value

String
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient Methods

The HoarderServiceClient type exposes the following members.

Methods
 | Name | Description
Public method | AddVisitorBookEntry | Adds an entry to the visitor book.
Public method | AssignSource | Assigns a source title in a set of titles.
Public method | BulkAssign | Bulk assigns the property values of many Titles to the same values.
Public method | CheckApiKey | Checks an ApiKey to gain application permissions.
Public method | ClearTitleGenres | Clears all genres from Titles with Ids that match an argument set of Ids.
Public method | DataFixup | Performs a custom fixup (repair) of certain information in Titles, and then updates the configuration document to ensure it is synchronised with the Titles.
Public method | DeletePictureBlob | Deletes a picture blob.
Public method | DeleteTitle | Deletes a title.
Public method | DeleteWorkerLog | Deletes a worker log.
Public method | Dispose |
Public method | ExportCollectionToJsonBlob | Starts an export of the entire database to a JSON document in the backup container.
Public method | ExportCollectionToXmlBlob | Starts an export of the entire database to an XML document in the backup container.
Public method | ExportToAzureTables | Starts an exports the entire database to Azure Tables in the backup storage account.
Public method | ExportToTsvNormalised | Starts an export of the entire database to normalized TSV files in the backup container.
Public method | GetDatabaseStats | Retrieves database query statistics and performance information.
Public method | GetDatabaseSummary | Retreives a summary of the counts of different types and values in the database.
Public method | GetGlobalConfig | Returns the Hoarder application suite configuration values.
Public method | GetMetadata | Lists metadata about the web service and the data manager.
Public method | GetWorkerLogLines | Gets the lines of a specific worker log.
Public method | GlobalNameSearch | Runs a global search for a string in Title titles, Picture names, Track names, File names and Contributor names.
Public method | ListBlobVDirMetadata | Gets metadata for picture blobs with a virtual directory prefix -- WARNING LARGE RESPONSE BODY.
Public method | ListContributorsInverted | Gets an array of inverted contributors.
Public method | ListDuplicateTitles | Lists duplicate titles.
Public method | ListPicMetaShort | Gets short metadata for picture blobs.
Public method | ListPicturesInverted | Gets an array of inverted pictures.
Public method | ListRandomTitles | Lists random titles.
Public method | ListThumbMetaShort | Gets short metadata for picture blobs.
Public method | ListTitleItems |
Public method | ListTitles | This is a special method to convert a previous POST into a new GET.
Public method | ListTitlesByContributorName | Lists titles containing a specified name as one of the contributors.
Public method | ListTitlesByLegacyId | Lists titles with a legacy Int32 Id from previous databases.
Public method | ListTitlesByPictureBlobName | Lists titles containing a specified blob name as one of the pictures.
Public method | ListUniqueContributorNames | Lists unique constributor names in all titles in the database.
Public method | ListVisitorBookEntries | Lists all visitor book entries.
Public method | ListWorkerLogs | Lists the short blob names of all worker logs.
Public method | Login | Converts an API Key into a JWT.
Public method | PurgeGenre | Purges a genre from the database and removes it from all titles.
Public method | ReadBlobMetadata | Gets metadata attached to the picture blob.
Public method | ReadConfig | Reads the Hoarder database configuration record.
Public method | ReadGlobalConfig | Returns the Hoarder application configuration.
Public method | ReadTitle | Retrieves a single title by Id.
Public method | RenameContributor | Renames a contributor and all Title references to the contributor.
Public method | RenameLocation | Renames a Location in all titles that reference the name.
Public method | RenameMedia | Renames a Media in all titles that reference the name.
Public method | RenameOwner | Renames an Owner in all titles that reference the name.
Public method | RenameTag | Renames a Tag in all titles that reference the name.
Public method | RepairMissingPhotos | Scans the Pictures references in Titles to see if they exist as a blob.
Public method | RepsertTitle | Replaces or inserts a title.
Public method | SetPictureMetadata | Sets picture metadata.
Public method | UpdateConfig | Updates the Hoarder database configuration record.
Public method | UpdateTitleFromItem | Updates a title with values from a title list item.
Public method | UploadPicture | Uploads a picture.
Public method | UseCountGenre | Gets a count of titles with a specified genre name.
Public method | UseCountLocation | Gets a count of titles with a specified location name.
Public method | UseCountMedia | Gets a count of titles with a specified media name.
Public method | UseCountOwner | Gets a count of titles with a specified owner name.
Public method | UseCountRole | Gets a count of titles with a specified role name.
Public method | UseCountTag | Gets a count of titles with a specified tag name.
Top
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.AddVisitorBookEntry Method

HoarderServiceClientAddVisitorBookEntry Method

Adds an entry to the visitor book.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<VisitorBookEntry> AddVisitorBookEntry(
    VisitorBookEntry entry
)

Parameters

entry VisitorBookEntry
Visitor book entry data.

Return Value

Task VisitorBookEntry
The completed entry that was added.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.AssignSource Method

HoarderServiceClientAssignSource Method

Assigns a source title in a set of titles.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Title> AssignSource(
    AssignSourceParameters parameters
)

Parameters

parameters AssignSourceParameters
Assign source parameters.

Return Value

Task Title
The source title.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.BulkAssign Method

HoarderServiceClientBulkAssign Method

Bulk assigns the property values of many Titles to the same values.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> BulkAssign(
    BulkAssignParameters bulkparams
)

Parameters

bulkparams BulkAssignParameters
Parameter values to control bulk assign operation.

Return Value

Task Int32
A serialized int count of titles updated.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if bulkparams is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.CheckApiKey Method

HoarderServiceClientCheckApiKey Method

Checks an ApiKey to gain application permissions.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string[]> CheckApiKey(
    string pin
)

Parameters

pin String
The API Key to validate.

Return Value

Task String
A string array of permission names unlocked by a valid API Key. An empty array indicates the API Key is not valid.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if pin is null.
Remarks

Contact the author or host of the Hoarder application suite to obtain an ApiKey to unlock permissions.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ClearTitleGenres Method

HoarderServiceClientClearTitleGenres Method

Clears all genres from Titles with Ids that match an argument set of Ids.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> ClearTitleGenres(
    string[] ids
)

Parameters

ids String
Ids of the titles to have genres cleared.

Return Value

Task Int32
An int count of titles updated.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if ids is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.DataFixup Method

HoarderServiceClientDataFixup Method

Performs a custom fixup (repair) of certain information in Titles, and then updates the configuration document to ensure it is synchronised with the Titles.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string> DataFixup(
    string[] picFileEnds
)

Parameters

picFileEnds String
A list of all local file suffixes (the picture root folder prefix is removed)

Return Value

Task String
The name of the data fixup worker log file.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if picFileEnds is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.DeletePictureBlob Method

HoarderServiceClientDeletePictureBlob Method

Deletes a picture blob.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<bool> DeletePictureBlob(
    DeletePictureBlobParameters parameters
)

Parameters

parameters DeletePictureBlobParameters
Parameters specifying the picture blob to delete.

Return Value

Task Boolean
True of the blob was deleted, False if the blob was not found.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if parameters is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.DeleteTitle Method

HoarderServiceClientDeleteTitle Method

Deletes a title.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<bool> DeleteTitle(
    string id
)

Parameters

id String
The Id of the title to delete.

Return Value

Task Boolean
A bool flag, True if the title was deleted, False if it was not found.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if id is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.DeleteWorkerLog Method

HoarderServiceClientDeleteWorkerLog Method

Deletes a worker log.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<bool> DeleteWorkerLog(
    string name
)

Parameters

name String
The name of the worker log file to delete.

Return Value

Task Boolean
True if the log was found and deleted, False otherwise.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.Dispose Method

HoarderServiceClientDispose Method

Releases all resources used by the HoarderServiceClient

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ExportCollectionToJsonBlob Method

HoarderServiceClientExportCollectionToJsonBlob Method

Starts an export of the entire database to a JSON document in the backup container.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string> ExportCollectionToJsonBlob()

Return Value

Task String
The name of the export worker log file.
Remarks

This call starts the export processing running in the background then returns. The response body string contains the Uri of the Azure Blob that will containing the processing log when the export completes.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ExportCollectionToXmlBlob Method

HoarderServiceClientExportCollectionToXmlBlob Method

Starts an export of the entire database to an XML document in the backup container.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string> ExportCollectionToXmlBlob()

Return Value

Task String
The name of the export worker log file.
Remarks

This call starts the export processing running in the background then returns. The response body string contains the Uri of the Azure Blob that will contain the processing log when the export completes.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ExportToAzureTables Method

HoarderServiceClientExportToAzureTables Method

Starts an exports the entire database to Azure Tables in the backup storage account.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string> ExportToAzureTables()

Return Value

Task String
The name of the export worker log file.
Remarks

This call starts the export processing running in the background then returns. The response body string contains the Uri of the Azure Blob that will containing the processing log when the export completes. This backup is purely experimental but it seems to be working correctly. The exported data is partially normalised, so it could be used to reconstruct the database if it was necessary.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ExportToTsvNormalised Method

HoarderServiceClientExportToTsvNormalised Method

Starts an export of the entire database to normalized TSV files in the backup container.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string> ExportToTsvNormalised()

Return Value

Task String
The name of the export worker log file.
Remarks

This call starts the export processing running in the background then returns. The response body string contains the Uri of the Azure Blob that will containing the processing log when the export completes. The whole database is exported in 3rd normal form to a set of tab delimited text files in the backup container. Each file represents a normalised RDB table. The files can be imported directly into a SQL Server database very slowly by a utility command elsewhere in the solution. Each file could theoretically construct an RDB holding the collection. Blog post Collections Database History (https://gfkeogh.blogspot.com/2018/01/collections-database-history.html) discusses how the old Agate SQL Server database was denormalised to create the Hoarder Cosmos database, so this method is ironically the reverse process. It's all an academic exercise. The set of exported files is first created in subfolder of the data folder specified in the Hoarder configuration, then each of those files is uploaded to a contain and virtual directory also specified in the Hoarder configuration.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.GetDatabaseStats Method

HoarderServiceClientGetDatabaseStats Method

Retrieves database query statistics and performance information.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<DbQueryStats[]> GetDatabaseStats()

Return Value

Task DbQueryStats
A DatabaseInfo array of recent database statistics and performance information.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.GetDatabaseSummary Method

HoarderServiceClientGetDatabaseSummary Method

Retreives a summary of the counts of different types and values in the database.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<DatabaseSummary> GetDatabaseSummary()

Return Value

Task DatabaseSummary
A DatabaseInfo describing database statistics and performance information.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.GetGlobalConfig Method

HoarderServiceClientGetGlobalConfig Method

Returns the Hoarder application suite configuration values.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<HoarderConfiguration> GetGlobalConfig()

Return Value

Task HoarderConfiguration
A HoarderConfiguration containing Hoarder suite configuration.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.GetMetadata Method

HoarderServiceClientGetMetadata Method

Lists metadata about the web service and the data manager.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<MetaItem[]> GetMetadata()

Return Value

Task MetaItem
A MetaItem arraydescribing the version and environment of the Hoarder web service.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.GetWorkerLogLines Method

HoarderServiceClientGetWorkerLogLines Method

Gets the lines of a specific worker log.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string[]> GetWorkerLogLines(
    string name
)

Parameters

name String
The name of the worker log file to retrieve.

Return Value

Task String
A string array of the text lines of a worker log.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.GlobalNameSearch Method

HoarderServiceClientGlobalNameSearch Method

Runs a global search for a string in Title titles, Picture names, Track names, File names and Contributor names.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<SearchResults> GlobalNameSearch(
    string searchText,
    int? max = null
)

Parameters

searchText String
Search text.
max Nullable Int32 (Optional)
Maximum number of items to return of each type.

Return Value

Task SearchResults
A SearchResults class instance containing the search results.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if searchText is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListBlobVDirMetadata Method

HoarderServiceClientListBlobVDirMetadata Method

Gets metadata for picture blobs with a virtual directory prefix -- WARNING LARGE RESPONSE BODY.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<FotoProperties[]> ListBlobVDirMetadata(
    BlobVDirMetaParameters parameters
)

Parameters

parameters BlobVDirMetaParameters
Parameters for the blob searching.

Return Value

Task FotoProperties
An FotoProperties object array.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if parameters is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListContributorsInverted Method

HoarderServiceClientListContributorsInverted Method

Gets an array of inverted contributors.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<InvertContributor[]> ListContributorsInverted(
    bool showDiscarded = true
)

Parameters

showDiscarded Boolean (Optional)
True to include names in discarded titles.

Return Value

Task InvertContributor
A InvertContributor array.
Remarks

The returned objects contain an inverted list of contributor names as the key, and a child set of Title Ids that reference the contributor.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListDuplicateTitles Method

HoarderServiceClientListDuplicateTitles Method

Lists duplicate titles.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Title[]> ListDuplicateTitles(
    bool? discarded = true
)

Parameters

discarded Nullable Boolean (Optional)
True to include discarded titles in the results.

Return Value

Task Title
A non-empty Title array.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListPicMetaShort Method

HoarderServiceClientListPicMetaShort Method

Gets short metadata for picture blobs.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<PicMetaShort[]> ListPicMetaShort(
    int? max = null
)

Parameters

max Nullable Int32 (Optional)
Maximum return count (for testing only).

Return Value

Task PicMetaShort
An PicMetaShort object array.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListPicturesInverted Method

HoarderServiceClientListPicturesInverted Method

Gets an array of inverted pictures.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<InvertPicture[]> ListPicturesInverted()

Return Value

Task InvertPicture
A InvertPicture array.
Remarks

The returned objects contain an inverted list of picture blob names as the key, and a child set of Title Ids and attributes that reference the picture.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListRandomTitles Method

HoarderServiceClientListRandomTitles Method

Lists random titles.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Title[]> ListRandomTitles(
    int count = 20,
    bool? discarded = true
)

Parameters

count Int32 (Optional)
The number of random titles to return.
discarded Nullable Boolean (Optional)
True to include discarded titles in the results.

Return Value

Task Title
A non-empty Title array.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListThumbMetaShort Method

HoarderServiceClientListThumbMetaShort Method

Gets short metadata for picture blobs.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<ThumbMetaShort[]> ListThumbMetaShort(
    int? max = null
)

Parameters

max Nullable Int32 (Optional)
Maximum return count (for testing only).

Return Value

Task ThumbMetaShort
An ThumbMetaShort object array.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListTitleItems Method

HoarderServiceClientListTitleItems Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.HoarderServiceClient.ListTitleItems(Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<TitleListItem[]> ListTitleItems(
    ListTitleParameters parameters
)

Parameters

parameters ListTitleParameters

[Missing <param name="parameters"/> documentation for "M:Orthogonal.Hoarder.StdLib.HoarderServiceClient.ListTitleItems(Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters)"]

Return Value

Task TitleListItem

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.HoarderServiceClient.ListTitleItems(Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters)"]

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListTitles Method

HoarderServiceClientListTitles Method

This is a special method to convert a previous POST into a new GET.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Title[]> ListTitles(
    ListTitleParameters parameters
)

Parameters

parameters ListTitleParameters

[Missing <param name="parameters"/> documentation for "M:Orthogonal.Hoarder.StdLib.HoarderServiceClient.ListTitles(Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters)"]

Return Value

Task Title

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.HoarderServiceClient.ListTitles(Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters)"]

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListTitlesByContributorName Method

HoarderServiceClientListTitlesByContributorName Method

Lists titles containing a specified name as one of the contributors.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Title[]> ListTitlesByContributorName(
    NameListParameters parameters
)

Parameters

parameters NameListParameters
Parameters for the list.

Return Value

Task Title
A Title array that may be zero length but not null.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if parameters is null.
Remarks

The name is the full name of a title contributor such as André Previn, AC/DC or Beach Boys, The.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListTitlesByLegacyId Method

HoarderServiceClientListTitlesByLegacyId Method

Lists titles with a legacy Int32 Id from previous databases.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Title[]> ListTitlesByLegacyId(
    int legacyId
)

Parameters

legacyId Int32
Legacy database Int32 Id.

Return Value

Task Title
A Title array that may be zero length but not null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListTitlesByPictureBlobName Method

HoarderServiceClientListTitlesByPictureBlobName Method

Lists titles containing a specified blob name as one of the pictures.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Title[]> ListTitlesByPictureBlobName(
    NameListParameters parameters
)

Parameters

parameters NameListParameters
Parameters for the list.

Return Value

Task Title
A Title array that may be zero length but not null.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if parameters is null.
Remarks

The blob name is the full path of the blob in the Azure container. Example: 'Media Covers/LP/Housemartins, The - Caravan of Love (LPS Front).jpg'

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListUniqueContributorNames Method

HoarderServiceClientListUniqueContributorNames Method

Lists unique constributor names in all titles in the database.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string[]> ListUniqueContributorNames(
    bool showDiscarded = true
)

Parameters

showDiscarded Boolean (Optional)
True to include names in discarded titles.

Return Value

Task String
A string array that may be zero length but not null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListVisitorBookEntries Method

HoarderServiceClientListVisitorBookEntries Method

Lists all visitor book entries.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<VisitorBookEntry[]> ListVisitorBookEntries()

Return Value

Task VisitorBookEntry
An array of visitor book entry objects.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ListWorkerLogs Method

HoarderServiceClientListWorkerLogs Method

Lists the short blob names of all worker logs.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string[]> ListWorkerLogs()

Return Value

Task String
A string array of the short blob names of all worker logs.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.Login Method

HoarderServiceClientLogin Method

Converts an API Key into a JWT.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string> Login(
    string apiKey
)

Parameters

apiKey String
The API Key that will be converted into a JWT containing the assigned roles.

Return Value

Task String
A string representing an encoded JSON Web Token.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if apiKey is null.
Remarks

Client applications with an API Key can use this endpoint to convert the key into a JWT (JSON Web Token) which contains the authorisation roles assigned to the key. The JWT is then placed into the headers of subsequent requests to allow elevation of permissions to view unredacted data and perform update or management operations. The HoarderServiceClient class has a Token property which correctly manages the placement of the JWT in the HTTP client's request headers.

An unrecognised API Key will return a JWT with no roles, in which case only read-only endpoints are permitted and private information is redacted.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.PurgeGenre Method

HoarderServiceClientPurgeGenre Method

Purges a genre from the database and removes it from all titles.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> PurgeGenre(
    string name
)

Parameters

name String
Name of the genre to purge.

Return Value

Task Int32
An int count of titles updated.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if name is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ReadBlobMetadata Method

HoarderServiceClientReadBlobMetadata Method

Gets metadata attached to the picture blob.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<FotoProperties> ReadBlobMetadata(
    string blobName
)

Parameters

blobName String
The name of the picture blob

Return Value

Task FotoProperties
A FotoProperties object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if blobName is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ReadConfig Method

HoarderServiceClientReadConfig Method

Reads the Hoarder database configuration record.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Configuration2> ReadConfig()

Return Value

Task Configuration2
A Configuration2 containing Hoarder global configuration values.
Remarks

This method always reads and returns the live database record, so applications will prefer to call GetConfig2Cached for better performance.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ReadGlobalConfig Method

HoarderServiceClientReadGlobalConfig Method

Returns the Hoarder application configuration.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<HoarderConfiguration> ReadGlobalConfig()

Return Value

Task HoarderConfiguration
A HoarderConfiguration containing Hoarder application configuration values.
Remarks

Information in the response will be redacted if the request does not assert the IsAdmin role.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.ReadTitle Method

HoarderServiceClientReadTitle Method

Retrieves a single title by Id.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<Title> ReadTitle(
    string id
)

Parameters

id String
The title Id to search for and retrieve.

Return Value

Task Title
A Title or null if the title is not found.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if id is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.RenameContributor Method

HoarderServiceClientRenameContributor Method

Renames a contributor and all Title references to the contributor.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> RenameContributor(
    RenameContributorParameters parameters
)

Parameters

parameters RenameContributorParameters
Contribtor rename parameters.

Return Value

Task Int32
An int count of titles updated.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.RenameLocation Method

HoarderServiceClientRenameLocation Method

Renames a Location in all titles that reference the name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> RenameLocation(
    RenameParameters parameters
)

Parameters

parameters RenameParameters
Parameters containing the old and new names.

Return Value

Task Int32
The count of titles updated.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.RenameMedia Method

HoarderServiceClientRenameMedia Method

Renames a Media in all titles that reference the name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> RenameMedia(
    RenameParameters parameters
)

Parameters

parameters RenameParameters
Parameters containing the old and new names.

Return Value

Task Int32
The count of titles updated.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.RenameOwner Method

HoarderServiceClientRenameOwner Method

Renames an Owner in all titles that reference the name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> RenameOwner(
    RenameParameters parameters
)

Parameters

parameters RenameParameters
Parameters containing the old and new names.

Return Value

Task Int32
The count of titles updated.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.RenameTag Method

HoarderServiceClientRenameTag Method

Renames a Tag in all titles that reference the name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> RenameTag(
    RenameParameters parameters
)

Parameters

parameters RenameParameters
Parameters containing the old and new names.

Return Value

Task Int32
The count of titles updated.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.RepairMissingPhotos Method

HoarderServiceClientRepairMissingPhotos Method

Scans the Pictures references in Titles to see if they exist as a blob.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<string> RepairMissingPhotos()

Return Value

Task String
The Uri of a text Blob containing the results of find processing.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.RepsertTitle Method

HoarderServiceClientRepsertTitle Method

Replaces or inserts a title.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<RepsertTitleResult> RepsertTitle(
    Title title
)

Parameters

title Title
The full title object to be updated or inserted.

Return Value

Task RepsertTitleResult
The Title document after it has been replaced or inserted. If a missing or invalid 'id' key was posted, then the returned Title will have a valid automatically assigned 'id'.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if title is null.
Remarks

A Title will be inserted if its id does not exist in the database, otherwise a Title with the existing Id will be replaced.

See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.SetPictureMetadata Method

HoarderServiceClientSetPictureMetadata Method

Sets picture metadata.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<bool> SetPictureMetadata(
    SetPicMetaParameters parameters
)

Parameters

parameters SetPicMetaParameters
Parameters specifying the blob name and metadata property values.

Return Value

Task Boolean
True of the blob was uploaded.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if parameters is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UpdateConfig Method

HoarderServiceClientUpdateConfig Method

Updates the Hoarder database configuration record.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<bool> UpdateConfig(
    Configuration2 doc
)

Parameters

doc Configuration2
The configuration document.

Return Value

Task Boolean
A bool success flag which is always True.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if doc is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UpdateTitleFromItem Method

HoarderServiceClientUpdateTitleFromItem Method

Updates a title with values from a title list item.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<bool> UpdateTitleFromItem(
    TitleListItem item
)

Parameters

item TitleListItem
Title item providing update values.

Return Value

Task Boolean
A bool flag which is currently always True.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if item is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UploadPicture Method

HoarderServiceClientUploadPicture Method

Uploads a picture.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<bool> UploadPicture(
    PicUploadParameters parameters
)

Parameters

parameters PicUploadParameters
Parameters for upload processing.

Return Value

Task Boolean
True of the blob was uploaded.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if parameters is null.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UseCountGenre Method

HoarderServiceClientUseCountGenre Method

Gets a count of titles with a specified genre name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> UseCountGenre(
    string name
)

Parameters

name String
Genre name to search for in titles.

Return Value

Task Int32
Title count.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UseCountLocation Method

HoarderServiceClientUseCountLocation Method

Gets a count of titles with a specified location name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> UseCountLocation(
    string name
)

Parameters

name String
Location name to search for in titles.

Return Value

Task Int32
Title count.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UseCountMedia Method

HoarderServiceClientUseCountMedia Method

Gets a count of titles with a specified media name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> UseCountMedia(
    string name
)

Parameters

name String
Media name to search for in titles.

Return Value

Task Int32
Title count.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UseCountOwner Method

HoarderServiceClientUseCountOwner Method

Gets a count of titles with a specified owner name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> UseCountOwner(
    string name
)

Parameters

name String
Owner name to search for in titles.

Return Value

Task Int32
Title count.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UseCountRole Method

HoarderServiceClientUseCountRole Method

Gets a count of titles with a specified role name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> UseCountRole(
    string name
)

Parameters

name String
Role name to search for in titles.

Return Value

Task Int32
Title count.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.UseCountTag Method

HoarderServiceClientUseCountTag Method

Gets a count of titles with a specified tag name.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Task<int> UseCountTag(
    string name
)

Parameters

name String
Tag name to search for in titles.

Return Value

Task Int32
Title count.
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient Fields

The HoarderServiceClient type exposes the following members.

Fields
Name | Description
AuthHeaderName | This is the name of the custom request header that the Hoarder web service recognises as providing an authorisation key to access features that update the database or retrieve private information. Failure to provide the key causes the service to redact selected private information from responses or reject some operations.
Top
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.AuthHeaderName Field

HoarderServiceClientAuthHeaderName Field

This is the name of the custom request header that the Hoarder web service recognises as providing an authorisation key to access features that update the database or retrieve private information. Failure to provide the key causes the service to redact selected private information from responses or reject some operations.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string AuthHeaderName = "x-Hoarder-key"

Field Value

String
See Also

Reference

HoarderServiceClient Class
Orthogonal.Hoarder.StdLib Namespace


HoarderServiceClient.LoggerDelegate Delegate

HoarderServiceClientLoggerDelegate Delegate

Defines a method signature that the client class can use as a logging sink.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public delegate void LoggerDelegate(
    string message
)

Parameters

message String
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


Role Enumeration

Enumeration of official authorisation roles recognised by the application suite.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public enum Role
Members
Member name | Value | Description
Admin | 0 | Can perform powerful administrative functions.
SeeOwner | 1 | Can see the full owner name of titles.
SeeHidden | 2 | Can see hidden titles.
Update | 3 | Can update (or delete) titles.
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


TestHelper Class

A base class of helper methods for unit tests.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLibTestHelper

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public abstract class TestHelper

The TestHelper type exposes the following members.

Constructors
 | Name | Description
Protected method | TestHelper | Initializes a new instance of the TestHelper class
Top
Methods
 | Name | Description
Protected method | MakeTitle |
Protected method | PrintJson |
Protected method | RandGenres |
Protected method | RandLocName |
Protected method | RandMediaName |
Protected method | RandOwnerName |
Protected method | RandTags |
Protected method | Sep1 |
Protected method | Sep2 |
Protected method | Trace |
Top
Fields
 | Name | Description
Protected field | Rand |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


TestHelper Constructor

Initializes a new instance of the TestHelper class

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected TestHelper()
See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper Methods

The TestHelper type exposes the following members.

Methods
 | Name | Description
Protected method | MakeTitle |
Protected method | PrintJson |
Protected method | RandGenres |
Protected method | RandLocName |
Protected method | RandMediaName |
Protected method | RandOwnerName |
Protected method | RandTags |
Protected method | Sep1 |
Protected method | Sep2 |
Protected method | Trace |
Top
See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.MakeTitle Method

TestHelperMakeTitle Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.MakeTitle(System.String,Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected Title MakeTitle(
    string name,
    Configuration2 config2
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.MakeTitle(System.String,Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

config2 Configuration2

[Missing <param name="config2"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.MakeTitle(System.String,Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

Return Value

Title

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.MakeTitle(System.String,Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.PrintJson Method

TestHelperPrintJson Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.PrintJson(System.Object,System.String)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected void PrintJson(
    Object o,
    string title = null
)

Parameters

o Object

[Missing <param name="o"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.PrintJson(System.Object,System.String)"]

title String (Optional)

[Missing <param name="title"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.PrintJson(System.Object,System.String)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.RandGenres Method

TestHelperRandGenres Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandGenres(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected Genre[] RandGenres(
    Configuration2 config,
    int min,
    int max
)

Parameters

config Configuration2

[Missing <param name="config"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandGenres(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

min Int32

[Missing <param name="min"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandGenres(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

max Int32

[Missing <param name="max"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandGenres(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

Return Value

Genre

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandGenres(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.RandLocName Method

TestHelperRandLocName Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandLocName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected string RandLocName(
    Configuration2 config
)

Parameters

config Configuration2

[Missing <param name="config"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandLocName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandLocName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.RandMediaName Method

TestHelperRandMediaName Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandMediaName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected string RandMediaName(
    Configuration2 config
)

Parameters

config Configuration2

[Missing <param name="config"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandMediaName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandMediaName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.RandOwnerName Method

TestHelperRandOwnerName Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandOwnerName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected string RandOwnerName(
    Configuration2 config
)

Parameters

config Configuration2

[Missing <param name="config"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandOwnerName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandOwnerName(Orthogonal.Hoarder.StdLib.Entity.Configuration2)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.RandTags Method

TestHelperRandTags Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandTags(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected Tag[] RandTags(
    Configuration2 config,
    int min,
    int max
)

Parameters

config Configuration2

[Missing <param name="config"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandTags(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

min Int32

[Missing <param name="min"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandTags(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

max Int32

[Missing <param name="max"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandTags(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

Return Value

Tag

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.RandTags(Orthogonal.Hoarder.StdLib.Entity.Configuration2,System.Int32,System.Int32)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.Sep1 Method

TestHelperSep1 Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.Sep1(System.String)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected void Sep1(
    string title = null
)

Parameters

title String (Optional)

[Missing <param name="title"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.Sep1(System.String)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.Sep2 Method

TestHelperSep2 Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.Sep2(System.String)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected void Sep2(
    string title = null
)

Parameters

title String (Optional)

[Missing <param name="title"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.Sep2(System.String)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.Trace Method

TestHelperTrace Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.Trace(System.String)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected abstract void Trace(
    string s
)

Parameters

s String

[Missing <param name="s"/> documentation for "M:Orthogonal.Hoarder.StdLib.TestHelper.Trace(System.String)"]

See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper Fields

The TestHelper type exposes the following members.

Fields
 | Name | Description
Protected field | Rand |
Top
See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


TestHelper.Rand Field

TestHelperRand Field

[Missing <summary> documentation for "F:Orthogonal.Hoarder.StdLib.TestHelper.Rand"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
protected Random Rand

Field Value

Random
See Also

Reference

TestHelper Class
Orthogonal.Hoarder.StdLib Namespace


Utility Class

A static class of utility methods that may be useful anywhere within the Hoarder suite.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLibUtility

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static class Utility

The Utility type exposes the following members.

Methods
Name | Description
GetWikiPageInfo | Retrieves Wikipedia information for a specific Page Id and returns selected details of the page.
GmtTime | Creates a pleasantly formatted timestamp string that can be placed in web page footers.
HtmlEncode | Encodes a string for display in the body of an HTML page.
IsValidISBN | Determines if a string is probably a valid ISBN 10 or 13. See: ISBN-10 check digit calculation and ISBN-13 check digit calculation.
MetaDecode | Decodes an Azure Blob metadata string that was encoded with MetaEncode(String).
MetaEncode | Encodes a string to a format suitable for storing in Azure Blob metadata.
NiceSize | Formats a long number in a format that is similar to the format used by the Windows Shell. This should be done by the Windows Shell API, but it's not available in a standard2.0 library.
StableHash | See: Blog post: GetHashCode. The original custom hashing code was replaced with the Xxhash32 class after it became available.
TsvDecode | Decodes a string that has been stored in a TSV field.
TsvEncode | Encodes a string so that it can be stored in a TSV field.
WikiSearchAsync | Searches Wikipedia for one or more phrases, and the phrases joined together.
Top
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


Utility Methods

The Utility type exposes the following members.

Methods
Name | Description
GetWikiPageInfo | Retrieves Wikipedia information for a specific Page Id and returns selected details of the page.
GmtTime | Creates a pleasantly formatted timestamp string that can be placed in web page footers.
HtmlEncode | Encodes a string for display in the body of an HTML page.
IsValidISBN | Determines if a string is probably a valid ISBN 10 or 13. See: ISBN-10 check digit calculation and ISBN-13 check digit calculation.
MetaDecode | Decodes an Azure Blob metadata string that was encoded with MetaEncode(String).
MetaEncode | Encodes a string to a format suitable for storing in Azure Blob metadata.
NiceSize | Formats a long number in a format that is similar to the format used by the Windows Shell. This should be done by the Windows Shell API, but it's not available in a standard2.0 library.
StableHash | See: Blog post: GetHashCode. The original custom hashing code was replaced with the Xxhash32 class after it became available.
TsvDecode | Decodes a string that has been stored in a TSV field.
TsvEncode | Encodes a string so that it can be stored in a TSV field.
WikiSearchAsync | Searches Wikipedia for one or more phrases, and the phrases joined together.
Top
See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.GetWikiPageInfo Method

UtilityGetWikiPageInfo Method

Retrieves Wikipedia information for a specific Page Id and returns selected details of the page.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static Task<WikiPageInfo> GetWikiPageInfo(
    long pageid
)

Parameters

pageid Int64

[Missing <param name="pageid"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.GetWikiPageInfo(System.Int64)"]

Return Value

Task WikiPageInfo
The page information currently just contains the full Uri of the page.
See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.GmtTime Method

UtilityGmtTime Method

Creates a pleasantly formatted timestamp string that can be placed in web page footers.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static string GmtTime(
    DateTime? time = null
)

Parameters

time Nullable DateTime (Optional)

[Missing <param name="time"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.GmtTime(System.Nullable{System.DateTime})"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.GmtTime(System.Nullable{System.DateTime})"]

See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.HtmlEncode Method

UtilityHtmlEncode Method

Encodes a string for display in the body of an HTML page.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static string HtmlEncode(
    string value
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.HtmlEncode(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.HtmlEncode(System.String)"]

See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.IsValidISBN Method

UtilityIsValidISBN Method

Determines if a string is probably a valid ISBN 10 or 13. See: ISBN-10 check digit calculation and ISBN-13 check digit calculation.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static bool IsValidISBN(
    string value
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.IsValidISBN(System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.IsValidISBN(System.String)"]

See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.MetaDecode Method

UtilityMetaDecode Method

Decodes an Azure Blob metadata string that was encoded with MetaEncode(String).

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static string MetaDecode(
    string value
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.MetaDecode(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.MetaDecode(System.String)"]

See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.MetaEncode Method

UtilityMetaEncode Method

Encodes a string to a format suitable for storing in Azure Blob metadata.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static string MetaEncode(
    string value
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.MetaEncode(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.MetaEncode(System.String)"]

See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.NiceSize Method

UtilityNiceSize Method

Formats a long number in a format that is similar to the format used by the Windows Shell. This should be done by the Windows Shell API, but it's not available in a standard2.0 library.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static string NiceSize(
    long? size
)

Parameters

size Nullable Int64

[Missing <param name="size"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.NiceSize(System.Nullable{System.Int64})"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.NiceSize(System.Nullable{System.Int64})"]

See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.StableHash Method

UtilityStableHash Method

See: Blog post: GetHashCode. The original custom hashing code was replaced with the Xxhash32 class after it became available.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static int StableHash(
    string value
)

Parameters

value String
The string value to hash.

Return Value

Int32
A hash generated by the XxHash32 algorithm.
See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.TsvDecode Method

UtilityTsvDecode Method

Decodes a string that has been stored in a TSV field.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static string TsvDecode(
    string value
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.TsvDecode(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.TsvDecode(System.String)"]

See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.TsvEncode Method

UtilityTsvEncode Method

Encodes a string so that it can be stored in a TSV field.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static string TsvEncode(
    string value
)

Parameters

value String

[Missing <param name="value"/> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.TsvEncode(System.String)"]

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Utility.TsvEncode(System.String)"]

See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


Utility.WikiSearchAsync Method

UtilityWikiSearchAsync Method

Searches Wikipedia for one or more phrases, and the phrases joined together.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static Task<WikiSearchResult[]> WikiSearchAsync(
    params string[] values
)

Parameters

values String
One or more phrases or sentences.

Return Value

Task WikiSearchResult
An array of WikiSearchResult containing a possibly unpredictable and unreliable summary of the search results.
See Also

Reference

Utility Class
Orthogonal.Hoarder.StdLib Namespace


WikiPageInfo Class

Represents Wikipedia page information (just the Uri at the moment).
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLibWikiPageInfo

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class WikiPageInfo : IEquatable<WikiPageInfo>

The WikiPageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WikiPageInfo | Represents Wikipedia page information (just the Uri at the moment).
Top
Properties
 | Name | Description
Public property | FullUrl |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


WikiPageInfo Constructor

Represents Wikipedia page information (just the Uri at the moment).

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public WikiPageInfo(
    string FullUrl
)

Parameters

FullUrl String

[Missing <param name="FullUrl"/> documentation for "M:Orthogonal.Hoarder.StdLib.WikiPageInfo.#ctor(System.String)"]

See Also

Reference

WikiPageInfo Class
Orthogonal.Hoarder.StdLib Namespace


WikiPageInfo Properties

The WikiPageInfo type exposes the following members.

Properties
 | Name | Description
Public property | FullUrl |
Top
See Also

Reference

WikiPageInfo Class
Orthogonal.Hoarder.StdLib Namespace


WikiPageInfo.FullUrl Property

WikiPageInfoFullUrl Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.WikiPageInfo.FullUrl"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string FullUrl { get; init; }

Property Value

String
See Also

Reference

WikiPageInfo Class
Orthogonal.Hoarder.StdLib Namespace


WikiSearchResult Class

Represents a short summary of Wikipedia search results.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLibWikiSearchResult

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class WikiSearchResult : IEquatable<WikiSearchResult>

The WikiSearchResult type exposes the following members.

Constructors
 | Name | Description
Public method | WikiSearchResult | Represents a short summary of Wikipedia search results.
Top
Properties
 | Name | Description
Public property | PageId |
Public property | Snippet |
Public property | Title |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


WikiSearchResult Constructor

Represents a short summary of Wikipedia search results.

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public WikiSearchResult(
    string Title,
    long PageId,
    string Snippet
)

Parameters

Title String

[Missing <param name="Title"/> documentation for "M:Orthogonal.Hoarder.StdLib.WikiSearchResult.#ctor(System.String,System.Int64,System.String)"]

PageId Int64

[Missing <param name="PageId"/> documentation for "M:Orthogonal.Hoarder.StdLib.WikiSearchResult.#ctor(System.String,System.Int64,System.String)"]

Snippet String

[Missing <param name="Snippet"/> documentation for "M:Orthogonal.Hoarder.StdLib.WikiSearchResult.#ctor(System.String,System.Int64,System.String)"]

See Also

Reference

WikiSearchResult Class
Orthogonal.Hoarder.StdLib Namespace


WikiSearchResult Properties

The WikiSearchResult type exposes the following members.

Properties
 | Name | Description
Public property | PageId |
Public property | Snippet |
Public property | Title |
Top
See Also

Reference

WikiSearchResult Class
Orthogonal.Hoarder.StdLib Namespace


WikiSearchResult.PageId Property

WikiSearchResultPageId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.WikiSearchResult.PageId"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public long PageId { get; init; }

Property Value

Int64
See Also

Reference

WikiSearchResult Class
Orthogonal.Hoarder.StdLib Namespace


WikiSearchResult.Snippet Property

WikiSearchResultSnippet Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.WikiSearchResult.Snippet"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Snippet { get; init; }

Property Value

String
See Also

Reference

WikiSearchResult Class
Orthogonal.Hoarder.StdLib Namespace


WikiSearchResult.Title Property

WikiSearchResultTitle Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.WikiSearchResult.Title"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Title { get; init; }

Property Value

String
See Also

Reference

WikiSearchResult Class
Orthogonal.Hoarder.StdLib Namespace


XmlSerializeHelper Class

A helper class to serialize and deserialize Title documents and their sub-documents to and from XML.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLibXmlSerializeHelper

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static class XmlSerializeHelper

The XmlSerializeHelper type exposes the following members.

Methods
Name | Description
ReadTitle |
WriteTitle |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib Namespace


XmlSerializeHelper Methods

The XmlSerializeHelper type exposes the following members.

Methods
Name | Description
ReadTitle |
WriteTitle |
Top
See Also

Reference

XmlSerializeHelper Class
Orthogonal.Hoarder.StdLib Namespace


XmlSerializeHelper.ReadTitle Method

XmlSerializeHelperReadTitle Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.XmlSerializeHelper.ReadTitle(System.Xml.Linq.XElement)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static Title ReadTitle(
    XElement elem
)

Parameters

elem XElement

[Missing <param name="elem"/> documentation for "M:Orthogonal.Hoarder.StdLib.XmlSerializeHelper.ReadTitle(System.Xml.Linq.XElement)"]

Return Value

Title

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.XmlSerializeHelper.ReadTitle(System.Xml.Linq.XElement)"]

See Also

Reference

XmlSerializeHelper Class
Orthogonal.Hoarder.StdLib Namespace


XmlSerializeHelper.WriteTitle Method

XmlSerializeHelperWriteTitle Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.XmlSerializeHelper.WriteTitle(System.Xml.XmlWriter,Orthogonal.Hoarder.StdLib.Entity.Title)"]

Namespace: Orthogonal.Hoarder.StdLib
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static void WriteTitle(
    XmlWriter writer,
    Title title
)

Parameters

writer XmlWriter

[Missing <param name="writer"/> documentation for "M:Orthogonal.Hoarder.StdLib.XmlSerializeHelper.WriteTitle(System.Xml.XmlWriter,Orthogonal.Hoarder.StdLib.Entity.Title)"]

title Title

[Missing <param name="title"/> documentation for "M:Orthogonal.Hoarder.StdLib.XmlSerializeHelper.WriteTitle(System.Xml.XmlWriter,Orthogonal.Hoarder.StdLib.Entity.Title)"]

See Also

Reference

XmlSerializeHelper Class
Orthogonal.Hoarder.StdLib Namespace


Orthogonal.Hoarder.StdLib.DTO Namespace

Namespace of Data Transfer Objects that represent request and response values to the API.
Classes
 | Class | Description
Public class | AssignSourceParameters | Request parameters for the AssignSource API method.
Public class | BlobVDirMetaParameters | Request parameters for the ListBlobVDirMetadata API method.
Public class | BulkAssignParameters | Request parameters for the BulkAssign API method.
Public class | DatabaseSummary | Response from the GetDatabaseSummary API method.
Public class | DbQueryStats | Response from the GetDatabaseStats API method.
Public class | DeletePictureBlobParameters | Request parameters for the DeletePictureBlobAsync API method.
Public class | FotoActor | Represents someone or something that is in a photo. The FotoProperties class contains a child collection PhotoActor.
Public class | FotoProperties | Encapsulates all of the photo information that can be associated with either Blob metadata or File properties.
Public class | FoundContributor | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundContributor.
Public class | FoundFile | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundFile.
Public class | FoundPicture | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundPicture.
Public class | FoundTitle | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundTitle.
Public class | FoundTrack | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundTrack.
Public class | InvertContributor | Response from the ListContributorsInverted API method.
Public class | InvertPicTitle | Response child class from the ListPicturesInverted API method. The InvertPicTitle class contains a collection of InvertPicTitle.
Public class | InvertPicture | Response from the ListPicturesInverted API method.
Public class | InvertTitle | The InvertContributor class contains a collection of InvertTitle.
Public class | ListTitleParameters | Request parameter for the ListTitles and ListTitleItems API methods.
Public class | MetaItem | Response from the GetMetadata API method.
Public class | NameListParameters | Request parameter for the ListTitlesByContributorName and ListTitlesByPictureBlobName API methods.
Public class | PicMetaShort | Response from the ListPicMetaShort API method.
Public class | PicUploadParameters | Request parameter for the UploadPictureAsync API method.
Public class | RenameContributorParameters | Request parameter for the RenameContributor API method.
Public class | RenameParameters | Request parameters for the RenameMedia, RenameOwner, RenameLocation and RenameTag API methods.
Public class | RepsertTitleResult | Response from the RepsertTitle API method.
Public class | SearchResults | Response from the GlobalNameSearch API method.
Public class | SetPicMetaParameters | Request parameter for the SetPictureMetadata API method.
Public class | SummaryTally | Response child class from the GetDatabaseSummary API method. The DatabaseSummary class contains collections of SummaryTally.
Public class | ThumbMetaShort | Response from the ListThumbMetaShort API method.
Public class | TitleListItem | Response from the ListTitleItems API method. Request parameter for the UpdateTitleFromItem API method. This class encapsulates a reduced set of information about a Title. The reduced information may be useful in situations where using full Title objects may be overkill and simpler summary information is satisfactory. One of the grids in the WPF desktop app uses this class to display large amounts of Title information in a concise spreadsheet format.
Public class | VisitorBookEntry | This class is used in the Web API methods related to listing and updating Visitor Book enties.
Public class | WebServiceErrorResponse | Encapsulates 'standard' error information returned in the body of any response that is not status 200 (OK). Hoarder only officially returns responses with status codes 200 (OK) and 403 (Unauthorized). A status of 500 (InternalServerError) indicates a server-side unhandled exception, probably a bug. Any response with status other than 200 will contain a serialized instance of this class.
Public class | XrefItem | Response child class from the GetDatabaseSummary API method. The DatabaseSummary class contains a collection of XrefItem.
Enumerations
 | Enumeration | Description
Public enumeration | TitleSpecialFilter | Enumeration of special Title search types for the SpecialFilter.


AssignSourceParameters Class

Request parameters for the AssignSource API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOAssignSourceParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class AssignSourceParameters : IEquatable<AssignSourceParameters>

The AssignSourceParameters type exposes the following members.

Constructors
 | Name | Description
Public method | AssignSourceParameters | Request parameters for the AssignSource API method.
Top
Properties
 | Name | Description
Public property | Ids |
Public property | SourceIndex |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


AssignSourceParameters Constructor

Request parameters for the AssignSource API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public AssignSourceParameters(
    int SourceIndex,
    string[] Ids
)

Parameters

SourceIndex Int32

[Missing <param name="SourceIndex"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.AssignSourceParameters.#ctor(System.Int32,System.String[])"]

Ids String

[Missing <param name="Ids"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.AssignSourceParameters.#ctor(System.Int32,System.String[])"]

See Also

Reference

AssignSourceParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


AssignSourceParameters Properties

The AssignSourceParameters type exposes the following members.

Properties
 | Name | Description
Public property | Ids |
Public property | SourceIndex |
Top
See Also

Reference

AssignSourceParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


AssignSourceParameters.Ids Property

AssignSourceParametersIds Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.AssignSourceParameters.Ids"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string[] Ids { get; init; }

Property Value

String
See Also

Reference

AssignSourceParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


AssignSourceParameters.SourceIndex Property

AssignSourceParametersSourceIndex Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.AssignSourceParameters.SourceIndex"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int SourceIndex { get; init; }

Property Value

Int32
See Also

Reference

AssignSourceParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BlobVDirMetaParameters Class

Request parameters for the ListBlobVDirMetadata API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOBlobVDirMetaParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class BlobVDirMetaParameters : IEquatable<BlobVDirMetaParameters>

The BlobVDirMetaParameters type exposes the following members.

Constructors
 | Name | Description
Public method | BlobVDirMetaParameters | Request parameters for the ListBlobVDirMetadata API method.
Top
Properties
 | Name | Description
Public property | VirtualDirPrefix |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


BlobVDirMetaParameters Constructor

Request parameters for the ListBlobVDirMetadata API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public BlobVDirMetaParameters(
    string VirtualDirPrefix
)

Parameters

VirtualDirPrefix String

[Missing <param name="VirtualDirPrefix"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BlobVDirMetaParameters.#ctor(System.String)"]

See Also

Reference

BlobVDirMetaParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BlobVDirMetaParameters Properties

The BlobVDirMetaParameters type exposes the following members.

Properties
 | Name | Description
Public property | VirtualDirPrefix |
Top
See Also

Reference

BlobVDirMetaParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BlobVDirMetaParameters.VirtualDirPrefix Property

BlobVDirMetaParametersVirtualDirPrefix Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BlobVDirMetaParameters.VirtualDirPrefix"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string VirtualDirPrefix { get; init; }

Property Value

String
See Also

Reference

BlobVDirMetaParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters Class

Request parameters for the BulkAssign API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOBulkAssignParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class BulkAssignParameters : IEquatable<BulkAssignParameters>

The BulkAssignParameters type exposes the following members.

Constructors
 | Name | Description
Public method | BulkAssignParameters | Request parameters for the BulkAssign API method.
Top
Properties
 | Name | Description
Public property | DocIds |
Public property | DoGenre |
Public property | DoLocation |
Public property | DoMedia |
Public property | DoOwner |
Public property | DoPublishYear |
Public property | DoTag |
Public property | Genre |
Public property | GenrePrimary |
Public property | Location |
Public property | Media |
Public property | Owner |
Public property | PublishYear |
Public property | Tag |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters Constructor

Request parameters for the BulkAssign API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public BulkAssignParameters(
    string[] DocIds,
    bool DoMedia,
    string Media,
    bool DoLocation,
    string Location,
    bool DoOwner,
    string Owner,
    bool DoGenre,
    string Genre,
    bool GenrePrimary,
    bool DoTag,
    string Tag,
    bool DoPublishYear,
    short? PublishYear
)

Parameters

DocIds String

[Missing <param name="DocIds"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

DoMedia Boolean

[Missing <param name="DoMedia"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

Media String

[Missing <param name="Media"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

DoLocation Boolean

[Missing <param name="DoLocation"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

Location String

[Missing <param name="Location"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

DoOwner Boolean

[Missing <param name="DoOwner"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

Owner String

[Missing <param name="Owner"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

DoGenre Boolean

[Missing <param name="DoGenre"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

Genre String

[Missing <param name="Genre"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

GenrePrimary Boolean

[Missing <param name="GenrePrimary"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

DoTag Boolean

[Missing <param name="DoTag"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

Tag String

[Missing <param name="Tag"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

DoPublishYear Boolean

[Missing <param name="DoPublishYear"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

PublishYear Nullable Int16

[Missing <param name="PublishYear"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.#ctor(System.String[],System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.String,System.Boolean,System.Boolean,System.String,System.Boolean,System.Nullable{System.Int16})"]

See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters Properties

The BulkAssignParameters type exposes the following members.

Properties
 | Name | Description
Public property | DocIds |
Public property | DoGenre |
Public property | DoLocation |
Public property | DoMedia |
Public property | DoOwner |
Public property | DoPublishYear |
Public property | DoTag |
Public property | Genre |
Public property | GenrePrimary |
Public property | Location |
Public property | Media |
Public property | Owner |
Public property | PublishYear |
Public property | Tag |
Top
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.DocIds Property

BulkAssignParametersDocIds Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.DocIds"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string[] DocIds { get; init; }

Property Value

String
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.DoGenre Property

BulkAssignParametersDoGenre Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.DoGenre"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool DoGenre { get; init; }

Property Value

Boolean
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.DoLocation Property

BulkAssignParametersDoLocation Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.DoLocation"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool DoLocation { get; init; }

Property Value

Boolean
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.DoMedia Property

BulkAssignParametersDoMedia Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.DoMedia"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool DoMedia { get; init; }

Property Value

Boolean
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.DoOwner Property

BulkAssignParametersDoOwner Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.DoOwner"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool DoOwner { get; init; }

Property Value

Boolean
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.DoPublishYear Property

BulkAssignParametersDoPublishYear Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.DoPublishYear"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool DoPublishYear { get; init; }

Property Value

Boolean
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.DoTag Property

BulkAssignParametersDoTag Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.DoTag"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool DoTag { get; init; }

Property Value

Boolean
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.Genre Property

BulkAssignParametersGenre Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.Genre"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Genre { get; init; }

Property Value

String
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.GenrePrimary Property

BulkAssignParametersGenrePrimary Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.GenrePrimary"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool GenrePrimary { get; init; }

Property Value

Boolean
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.Location Property

BulkAssignParametersLocation Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.Location"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Location { get; init; }

Property Value

String
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.Media Property

BulkAssignParametersMedia Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.Media"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Media { get; init; }

Property Value

String
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.Owner Property

BulkAssignParametersOwner Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.Owner"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Owner { get; init; }

Property Value

String
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.PublishYear Property

BulkAssignParametersPublishYear Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.PublishYear"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? PublishYear { get; init; }

Property Value

Nullable Int16
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


BulkAssignParameters.Tag Property

BulkAssignParametersTag Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.BulkAssignParameters.Tag"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Tag { get; init; }

Property Value

String
See Also

Reference

BulkAssignParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary Class

Response from the GetDatabaseSummary API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTODatabaseSummary

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public class DatabaseSummary

The DatabaseSummary type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseSummary | Initializes a new instance of the DatabaseSummary class
Top
Properties
 | Name | Description
Public property | ContributorCount |
Public property | ContributorDistinctCount |
Public property | DiscardedCount |
Public property | FileCount |
Public property | GenreTally |
Public property | HiddenCount |
Public property | LocationTally |
Public property | MediaTally |
Public property | OwnerMediaXref |
Public property | OwnerTally |
Public property | PictureCount |
Public property | PictureDistinctCount |
Public property | RoleTally |
Public property | TagTally |
Public property | TitleCount |
Public property | TrackCount |
Public property | UnusedGenres |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary Constructor

Initializes a new instance of the DatabaseSummary class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DatabaseSummary()
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary Properties

The DatabaseSummary type exposes the following members.

Properties
 | Name | Description
Public property | ContributorCount |
Public property | ContributorDistinctCount |
Public property | DiscardedCount |
Public property | FileCount |
Public property | GenreTally |
Public property | HiddenCount |
Public property | LocationTally |
Public property | MediaTally |
Public property | OwnerMediaXref |
Public property | OwnerTally |
Public property | PictureCount |
Public property | PictureDistinctCount |
Public property | RoleTally |
Public property | TagTally |
Public property | TitleCount |
Public property | TrackCount |
Public property | UnusedGenres |
Top
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.ContributorCount Property

DatabaseSummaryContributorCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.ContributorCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int ContributorCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.ContributorDistinctCount Property

DatabaseSummaryContributorDistinctCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.ContributorDistinctCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int ContributorDistinctCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.DiscardedCount Property

DatabaseSummaryDiscardedCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.DiscardedCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int DiscardedCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.FileCount Property

DatabaseSummaryFileCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.FileCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int FileCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.GenreTally Property

DatabaseSummaryGenreTally Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.GenreTally"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SummaryTally[] GenreTally { get; set; }

Property Value

SummaryTally
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.HiddenCount Property

DatabaseSummaryHiddenCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.HiddenCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int HiddenCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.LocationTally Property

DatabaseSummaryLocationTally Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.LocationTally"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SummaryTally[] LocationTally { get; set; }

Property Value

SummaryTally
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.MediaTally Property

DatabaseSummaryMediaTally Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.MediaTally"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SummaryTally[] MediaTally { get; set; }

Property Value

SummaryTally
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.OwnerMediaXref Property

DatabaseSummaryOwnerMediaXref Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.OwnerMediaXref"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public XrefItem[] OwnerMediaXref { get; set; }

Property Value

XrefItem
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.OwnerTally Property

DatabaseSummaryOwnerTally Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.OwnerTally"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SummaryTally[] OwnerTally { get; set; }

Property Value

SummaryTally
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.PictureCount Property

DatabaseSummaryPictureCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.PictureCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int PictureCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.PictureDistinctCount Property

DatabaseSummaryPictureDistinctCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.PictureDistinctCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int PictureDistinctCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.RoleTally Property

DatabaseSummaryRoleTally Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.RoleTally"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SummaryTally[] RoleTally { get; set; }

Property Value

SummaryTally
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.TagTally Property

DatabaseSummaryTagTally Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.TagTally"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SummaryTally[] TagTally { get; set; }

Property Value

SummaryTally
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.TitleCount Property

DatabaseSummaryTitleCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.TitleCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int TitleCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.TrackCount Property

DatabaseSummaryTrackCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.TrackCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int TrackCount { get; set; }

Property Value

Int32
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.UnusedGenres Property

DatabaseSummaryUnusedGenres Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.UnusedGenres"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string[] UnusedGenres { get; set; }

Property Value

String
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary Methods

The DatabaseSummary type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DatabaseSummary.ToString Method

DatabaseSummaryToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.DatabaseSummary.ToString"]

See Also

Reference

DatabaseSummary Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats Class

Response from the GetDatabaseStats API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTODbQueryStats

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class DbQueryStats

The DbQueryStats type exposes the following members.

Constructors
 | Name | Description
Public method | DbQueryStats | Initializes a new instance of the DbQueryStats class
Top
Properties
 | Name | Description
Public property | ActivityId |
Public property | Charge |
Public property | CollSize |
Public property | ContinuationToken |
Public property | DocCount |
Public property | Method |
Public property | Query |
Public property | Sequence |
Public property | Time |
Public property | Uri |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats Constructor

Initializes a new instance of the DbQueryStats class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DbQueryStats()
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats Properties

The DbQueryStats type exposes the following members.

Properties
 | Name | Description
Public property | ActivityId |
Public property | Charge |
Public property | CollSize |
Public property | ContinuationToken |
Public property | DocCount |
Public property | Method |
Public property | Query |
Public property | Sequence |
Public property | Time |
Public property | Uri |
Top
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.ActivityId Property

DbQueryStatsActivityId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.ActivityId"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Guid ActivityId { get; set; }

Property Value

Guid
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.Charge Property

DbQueryStatsCharge Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.Charge"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public double Charge { get; set; }

Property Value

Double
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.CollSize Property

DbQueryStatsCollSize Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.CollSize"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int CollSize { get; set; }

Property Value

Int32
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.ContinuationToken Property

DbQueryStatsContinuationToken Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.ContinuationToken"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string ContinuationToken { get; set; }

Property Value

String
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.DocCount Property

DbQueryStatsDocCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.DocCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int DocCount { get; set; }

Property Value

Int32
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.Method Property

DbQueryStatsMethod Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.Method"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Method { get; set; }

Property Value

String
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.Query Property

DbQueryStatsQuery Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.Query"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Query { get; set; }

Property Value

String
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.Sequence Property

DbQueryStatsSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.Sequence"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Sequence { get; set; }

Property Value

Int32
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.Time Property

DbQueryStatsTime Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.Time"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime Time { get; set; }

Property Value

DateTime
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.Uri Property

DbQueryStatsUri Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.Uri"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Uri { get; set; }

Property Value

String
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats Methods

The DbQueryStats type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DbQueryStats.ToString Method

DbQueryStatsToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.DbQueryStats.ToString"]

See Also

Reference

DbQueryStats Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DeletePictureBlobParameters Class

Request parameters for the DeletePictureBlobAsync API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTODeletePictureBlobParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class DeletePictureBlobParameters : IEquatable<DeletePictureBlobParameters>

The DeletePictureBlobParameters type exposes the following members.

Constructors
 | Name | Description
Public method | DeletePictureBlobParameters | Request parameters for the DeletePictureBlobAsync API method.
Top
Properties
 | Name | Description
Public property | BlobName |
Public property | IsThumbnail |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


DeletePictureBlobParameters Constructor

Request parameters for the DeletePictureBlobAsync API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DeletePictureBlobParameters(
    string BlobName,
    bool IsThumbnail
)

Parameters

BlobName String

[Missing <param name="BlobName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.DeletePictureBlobParameters.#ctor(System.String,System.Boolean)"]

IsThumbnail Boolean

[Missing <param name="IsThumbnail"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.DeletePictureBlobParameters.#ctor(System.String,System.Boolean)"]

See Also

Reference

DeletePictureBlobParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DeletePictureBlobParameters Properties

The DeletePictureBlobParameters type exposes the following members.

Properties
 | Name | Description
Public property | BlobName |
Public property | IsThumbnail |
Top
See Also

Reference

DeletePictureBlobParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DeletePictureBlobParameters.BlobName Property

DeletePictureBlobParametersBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DeletePictureBlobParameters.BlobName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string BlobName { get; init; }

Property Value

String
See Also

Reference

DeletePictureBlobParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


DeletePictureBlobParameters.IsThumbnail Property

DeletePictureBlobParametersIsThumbnail Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.DeletePictureBlobParameters.IsThumbnail"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsThumbnail { get; init; }

Property Value

Boolean
See Also

Reference

DeletePictureBlobParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoActor Class

Represents someone or something that is in a photo. The FotoProperties class contains a child collection PhotoActor.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOFotoActor

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class FotoActor : IEquatable<FotoActor>

The FotoActor type exposes the following members.

Constructors
 | Name | Description
Public method | FotoActor | Represents someone or something that is in a photo. The FotoProperties class contains a child collection PhotoActor.
Top
Properties
 | Name | Description
Public property | Group |
Public property | IsPrimary |
Public property | Name |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


FotoActor Constructor

Represents someone or something that is in a photo. The FotoProperties class contains a child collection PhotoActor.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FotoActor(
    string Name,
    bool IsPrimary,
    string Group
)

Parameters

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FotoActor.#ctor(System.String,System.Boolean,System.String)"]

IsPrimary Boolean

[Missing <param name="IsPrimary"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FotoActor.#ctor(System.String,System.Boolean,System.String)"]

Group String

[Missing <param name="Group"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FotoActor.#ctor(System.String,System.Boolean,System.String)"]

See Also

Reference

FotoActor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoActor Properties

The FotoActor type exposes the following members.

Properties
 | Name | Description
Public property | Group |
Public property | IsPrimary |
Public property | Name |
Top
See Also

Reference

FotoActor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoActor.Group Property

FotoActorGroup Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoActor.Group"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Group { get; init; }

Property Value

String
See Also

Reference

FotoActor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoActor.IsPrimary Property

FotoActorIsPrimary Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoActor.IsPrimary"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsPrimary { get; init; }

Property Value

Boolean
See Also

Reference

FotoActor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoActor.Name Property

FotoActorName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoActor.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

FotoActor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties Class

Encapsulates all of the photo information that can be associated with either Blob metadata or File properties.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOFotoProperties

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public class FotoProperties

The FotoProperties type exposes the following members.

Constructors
 | Name | Description
Public method | FotoProperties | Initializes a new instance of the FotoProperties class
Top
Properties
 | Name | Description
Public property | Actors |
Public property | Altitude |
Public property | Caption |
Public property | Comment |
Public property | Created |
Public property | ExifAperture |
Public property | ExifExposureProg |
Public property | ExifExposureTime |
Public property | ExifFlash |
Public property | ExifFNumber |
Public property | ExifFocalLength |
Public property | ExifFocalResUnit |
Public property | ExifFocalXRes |
Public property | ExifFocalYRes |
Public property | ExifISOSpeed |
Public property | ExifShutterSpeed |
Public property | FileOrBlobName |
Public property | GPS |
Public property | Height |
Public property | IsFrozen |
Public property | IsPublic |
Public property | LastModified |
Public property | LegacyKey |
Public property | Length |
Public property | Make |
Public property | Md5 |
Public property | Model |
Public property | Orientation |
Public property | Rotate |
Public property | Taken |
Public property | Type |
Public property | Width |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties Constructor

Initializes a new instance of the FotoProperties class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FotoProperties()
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties Properties

The FotoProperties type exposes the following members.

Properties
 | Name | Description
Public property | Actors |
Public property | Altitude |
Public property | Caption |
Public property | Comment |
Public property | Created |
Public property | ExifAperture |
Public property | ExifExposureProg |
Public property | ExifExposureTime |
Public property | ExifFlash |
Public property | ExifFNumber |
Public property | ExifFocalLength |
Public property | ExifFocalResUnit |
Public property | ExifFocalXRes |
Public property | ExifFocalYRes |
Public property | ExifISOSpeed |
Public property | ExifShutterSpeed |
Public property | FileOrBlobName |
Public property | GPS |
Public property | Height |
Public property | IsFrozen |
Public property | IsPublic |
Public property | LastModified |
Public property | LegacyKey |
Public property | Length |
Public property | Make |
Public property | Md5 |
Public property | Model |
Public property | Orientation |
Public property | Rotate |
Public property | Taken |
Public property | Type |
Public property | Width |
Top
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Actors Property

FotoPropertiesActors Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Actors"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FotoActor[] Actors { get; set; }

Property Value

FotoActor
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Altitude Property

FotoPropertiesAltitude Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Altitude"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public double? Altitude { get; set; }

Property Value

Nullable Double
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Caption Property

FotoPropertiesCaption Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Caption"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Caption { get; set; }

Property Value

String
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Comment Property

FotoPropertiesComment Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Comment"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

String
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Created Property

FotoPropertiesCreated Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Created"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? Created { get; set; }

Property Value

Nullable DateTime
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifAperture Property

FotoPropertiesExifAperture Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifAperture"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public double? ExifAperture { get; set; }

Property Value

Nullable Double
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifExposureProg Property

FotoPropertiesExifExposureProg Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifExposureProg"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? ExifExposureProg { get; set; }

Property Value

Nullable Int16
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifExposureTime Property

FotoPropertiesExifExposureTime Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifExposureTime"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public double? ExifExposureTime { get; set; }

Property Value

Nullable Double
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifFlash Property

FotoPropertiesExifFlash Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifFlash"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? ExifFlash { get; set; }

Property Value

Nullable Int16
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifFNumber Property

FotoPropertiesExifFNumber Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifFNumber"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public double? ExifFNumber { get; set; }

Property Value

Nullable Double
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifFocalLength Property

FotoPropertiesExifFocalLength Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifFocalLength"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public double? ExifFocalLength { get; set; }

Property Value

Nullable Double
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifFocalResUnit Property

FotoPropertiesExifFocalResUnit Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifFocalResUnit"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? ExifFocalResUnit { get; set; }

Property Value

Nullable Int16
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifFocalXRes Property

FotoPropertiesExifFocalXRes Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifFocalXRes"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public float? ExifFocalXRes { get; set; }

Property Value

Nullable Single
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifFocalYRes Property

FotoPropertiesExifFocalYRes Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifFocalYRes"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public float? ExifFocalYRes { get; set; }

Property Value

Nullable Single
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifISOSpeed Property

FotoPropertiesExifISOSpeed Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifISOSpeed"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? ExifISOSpeed { get; set; }

Property Value

Nullable Int16
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.ExifShutterSpeed Property

FotoPropertiesExifShutterSpeed Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.ExifShutterSpeed"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public double? ExifShutterSpeed { get; set; }

Property Value

Nullable Double
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.FileOrBlobName Property

FotoPropertiesFileOrBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.FileOrBlobName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string FileOrBlobName { get; set; }

Property Value

String
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.GPS Property

FotoPropertiesGPS Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.GPS"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string GPS { get; set; }

Property Value

String
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Height Property

FotoPropertiesHeight Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Height"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Height { get; set; }

Property Value

Nullable Int32
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.IsFrozen Property

FotoPropertiesIsFrozen Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.IsFrozen"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool? IsFrozen { get; set; }

Property Value

Nullable Boolean
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.IsPublic Property

FotoPropertiesIsPublic Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.IsPublic"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool? IsPublic { get; set; }

Property Value

Nullable Boolean
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.LastModified Property

FotoPropertiesLastModified Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.LastModified"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? LastModified { get; set; }

Property Value

Nullable DateTime
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.LegacyKey Property

FotoPropertiesLegacyKey Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.LegacyKey"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string LegacyKey { get; set; }

Property Value

String
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Length Property

FotoPropertiesLength Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Length"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public long? Length { get; set; }

Property Value

Nullable Int64
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Make Property

FotoPropertiesMake Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Make"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Make { get; set; }

Property Value

String
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Md5 Property

FotoPropertiesMd5 Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Md5"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Guid? Md5 { get; set; }

Property Value

Nullable Guid
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Model Property

FotoPropertiesModel Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Model"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Model { get; set; }

Property Value

String
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Orientation Property

FotoPropertiesOrientation Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Orientation"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? Orientation { get; set; }

Property Value

Nullable Int16
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Rotate Property

FotoPropertiesRotate Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Rotate"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? Rotate { get; set; }

Property Value

Nullable Int16
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Taken Property

FotoPropertiesTaken Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Taken"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? Taken { get; set; }

Property Value

Nullable DateTime
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Type Property

FotoPropertiesType Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Type"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Type { get; set; }

Property Value

String
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FotoProperties.Width Property

FotoPropertiesWidth Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FotoProperties.Width"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Width { get; set; }

Property Value

Nullable Int32
See Also

Reference

FotoProperties Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundContributor Class

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundContributor.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOFoundContributor

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class FoundContributor : IEquatable<FoundContributor>

The FoundContributor type exposes the following members.

Constructors
 | Name | Description
Public method | FoundContributor | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundContributor.
Top
Properties
 | Name | Description
Public property | Name |
Public property | Role |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


FoundContributor Constructor

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundContributor.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundContributor(
    string Name,
    string Role
)

Parameters

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundContributor.#ctor(System.String,System.String)"]

Role String

[Missing <param name="Role"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundContributor.#ctor(System.String,System.String)"]

See Also

Reference

FoundContributor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundContributor Properties

The FoundContributor type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Role |
Top
See Also

Reference

FoundContributor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundContributor.Name Property

FoundContributorName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundContributor.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

FoundContributor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundContributor.Role Property

FoundContributorRole Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundContributor.Role"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Role { get; init; }

Property Value

String
See Also

Reference

FoundContributor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile Class

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundFile.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOFoundFile

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class FoundFile : IEquatable<FoundFile>

The FoundFile type exposes the following members.

Constructors
 | Name | Description
Public method | FoundFile | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundFile.
Top
Properties
 | Name | Description
Public property | Fullname |
Public property | Id |
Public property | Length |
Public property | Media |
Public property | Part |
Public property | TitleName |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile Constructor

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundFile.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundFile(
    string Id,
    string TitleName,
    string Media,
    int? Part,
    string Fullname,
    long? Length
)

Parameters

Id String

[Missing <param name="Id"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundFile.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int64})"]

TitleName String

[Missing <param name="TitleName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundFile.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int64})"]

Media String

[Missing <param name="Media"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundFile.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int64})"]

Part Nullable Int32

[Missing <param name="Part"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundFile.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int64})"]

Fullname String

[Missing <param name="Fullname"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundFile.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int64})"]

Length Nullable Int64

[Missing <param name="Length"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundFile.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int64})"]

See Also

Reference

FoundFile Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile Properties

The FoundFile type exposes the following members.

Properties
 | Name | Description
Public property | Fullname |
Public property | Id |
Public property | Length |
Public property | Media |
Public property | Part |
Public property | TitleName |
Top
See Also

Reference

FoundFile Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile.Fullname Property

FoundFileFullname Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundFile.Fullname"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Fullname { get; init; }

Property Value

String
See Also

Reference

FoundFile Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile.Id Property

FoundFileId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundFile.Id"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Id { get; init; }

Property Value

String
See Also

Reference

FoundFile Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile.Length Property

FoundFileLength Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundFile.Length"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public long? Length { get; init; }

Property Value

Nullable Int64
See Also

Reference

FoundFile Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile.Media Property

FoundFileMedia Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundFile.Media"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Media { get; init; }

Property Value

String
See Also

Reference

FoundFile Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile.Part Property

FoundFilePart Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundFile.Part"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Part { get; init; }

Property Value

Nullable Int32
See Also

Reference

FoundFile Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundFile.TitleName Property

FoundFileTitleName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundFile.TitleName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string TitleName { get; init; }

Property Value

String
See Also

Reference

FoundFile Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundPicture Class

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundPicture.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOFoundPicture

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class FoundPicture : IEquatable<FoundPicture>

The FoundPicture type exposes the following members.

Constructors
 | Name | Description
Public method | FoundPicture | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundPicture.
Top
Properties
 | Name | Description
Public property | BlobName |
Public property | IsPrimary |
Public property | Sequence |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


FoundPicture Constructor

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundPicture.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundPicture(
    string BlobName,
    bool? IsPrimary,
    int? Sequence
)

Parameters

BlobName String

[Missing <param name="BlobName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundPicture.#ctor(System.String,System.Nullable{System.Boolean},System.Nullable{System.Int32})"]

IsPrimary Nullable Boolean

[Missing <param name="IsPrimary"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundPicture.#ctor(System.String,System.Nullable{System.Boolean},System.Nullable{System.Int32})"]

Sequence Nullable Int32

[Missing <param name="Sequence"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundPicture.#ctor(System.String,System.Nullable{System.Boolean},System.Nullable{System.Int32})"]

See Also

Reference

FoundPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundPicture Properties

The FoundPicture type exposes the following members.

Properties
 | Name | Description
Public property | BlobName |
Public property | IsPrimary |
Public property | Sequence |
Top
See Also

Reference

FoundPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundPicture.BlobName Property

FoundPictureBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundPicture.BlobName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string BlobName { get; init; }

Property Value

String
See Also

Reference

FoundPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundPicture.IsPrimary Property

FoundPictureIsPrimary Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundPicture.IsPrimary"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool? IsPrimary { get; init; }

Property Value

Nullable Boolean
See Also

Reference

FoundPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundPicture.Sequence Property

FoundPictureSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundPicture.Sequence"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Sequence { get; init; }

Property Value

Nullable Int32
See Also

Reference

FoundPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle Class

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundTitle.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOFoundTitle

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class FoundTitle : IEquatable<FoundTitle>

The FoundTitle type exposes the following members.

Constructors
 | Name | Description
Public method | FoundTitle | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundTitle.
Top
Properties
 | Name | Description
Public property | Catalog |
Public property | Created |
Public property | EditionYear |
Public property | Id |
Public property | IsHidden |
Public property | Location |
Public property | Media |
Public property | Name |
Public property | Owner |
Public property | PublishYear |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle Constructor

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundTitle.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundTitle(
    string Id,
    DateTime Created,
    string Name,
    string Media,
    string Location,
    string Owner,
    string Catalog,
    short? PublishYear,
    short? EditionYear,
    bool IsHidden
)

Parameters

Id String

[Missing <param name="Id"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

Created DateTime

[Missing <param name="Created"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

Media String

[Missing <param name="Media"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

Location String

[Missing <param name="Location"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

Owner String

[Missing <param name="Owner"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

Catalog String

[Missing <param name="Catalog"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

PublishYear Nullable Int16

[Missing <param name="PublishYear"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

EditionYear Nullable Int16

[Missing <param name="EditionYear"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

IsHidden Boolean

[Missing <param name="IsHidden"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.#ctor(System.String,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Int16},System.Nullable{System.Int16},System.Boolean)"]

See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle Properties

The FoundTitle type exposes the following members.

Properties
 | Name | Description
Public property | Catalog |
Public property | Created |
Public property | EditionYear |
Public property | Id |
Public property | IsHidden |
Public property | Location |
Public property | Media |
Public property | Name |
Public property | Owner |
Public property | PublishYear |
Top
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.Catalog Property

FoundTitleCatalog Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.Catalog"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Catalog { get; init; }

Property Value

String
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.Created Property

FoundTitleCreated Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.Created"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime Created { get; init; }

Property Value

DateTime
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.EditionYear Property

FoundTitleEditionYear Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.EditionYear"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? EditionYear { get; init; }

Property Value

Nullable Int16
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.Id Property

FoundTitleId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.Id"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Id { get; init; }

Property Value

String
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.IsHidden Property

FoundTitleIsHidden Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.IsHidden"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsHidden { get; init; }

Property Value

Boolean
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.Location Property

FoundTitleLocation Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.Location"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Location { get; init; }

Property Value

String
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.Media Property

FoundTitleMedia Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.Media"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Media { get; init; }

Property Value

String
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.Name Property

FoundTitleName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.Owner Property

FoundTitleOwner Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.Owner"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Owner { get; init; }

Property Value

String
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTitle.PublishYear Property

FoundTitlePublishYear Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTitle.PublishYear"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? PublishYear { get; init; }

Property Value

Nullable Int16
See Also

Reference

FoundTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack Class

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundTrack.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOFoundTrack

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class FoundTrack : IEquatable<FoundTrack>

The FoundTrack type exposes the following members.

Constructors
 | Name | Description
Public method | FoundTrack | Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundTrack.
Top
Properties
 | Name | Description
Public property | Id |
Public property | Media |
Public property | Name |
Public property | Part |
Public property | Seconds |
Public property | Sequence |
Public property | Side |
Public property | TitleName |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack Constructor

Response child class from the GlobalNameSearch API method. The SearchResults class contains a collection of FoundTrack.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundTrack(
    string Id,
    string TitleName,
    string Media,
    int? Part,
    string Side,
    int? Sequence,
    string Name,
    int? Seconds
)

Parameters

Id String

[Missing <param name="Id"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32})"]

TitleName String

[Missing <param name="TitleName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32})"]

Media String

[Missing <param name="Media"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32})"]

Part Nullable Int32

[Missing <param name="Part"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32})"]

Side String

[Missing <param name="Side"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32})"]

Sequence Nullable Int32

[Missing <param name="Sequence"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32})"]

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32})"]

Seconds Nullable Int32

[Missing <param name="Seconds"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.#ctor(System.String,System.String,System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32},System.String,System.Nullable{System.Int32})"]

See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack Properties

The FoundTrack type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Media |
Public property | Name |
Public property | Part |
Public property | Seconds |
Public property | Sequence |
Public property | Side |
Public property | TitleName |
Top
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack.Id Property

FoundTrackId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.Id"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Id { get; init; }

Property Value

String
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack.Media Property

FoundTrackMedia Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.Media"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Media { get; init; }

Property Value

String
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack.Name Property

FoundTrackName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack.Part Property

FoundTrackPart Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.Part"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Part { get; init; }

Property Value

Nullable Int32
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack.Seconds Property

FoundTrackSeconds Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.Seconds"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Seconds { get; init; }

Property Value

Nullable Int32
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack.Sequence Property

FoundTrackSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.Sequence"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Sequence { get; init; }

Property Value

Nullable Int32
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack.Side Property

FoundTrackSide Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.Side"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Side { get; init; }

Property Value

String
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


FoundTrack.TitleName Property

FoundTrackTitleName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.FoundTrack.TitleName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string TitleName { get; init; }

Property Value

String
See Also

Reference

FoundTrack Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertContributor Class

Response from the ListContributorsInverted API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOInvertContributor

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class InvertContributor : IEquatable<InvertContributor>

The InvertContributor type exposes the following members.

Constructors
 | Name | Description
Public method | InvertContributor | Response from the ListContributorsInverted API method.
Top
Properties
 | Name | Description
Public property | Name |
Public property | Titles |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


InvertContributor Constructor

Response from the ListContributorsInverted API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertContributor(
    string Name,
    InvertTitle[] Titles
)

Parameters

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertContributor.#ctor(System.String,Orthogonal.Hoarder.StdLib.DTO.InvertTitle[])"]

Titles InvertTitle

[Missing <param name="Titles"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertContributor.#ctor(System.String,Orthogonal.Hoarder.StdLib.DTO.InvertTitle[])"]

See Also

Reference

InvertContributor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertContributor Properties

The InvertContributor type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Titles |
Top
See Also

Reference

InvertContributor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertContributor.Name Property

InvertContributorName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertContributor.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

InvertContributor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertContributor.Titles Property

InvertContributorTitles Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertContributor.Titles"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertTitle[] Titles { get; init; }

Property Value

InvertTitle
See Also

Reference

InvertContributor Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle Class

Response child class from the ListPicturesInverted API method. The InvertPicTitle class contains a collection of InvertPicTitle.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOInvertPicTitle

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class InvertPicTitle

The InvertPicTitle type exposes the following members.

Constructors
 | Name | Description
Public method | InvertPicTitle | Initializes a new instance of the InvertPicTitle class
Public method | InvertPicTitle(String, String, Boolean, Boolean) | Initializes a new instance of the InvertPicTitle class
Top
Properties
 | Name | Description
Public property | Discarded |
Public property | Hidden |
Public property | Id |
Public property | Owner |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle Constructor

Overload List
 | Name | Description
Public method | InvertPicTitle | Initializes a new instance of the InvertPicTitle class
Public method | InvertPicTitle(String, String, Boolean, Boolean) | Initializes a new instance of the InvertPicTitle class
Top
See Also

Reference

InvertPicTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle Constructor

Initializes a new instance of the InvertPicTitle class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertPicTitle()
See Also

Reference

InvertPicTitle Class
InvertPicTitle Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle(String, String, Boolean, Boolean) Constructor

Initializes a new instance of the InvertPicTitle class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertPicTitle(
    string id,
    string owner,
    bool discarded,
    bool hidden
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.#ctor(System.String,System.String,System.Boolean,System.Boolean)"]

owner String

[Missing <param name="owner"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.#ctor(System.String,System.String,System.Boolean,System.Boolean)"]

discarded Boolean

[Missing <param name="discarded"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.#ctor(System.String,System.String,System.Boolean,System.Boolean)"]

hidden Boolean

[Missing <param name="hidden"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.#ctor(System.String,System.String,System.Boolean,System.Boolean)"]

See Also

Reference

InvertPicTitle Class
InvertPicTitle Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle Properties

The InvertPicTitle type exposes the following members.

Properties
 | Name | Description
Public property | Discarded |
Public property | Hidden |
Public property | Id |
Public property | Owner |
Top
See Also

Reference

InvertPicTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle.Discarded Property

InvertPicTitleDiscarded Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.Discarded"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Discarded { get; set; }

Property Value

Boolean
See Also

Reference

InvertPicTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle.Hidden Property

InvertPicTitleHidden Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.Hidden"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Hidden { get; set; }

Property Value

Boolean
See Also

Reference

InvertPicTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle.Id Property

InvertPicTitleId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.Id"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Id { get; set; }

Property Value

String
See Also

Reference

InvertPicTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle.Owner Property

InvertPicTitleOwner Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.Owner"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Owner { get; set; }

Property Value

String
See Also

Reference

InvertPicTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle Methods

The InvertPicTitle type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

InvertPicTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicTitle.ToString Method

InvertPicTitleToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle.ToString"]

See Also

Reference

InvertPicTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture Class

Response from the ListPicturesInverted API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOInvertPicture

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class InvertPicture

The InvertPicture type exposes the following members.

Constructors
 | Name | Description
Public method | InvertPicture | Initializes a new instance of the InvertPicture class
Public method | InvertPicture(String, IEnumerableInvertPicTitle) | Initializes a new instance of the InvertPicture class
Top
Properties
 | Name | Description
Public property | BlobName |
Public property | Titles |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture Constructor

Overload List
 | Name | Description
Public method | InvertPicture | Initializes a new instance of the InvertPicture class
Public method | InvertPicture(String, IEnumerableInvertPicTitle) | Initializes a new instance of the InvertPicture class
Top
See Also

Reference

InvertPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture Constructor

Initializes a new instance of the InvertPicture class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertPicture()
See Also

Reference

InvertPicture Class
InvertPicture Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture(String, IEnumerable<InvertPicTitle>) Constructor

InvertPicture(String, IEnumerableInvertPicTitle) Constructor

Initializes a new instance of the InvertPicture class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertPicture(
    string blobName,
    IEnumerable<InvertPicTitle> titles
)

Parameters

blobName String

[Missing <param name="blobName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicture.#ctor(System.String,System.Collections.Generic.IEnumerable{Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle})"]

titles IEnumerable InvertPicTitle

[Missing <param name="titles"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicture.#ctor(System.String,System.Collections.Generic.IEnumerable{Orthogonal.Hoarder.StdLib.DTO.InvertPicTitle})"]

See Also

Reference

InvertPicture Class
InvertPicture Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture Properties

The InvertPicture type exposes the following members.

Properties
 | Name | Description
Public property | BlobName |
Public property | Titles |
Top
See Also

Reference

InvertPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture.BlobName Property

InvertPictureBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertPicture.BlobName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string BlobName { get; set; }

Property Value

String
See Also

Reference

InvertPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture.Titles Property

InvertPictureTitles Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertPicture.Titles"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertPicTitle[] Titles { get; set; }

Property Value

InvertPicTitle
See Also

Reference

InvertPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture Methods

The InvertPicture type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

InvertPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertPicture.ToString Method

InvertPictureToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicture.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertPicture.ToString"]

See Also

Reference

InvertPicture Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertTitle Class

The InvertContributor class contains a collection of InvertTitle.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOInvertTitle

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class InvertTitle : IEquatable<InvertTitle>

The InvertTitle type exposes the following members.

Constructors
 | Name | Description
Public method | InvertTitle | The InvertContributor class contains a collection of InvertTitle.
Top
Properties
 | Name | Description
Public property | Id |
Public property | Media |
Public property | Name |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


InvertTitle Constructor

The InvertContributor class contains a collection of InvertTitle.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertTitle(
    string Id,
    string Name,
    string Media
)

Parameters

Id String

[Missing <param name="Id"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertTitle.#ctor(System.String,System.String,System.String)"]

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertTitle.#ctor(System.String,System.String,System.String)"]

Media String

[Missing <param name="Media"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.InvertTitle.#ctor(System.String,System.String,System.String)"]

See Also

Reference

InvertTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertTitle Properties

The InvertTitle type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Media |
Public property | Name |
Top
See Also

Reference

InvertTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertTitle.Id Property

InvertTitleId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertTitle.Id"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Id { get; init; }

Property Value

String
See Also

Reference

InvertTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertTitle.Media Property

InvertTitleMedia Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertTitle.Media"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Media { get; init; }

Property Value

String
See Also

Reference

InvertTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


InvertTitle.Name Property

InvertTitleName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.InvertTitle.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

InvertTitle Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters Class

Request parameter for the ListTitles and ListTitleItems API methods.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOListTitleParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class ListTitleParameters

The ListTitleParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ListTitleParameters | Initializes a new instance of the ListTitleParameters class
Public method | ListTitleParameters(String) | Initializes a new instance of the ListTitleParameters class
Public method | ListTitleParameters(NullableInt32, String) | Initializes a new instance of the ListTitleParameters class
Public method | ListTitleParameters(NullableInt32, String, NullableBoolean, String, String, String, String, String, String, String, NullableBoolean, NullableTitleSpecialFilter) | Initializes a new instance of the ListTitleParameters class
Top
Properties
 | Name | Description
Public property | Contributor |
 | Default |
Public property | Genre |
Public property | Location |
Public property | MatchTitleCase |
Public property | Max |
Public property | Media |
Public property | Name |
Public property | Owner |
Public property | Role |
Public property | ShowDiscarded |
Public property | SpecialFilter |
Public property | Summary |
Public property | Tag |
Top
Methods
 | Name | Description
Public method | GetHashCode | Overriden to return a meaningful instance hash code calculated from all of the property values. (Overrides ObjectGetHashCode)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters Constructor

Overload List
 | Name | Description
Public method | ListTitleParameters | Initializes a new instance of the ListTitleParameters class
Public method | ListTitleParameters(String) | Initializes a new instance of the ListTitleParameters class
Public method | ListTitleParameters(NullableInt32, String) | Initializes a new instance of the ListTitleParameters class
Public method | ListTitleParameters(NullableInt32, String, NullableBoolean, String, String, String, String, String, String, String, NullableBoolean, NullableTitleSpecialFilter) | Initializes a new instance of the ListTitleParameters class
Top
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters Constructor

Initializes a new instance of the ListTitleParameters class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ListTitleParameters()
See Also

Reference

ListTitleParameters Class
ListTitleParameters Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters(String) Constructor

Initializes a new instance of the ListTitleParameters class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ListTitleParameters(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.String)"]

See Also

Reference

ListTitleParameters Class
ListTitleParameters Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters(Nullable<Int32>, String) Constructor

ListTitleParameters(NullableInt32, String) Constructor

Initializes a new instance of the ListTitleParameters class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ListTitleParameters(
    int? max,
    string name
)

Parameters

max Nullable Int32

[Missing <param name="max"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String)"]

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String)"]

See Also

Reference

ListTitleParameters Class
ListTitleParameters Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters(Nullable<Int32>, String, Nullable<Boolean>, String, String, String, String, String, String, String, Nullable<Boolean>, Nullable<TitleSpecialFilter>) Constructor

ListTitleParameters(NullableInt32, String, NullableBoolean, String, String, String, String, String, String, String, NullableBoolean, NullableTitleSpecialFilter) Constructor

Initializes a new instance of the ListTitleParameters class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ListTitleParameters(
    int? max,
    string name,
    bool? matchTitleCase,
    string media,
    string location,
    string owner,
    string contributor,
    string tag,
    string genre,
    string role,
    bool? showDiscarded,
    TitleSpecialFilter? specialFilter
)

Parameters

max Nullable Int32

[Missing <param name="max"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

matchTitleCase Nullable Boolean

[Missing <param name="matchTitleCase"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

media String

[Missing <param name="media"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

location String

[Missing <param name="location"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

owner String

[Missing <param name="owner"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

contributor String

[Missing <param name="contributor"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

tag String

[Missing <param name="tag"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

genre String

[Missing <param name="genre"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

role String

[Missing <param name="role"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

showDiscarded Nullable Boolean

[Missing <param name="showDiscarded"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

specialFilter Nullable TitleSpecialFilter

[Missing <param name="specialFilter"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.#ctor(System.Nullable{System.Int32},System.String,System.Nullable{System.Boolean},System.String,System.String,System.String,System.String,System.String,System.String,System.String,System.Nullable{System.Boolean},System.Nullable{Orthogonal.Hoarder.StdLib.DTO.TitleSpecialFilter})"]

See Also

Reference

ListTitleParameters Class
ListTitleParameters Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters Properties

The ListTitleParameters type exposes the following members.

Properties
 | Name | Description
Public property | Contributor |
 | Default |
Public property | Genre |
Public property | Location |
Public property | MatchTitleCase |
Public property | Max |
Public property | Media |
Public property | Name |
Public property | Owner |
Public property | Role |
Public property | ShowDiscarded |
Public property | SpecialFilter |
Public property | Summary |
Public property | Tag |
Top
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Contributor Property

ListTitleParametersContributor Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Contributor"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Contributor { get; set; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Default Property

ListTitleParametersDefault Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Default"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static ListTitleParameters Default { get; }

Property Value

ListTitleParameters
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Genre Property

ListTitleParametersGenre Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Genre"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Genre { get; set; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Location Property

ListTitleParametersLocation Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Location"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Location { get; set; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.MatchTitleCase Property

ListTitleParametersMatchTitleCase Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.MatchTitleCase"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool? MatchTitleCase { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Max Property

ListTitleParametersMax Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Max"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Max { get; set; }

Property Value

Nullable Int32
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Media Property

ListTitleParametersMedia Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Media"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Media { get; set; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Name Property

ListTitleParametersName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Owner Property

ListTitleParametersOwner Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Owner"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Owner { get; set; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Role Property

ListTitleParametersRole Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Role"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Role { get; set; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.ShowDiscarded Property

ListTitleParametersShowDiscarded Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.ShowDiscarded"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool? ShowDiscarded { get; set; }

Property Value

Nullable Boolean
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.SpecialFilter Property

ListTitleParametersSpecialFilter Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.SpecialFilter"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public TitleSpecialFilter? SpecialFilter { get; set; }

Property Value

Nullable TitleSpecialFilter
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Summary Property

ListTitleParametersSummary Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Summary"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Summary { get; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.Tag Property

ListTitleParametersTag Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.Tag"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Tag { get; set; }

Property Value

String
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters Methods

The ListTitleParameters type exposes the following members.

Methods
 | Name | Description
Public method | GetHashCode | Overriden to return a meaningful instance hash code calculated from all of the property values. (Overrides ObjectGetHashCode)
Top
See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ListTitleParameters.GetHashCode Method

ListTitleParametersGetHashCode Method

Overriden to return a meaningful instance hash code calculated from all of the property values.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ListTitleParameters.GetHashCode"]

See Also

Reference

ListTitleParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


MetaItem Class

Response from the GetMetadata API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOMetaItem

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class MetaItem : IEquatable<MetaItem>

The MetaItem type exposes the following members.

Constructors
 | Name | Description
Public method | MetaItem | Response from the GetMetadata API method.
Top
Properties
 | Name | Description
Public property | Key |
Public property | Value |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


MetaItem Constructor

Response from the GetMetadata API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public MetaItem(
    string Key,
    string? Value
)

Parameters

Key String

[Missing <param name="Key"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.MetaItem.#ctor(System.String,System.String)"]

Value String

[Missing <param name="Value"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.MetaItem.#ctor(System.String,System.String)"]

See Also

Reference

MetaItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


MetaItem Properties

The MetaItem type exposes the following members.

Properties
 | Name | Description
Public property | Key |
Public property | Value |
Top
See Also

Reference

MetaItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


MetaItem.Key Property

MetaItemKey Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.MetaItem.Key"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Key { get; init; }

Property Value

String
See Also

Reference

MetaItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


MetaItem.Value Property

MetaItemValue Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.MetaItem.Value"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string? Value { get; init; }

Property Value

String
See Also

Reference

MetaItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


NameListParameters Class

Request parameter for the ListTitlesByContributorName and ListTitlesByPictureBlobName API methods.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTONameListParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class NameListParameters : IEquatable<NameListParameters>

The NameListParameters type exposes the following members.

Constructors
 | Name | Description
Public method | NameListParameters | Request parameter for the ListTitlesByContributorName and ListTitlesByPictureBlobName API methods.
Top
Properties
 | Name | Description
Public property | Name |
Public property | ShowDiscarded |
Public property | Top |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


NameListParameters Constructor

Request parameter for the ListTitlesByContributorName and ListTitlesByPictureBlobName API methods.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public NameListParameters(
    string Name,
    bool ShowDiscarded,
    int? Top = null
)

Parameters

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.NameListParameters.#ctor(System.String,System.Boolean,System.Nullable{System.Int32})"]

ShowDiscarded Boolean

[Missing <param name="ShowDiscarded"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.NameListParameters.#ctor(System.String,System.Boolean,System.Nullable{System.Int32})"]

Top Nullable Int32 (Optional)

[Missing <param name="Top"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.NameListParameters.#ctor(System.String,System.Boolean,System.Nullable{System.Int32})"]

See Also

Reference

NameListParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


NameListParameters Properties

The NameListParameters type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | ShowDiscarded |
Public property | Top |
Top
See Also

Reference

NameListParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


NameListParameters.Name Property

NameListParametersName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.NameListParameters.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

NameListParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


NameListParameters.ShowDiscarded Property

NameListParametersShowDiscarded Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.NameListParameters.ShowDiscarded"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool ShowDiscarded { get; init; }

Property Value

Boolean
See Also

Reference

NameListParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


NameListParameters.Top Property

NameListParametersTop Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.NameListParameters.Top"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Top { get; init; }

Property Value

Nullable Int32
See Also

Reference

NameListParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort Class

Response from the ListPicMetaShort API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOPicMetaShort

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class PicMetaShort : IEquatable<PicMetaShort>

The PicMetaShort type exposes the following members.

Constructors
 | Name | Description
Public method | PicMetaShort | Response from the ListPicMetaShort API method.
Top
Properties
 | Name | Description
Public property | Caption |
Public property | Height |
Public property | IsPublic |
Public property | LastModified |
Public property | Length |
Public property | Name |
Public property | Rotate |
Public property | Width |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort Constructor

Response from the ListPicMetaShort API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public PicMetaShort(
    string Name,
    string Caption,
    bool? IsPublic,
    short? Rotate,
    DateTime? LastModified,
    int? Width,
    int? Height,
    long? Length
)

Parameters

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.#ctor(System.String,System.String,System.Nullable{System.Boolean},System.Nullable{System.Int16},System.Nullable{System.DateTime},System.Nullable{System.Int32},System.Nullable{System.Int32},System.Nullable{System.Int64})"]

Caption String

[Missing <param name="Caption"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.#ctor(System.String,System.String,System.Nullable{System.Boolean},System.Nullable{System.Int16},System.Nullable{System.DateTime},System.Nullable{System.Int32},System.Nullable{System.Int32},System.Nullable{System.Int64})"]

IsPublic Nullable Boolean

[Missing <param name="IsPublic"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.#ctor(System.String,System.String,System.Nullable{System.Boolean},System.Nullable{System.Int16},System.Nullable{System.DateTime},System.Nullable{System.Int32},System.Nullable{System.Int32},System.Nullable{System.Int64})"]

Rotate Nullable Int16

[Missing <param name="Rotate"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.#ctor(System.String,System.String,System.Nullable{System.Boolean},System.Nullable{System.Int16},System.Nullable{System.DateTime},System.Nullable{System.Int32},System.Nullable{System.Int32},System.Nullable{System.Int64})"]

LastModified Nullable DateTime

[Missing <param name="LastModified"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.#ctor(System.String,System.String,System.Nullable{System.Boolean},System.Nullable{System.Int16},System.Nullable{System.DateTime},System.Nullable{System.Int32},System.Nullable{System.Int32},System.Nullable{System.Int64})"]

Width Nullable Int32

[Missing <param name="Width"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.#ctor(System.String,System.String,System.Nullable{System.Boolean},System.Nullable{System.Int16},System.Nullable{System.DateTime},System.Nullable{System.Int32},System.Nullable{System.Int32},System.Nullable{System.Int64})"]

Height Nullable Int32

[Missing <param name="Height"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.#ctor(System.String,System.String,System.Nullable{System.Boolean},System.Nullable{System.Int16},System.Nullable{System.DateTime},System.Nullable{System.Int32},System.Nullable{System.Int32},System.Nullable{System.Int64})"]

Length Nullable Int64

[Missing <param name="Length"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.#ctor(System.String,System.String,System.Nullable{System.Boolean},System.Nullable{System.Int16},System.Nullable{System.DateTime},System.Nullable{System.Int32},System.Nullable{System.Int32},System.Nullable{System.Int64})"]

See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort Properties

The PicMetaShort type exposes the following members.

Properties
 | Name | Description
Public property | Caption |
Public property | Height |
Public property | IsPublic |
Public property | LastModified |
Public property | Length |
Public property | Name |
Public property | Rotate |
Public property | Width |
Top
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort.Caption Property

PicMetaShortCaption Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.Caption"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Caption { get; init; }

Property Value

String
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort.Height Property

PicMetaShortHeight Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.Height"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Height { get; init; }

Property Value

Nullable Int32
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort.IsPublic Property

PicMetaShortIsPublic Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.IsPublic"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool? IsPublic { get; init; }

Property Value

Nullable Boolean
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort.LastModified Property

PicMetaShortLastModified Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.LastModified"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? LastModified { get; init; }

Property Value

Nullable DateTime
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort.Length Property

PicMetaShortLength Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.Length"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public long? Length { get; init; }

Property Value

Nullable Int64
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort.Name Property

PicMetaShortName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort.Rotate Property

PicMetaShortRotate Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.Rotate"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? Rotate { get; init; }

Property Value

Nullable Int16
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicMetaShort.Width Property

PicMetaShortWidth Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicMetaShort.Width"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Width { get; init; }

Property Value

Nullable Int32
See Also

Reference

PicMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicUploadParameters Class

Request parameter for the UploadPictureAsync API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOPicUploadParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class PicUploadParameters : IEquatable<PicUploadParameters>

The PicUploadParameters type exposes the following members.

Constructors
 | Name | Description
Public method | PicUploadParameters | Request parameter for the UploadPictureAsync API method.
Top
Properties
 | Name | Description
Public property | BlobName |
Public property | Data |
Public property | IsThumbnail |
Public property | Properties |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


PicUploadParameters Constructor

Request parameter for the UploadPictureAsync API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public PicUploadParameters(
    string BlobName,
    byte[] Data,
    bool IsThumbnail,
    FotoProperties? Properties
)

Parameters

BlobName String

[Missing <param name="BlobName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicUploadParameters.#ctor(System.String,System.Byte[],System.Boolean,Orthogonal.Hoarder.StdLib.DTO.FotoProperties)"]

Data Byte

[Missing <param name="Data"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicUploadParameters.#ctor(System.String,System.Byte[],System.Boolean,Orthogonal.Hoarder.StdLib.DTO.FotoProperties)"]

IsThumbnail Boolean

[Missing <param name="IsThumbnail"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicUploadParameters.#ctor(System.String,System.Byte[],System.Boolean,Orthogonal.Hoarder.StdLib.DTO.FotoProperties)"]

Properties FotoProperties

[Missing <param name="Properties"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.PicUploadParameters.#ctor(System.String,System.Byte[],System.Boolean,Orthogonal.Hoarder.StdLib.DTO.FotoProperties)"]

See Also

Reference

PicUploadParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicUploadParameters Properties

The PicUploadParameters type exposes the following members.

Properties
 | Name | Description
Public property | BlobName |
Public property | Data |
Public property | IsThumbnail |
Public property | Properties |
Top
See Also

Reference

PicUploadParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicUploadParameters.BlobName Property

PicUploadParametersBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicUploadParameters.BlobName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string BlobName { get; init; }

Property Value

String
See Also

Reference

PicUploadParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicUploadParameters.Data Property

PicUploadParametersData Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicUploadParameters.Data"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public byte[] Data { get; init; }

Property Value

Byte
See Also

Reference

PicUploadParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicUploadParameters.IsThumbnail Property

PicUploadParametersIsThumbnail Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicUploadParameters.IsThumbnail"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsThumbnail { get; init; }

Property Value

Boolean
See Also

Reference

PicUploadParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


PicUploadParameters.Properties Property

PicUploadParametersProperties Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.PicUploadParameters.Properties"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FotoProperties? Properties { get; init; }

Property Value

FotoProperties
See Also

Reference

PicUploadParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RenameContributorParameters Class

Request parameter for the RenameContributor API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTORenameContributorParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class RenameContributorParameters : IEquatable<RenameContributorParameters>

The RenameContributorParameters type exposes the following members.

Constructors
 | Name | Description
Public method | RenameContributorParameters | Request parameter for the RenameContributor API method.
Top
Properties
 | Name | Description
Public property | Invcons |
Public property | NewName |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


RenameContributorParameters Constructor

Request parameter for the RenameContributor API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public RenameContributorParameters(
    string NewName,
    InvertContributor[] Invcons
)

Parameters

NewName String

[Missing <param name="NewName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.RenameContributorParameters.#ctor(System.String,Orthogonal.Hoarder.StdLib.DTO.InvertContributor[])"]

Invcons InvertContributor

[Missing <param name="Invcons"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.RenameContributorParameters.#ctor(System.String,Orthogonal.Hoarder.StdLib.DTO.InvertContributor[])"]

See Also

Reference

RenameContributorParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RenameContributorParameters Properties

The RenameContributorParameters type exposes the following members.

Properties
 | Name | Description
Public property | Invcons |
Public property | NewName |
Top
See Also

Reference

RenameContributorParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RenameContributorParameters.Invcons Property

RenameContributorParametersInvcons Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.RenameContributorParameters.Invcons"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public InvertContributor[] Invcons { get; init; }

Property Value

InvertContributor
See Also

Reference

RenameContributorParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RenameContributorParameters.NewName Property

RenameContributorParametersNewName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.RenameContributorParameters.NewName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string NewName { get; init; }

Property Value

String
See Also

Reference

RenameContributorParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RenameParameters Class

Request parameters for the RenameMedia, RenameOwner, RenameLocation and RenameTag API methods.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTORenameParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class RenameParameters : IEquatable<RenameParameters>

The RenameParameters type exposes the following members.

Constructors
 | Name | Description
Public method | RenameParameters | Request parameters for the RenameMedia, RenameOwner, RenameLocation and RenameTag API methods.
Top
Properties
 | Name | Description
Public property | NewName |
Public property | OldName |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


RenameParameters Constructor

Request parameters for the RenameMedia, RenameOwner, RenameLocation and RenameTag API methods.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public RenameParameters(
    string OldName,
    string NewName
)

Parameters

OldName String

[Missing <param name="OldName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.RenameParameters.#ctor(System.String,System.String)"]

NewName String

[Missing <param name="NewName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.RenameParameters.#ctor(System.String,System.String)"]

See Also

Reference

RenameParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RenameParameters Properties

The RenameParameters type exposes the following members.

Properties
 | Name | Description
Public property | NewName |
Public property | OldName |
Top
See Also

Reference

RenameParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RenameParameters.NewName Property

RenameParametersNewName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.RenameParameters.NewName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string NewName { get; init; }

Property Value

String
See Also

Reference

RenameParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RenameParameters.OldName Property

RenameParametersOldName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.RenameParameters.OldName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string OldName { get; init; }

Property Value

String
See Also

Reference

RenameParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RepsertTitleResult Class

Response from the RepsertTitle API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTORepsertTitleResult

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class RepsertTitleResult : IEquatable<RepsertTitleResult>

The RepsertTitleResult type exposes the following members.

Constructors
 | Name | Description
Public method | RepsertTitleResult | Response from the RepsertTitle API method.
Top
Properties
 | Name | Description
Public property | Created | True if the title was created, False if it was updated.
Public property | SavedTitle | The title after update.
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


RepsertTitleResult Constructor

Response from the RepsertTitle API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public RepsertTitleResult(
    Title SavedTitle,
    bool Created
)

Parameters

SavedTitle Title
The title after update.
Created Boolean
True if the title was created, False if it was updated.
See Also

Reference

RepsertTitleResult Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RepsertTitleResult Properties

The RepsertTitleResult type exposes the following members.

Properties
 | Name | Description
Public property | Created | True if the title was created, False if it was updated.
Public property | SavedTitle | The title after update.
Top
See Also

Reference

RepsertTitleResult Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RepsertTitleResult.Created Property

RepsertTitleResultCreated Property

True if the title was created, False if it was updated.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Created { get; init; }

Property Value

Boolean
See Also

Reference

RepsertTitleResult Class
Orthogonal.Hoarder.StdLib.DTO Namespace


RepsertTitleResult.SavedTitle Property

RepsertTitleResultSavedTitle Property

The title after update.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Title SavedTitle { get; init; }

Property Value

Title
See Also

Reference

RepsertTitleResult Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults Class

Response from the GlobalNameSearch API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOSearchResults

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class SearchResults : IEquatable<SearchResults>

The SearchResults type exposes the following members.

Constructors
 | Name | Description
Public method | SearchResults | Response from the GlobalNameSearch API method.
Top
Properties
 | Name | Description
Public property | Contributor |
Public property | File |
Public property | Picture |
Public property | ResultTotal |
Public property | Title |
Public property | Track |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults Constructor

Response from the GlobalNameSearch API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SearchResults(
    FoundTitle[] Title,
    FoundPicture[] Picture,
    FoundTrack[] Track,
    FoundFile[] File,
    FoundContributor[] Contributor
)

Parameters

Title FoundTitle

[Missing <param name="Title"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SearchResults.#ctor(Orthogonal.Hoarder.StdLib.DTO.FoundTitle[],Orthogonal.Hoarder.StdLib.DTO.FoundPicture[],Orthogonal.Hoarder.StdLib.DTO.FoundTrack[],Orthogonal.Hoarder.StdLib.DTO.FoundFile[],Orthogonal.Hoarder.StdLib.DTO.FoundContributor[])"]

Picture FoundPicture

[Missing <param name="Picture"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SearchResults.#ctor(Orthogonal.Hoarder.StdLib.DTO.FoundTitle[],Orthogonal.Hoarder.StdLib.DTO.FoundPicture[],Orthogonal.Hoarder.StdLib.DTO.FoundTrack[],Orthogonal.Hoarder.StdLib.DTO.FoundFile[],Orthogonal.Hoarder.StdLib.DTO.FoundContributor[])"]

Track FoundTrack

[Missing <param name="Track"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SearchResults.#ctor(Orthogonal.Hoarder.StdLib.DTO.FoundTitle[],Orthogonal.Hoarder.StdLib.DTO.FoundPicture[],Orthogonal.Hoarder.StdLib.DTO.FoundTrack[],Orthogonal.Hoarder.StdLib.DTO.FoundFile[],Orthogonal.Hoarder.StdLib.DTO.FoundContributor[])"]

File FoundFile

[Missing <param name="File"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SearchResults.#ctor(Orthogonal.Hoarder.StdLib.DTO.FoundTitle[],Orthogonal.Hoarder.StdLib.DTO.FoundPicture[],Orthogonal.Hoarder.StdLib.DTO.FoundTrack[],Orthogonal.Hoarder.StdLib.DTO.FoundFile[],Orthogonal.Hoarder.StdLib.DTO.FoundContributor[])"]

Contributor FoundContributor

[Missing <param name="Contributor"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SearchResults.#ctor(Orthogonal.Hoarder.StdLib.DTO.FoundTitle[],Orthogonal.Hoarder.StdLib.DTO.FoundPicture[],Orthogonal.Hoarder.StdLib.DTO.FoundTrack[],Orthogonal.Hoarder.StdLib.DTO.FoundFile[],Orthogonal.Hoarder.StdLib.DTO.FoundContributor[])"]

See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults Properties

The SearchResults type exposes the following members.

Properties
 | Name | Description
Public property | Contributor |
Public property | File |
Public property | Picture |
Public property | ResultTotal |
Public property | Title |
Public property | Track |
Top
See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults.Contributor Property

SearchResultsContributor Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SearchResults.Contributor"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundContributor[] Contributor { get; init; }

Property Value

FoundContributor
See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults.File Property

SearchResultsFile Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SearchResults.File"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundFile[] File { get; init; }

Property Value

FoundFile
See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults.Picture Property

SearchResultsPicture Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SearchResults.Picture"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundPicture[] Picture { get; init; }

Property Value

FoundPicture
See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults.ResultTotal Property

SearchResultsResultTotal Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SearchResults.ResultTotal"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int ResultTotal { get; }

Property Value

Int32
See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults.Title Property

SearchResultsTitle Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SearchResults.Title"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundTitle[] Title { get; init; }

Property Value

FoundTitle
See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults.Track Property

SearchResultsTrack Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SearchResults.Track"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FoundTrack[] Track { get; init; }

Property Value

FoundTrack
See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults Methods

The SearchResults type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SearchResults.ToString Method

SearchResultsToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SearchResults.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SearchResults.ToString"]

See Also

Reference

SearchResults Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SetPicMetaParameters Class

Request parameter for the SetPictureMetadata API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOSetPicMetaParameters

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class SetPicMetaParameters : IEquatable<SetPicMetaParameters>

The SetPicMetaParameters type exposes the following members.

Constructors
 | Name | Description
Public method | SetPicMetaParameters | Request parameter for the SetPictureMetadata API method.
Top
Properties
 | Name | Description
Public property | BlobName |
Public property | Properties |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


SetPicMetaParameters Constructor

Request parameter for the SetPictureMetadata API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SetPicMetaParameters(
    string BlobName,
    FotoProperties Properties
)

Parameters

BlobName String

[Missing <param name="BlobName"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SetPicMetaParameters.#ctor(System.String,Orthogonal.Hoarder.StdLib.DTO.FotoProperties)"]

Properties FotoProperties

[Missing <param name="Properties"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SetPicMetaParameters.#ctor(System.String,Orthogonal.Hoarder.StdLib.DTO.FotoProperties)"]

See Also

Reference

SetPicMetaParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SetPicMetaParameters Properties

The SetPicMetaParameters type exposes the following members.

Properties
 | Name | Description
Public property | BlobName |
Public property | Properties |
Top
See Also

Reference

SetPicMetaParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SetPicMetaParameters.BlobName Property

SetPicMetaParametersBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SetPicMetaParameters.BlobName"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string BlobName { get; init; }

Property Value

String
See Also

Reference

SetPicMetaParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SetPicMetaParameters.Properties Property

SetPicMetaParametersProperties Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SetPicMetaParameters.Properties"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public FotoProperties Properties { get; init; }

Property Value

FotoProperties
See Also

Reference

SetPicMetaParameters Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SummaryTally Class

Response child class from the GetDatabaseSummary API method. The DatabaseSummary class contains collections of SummaryTally.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOSummaryTally

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class SummaryTally

The SummaryTally type exposes the following members.

Constructors
 | Name | Description
Public method | SummaryTally | Initializes a new instance of the SummaryTally class
Top
Properties
 | Name | Description
Public property | Count |
Public property | InConfig |
Public property | Name |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


SummaryTally Constructor

Initializes a new instance of the SummaryTally class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public SummaryTally()
See Also

Reference

SummaryTally Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SummaryTally Properties

The SummaryTally type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | InConfig |
Public property | Name |
Top
See Also

Reference

SummaryTally Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SummaryTally.Count Property

SummaryTallyCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SummaryTally.Count"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Count { get; set; }

Property Value

Int32
See Also

Reference

SummaryTally Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SummaryTally.InConfig Property

SummaryTallyInConfig Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SummaryTally.InConfig"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool InConfig { get; set; }

Property Value

Boolean
See Also

Reference

SummaryTally Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SummaryTally.Name Property

SummaryTallyName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.SummaryTally.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

SummaryTally Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SummaryTally Methods

The SummaryTally type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

SummaryTally Class
Orthogonal.Hoarder.StdLib.DTO Namespace


SummaryTally.ToString Method

SummaryTallyToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SummaryTally.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.SummaryTally.ToString"]

See Also

Reference

SummaryTally Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ThumbMetaShort Class

Response from the ListThumbMetaShort API method.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOThumbMetaShort

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class ThumbMetaShort : IEquatable<ThumbMetaShort>

The ThumbMetaShort type exposes the following members.

Constructors
 | Name | Description
Public method | ThumbMetaShort | Response from the ListThumbMetaShort API method.
Top
Properties
 | Name | Description
Public property | LastModified |
Public property | Name |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


ThumbMetaShort Constructor

Response from the ListThumbMetaShort API method.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ThumbMetaShort(
    string Name,
    DateTime? LastModified
)

Parameters

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ThumbMetaShort.#ctor(System.String,System.Nullable{System.DateTime})"]

LastModified Nullable DateTime

[Missing <param name="LastModified"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.ThumbMetaShort.#ctor(System.String,System.Nullable{System.DateTime})"]

See Also

Reference

ThumbMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ThumbMetaShort Properties

The ThumbMetaShort type exposes the following members.

Properties
 | Name | Description
Public property | LastModified |
Public property | Name |
Top
See Also

Reference

ThumbMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ThumbMetaShort.LastModified Property

ThumbMetaShortLastModified Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ThumbMetaShort.LastModified"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? LastModified { get; init; }

Property Value

Nullable DateTime
See Also

Reference

ThumbMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


ThumbMetaShort.Name Property

ThumbMetaShortName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.ThumbMetaShort.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

ThumbMetaShort Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem Class

Response from the ListTitleItems API method. Request parameter for the UpdateTitleFromItem API method.

This class encapsulates a reduced set of information about a Title. The reduced information may be useful in situations where using full Title objects may be overkill and simpler summary information is satisfactory. One of the grids in the WPF desktop app uses this class to display large amounts of Title information in a concise spreadsheet format.

Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOTitleListItem

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public class TitleListItem

The TitleListItem type exposes the following members.

Constructors
 | Name | Description
Public method | TitleListItem | Initializes a new instance of the TitleListItem class
Public method | TitleListItem(String, DateTime, String, String) | Initializes a new instance of the TitleListItem class
Top
Properties
 | Name | Description
Public property | Catalog |
Public property | Company |
Public property | Created |
Public property | EditionYear |
Public property | id |
Public property | IsDiscarded |
Public property | IsHidden |
Public property | LegacyId |
Public property | LegacyKey |
Public property | LegacyUid |
Public property | Location |
Public property | Media |
Public property | Name |
Public property | Owner |
Public property | PartCount |
Public property | Price |
Public property | PrimaryGenres |
Public property | PrimaryNames |
Public property | PublishYear |
Public property | Purchased |
Public property | ScanHash |
Public property | ScanLabel |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem Constructor

Overload List
 | Name | Description
Public method | TitleListItem | Initializes a new instance of the TitleListItem class
Public method | TitleListItem(String, DateTime, String, String) | Initializes a new instance of the TitleListItem class
Top
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem Constructor

Initializes a new instance of the TitleListItem class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public TitleListItem()
See Also

Reference

TitleListItem Class
TitleListItem Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem(String, DateTime, String, String) Constructor

Initializes a new instance of the TitleListItem class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public TitleListItem(
    string id,
    DateTime created,
    string name,
    string media
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.#ctor(System.String,System.DateTime,System.String,System.String)"]

created DateTime

[Missing <param name="created"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.#ctor(System.String,System.DateTime,System.String,System.String)"]

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.#ctor(System.String,System.DateTime,System.String,System.String)"]

media String

[Missing <param name="media"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.#ctor(System.String,System.DateTime,System.String,System.String)"]

See Also

Reference

TitleListItem Class
TitleListItem Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem Properties

The TitleListItem type exposes the following members.

Properties
 | Name | Description
Public property | Catalog |
Public property | Company |
Public property | Created |
Public property | EditionYear |
Public property | id |
Public property | IsDiscarded |
Public property | IsHidden |
Public property | LegacyId |
Public property | LegacyKey |
Public property | LegacyUid |
Public property | Location |
Public property | Media |
Public property | Name |
Public property | Owner |
Public property | PartCount |
Public property | Price |
Public property | PrimaryGenres |
Public property | PrimaryNames |
Public property | PublishYear |
Public property | Purchased |
Public property | ScanHash |
Public property | ScanLabel |
Top
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Catalog Property

TitleListItemCatalog Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Catalog"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Catalog { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Company Property

TitleListItemCompany Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Company"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Company { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Created Property

TitleListItemCreated Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Created"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime Created { get; set; }

Property Value

DateTime
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.EditionYear Property

TitleListItemEditionYear Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.EditionYear"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? EditionYear { get; set; }

Property Value

Nullable Int16
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.id Property

TitleListItemid Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.id"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string id { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.IsDiscarded Property

TitleListItemIsDiscarded Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.IsDiscarded"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsDiscarded { get; set; }

Property Value

Boolean
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.IsHidden Property

TitleListItemIsHidden Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.IsHidden"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsHidden { get; set; }

Property Value

Boolean
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.LegacyId Property

TitleListItemLegacyId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.LegacyId"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? LegacyId { get; set; }

Property Value

Nullable Int32
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.LegacyKey Property

TitleListItemLegacyKey Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.LegacyKey"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string LegacyKey { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.LegacyUid Property

TitleListItemLegacyUid Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.LegacyUid"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Guid? LegacyUid { get; set; }

Property Value

Nullable Guid
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Location Property

TitleListItemLocation Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Location"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Location { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Media Property

TitleListItemMedia Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Media"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Media { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Name Property

TitleListItemName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Owner Property

TitleListItemOwner Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Owner"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Owner { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.PartCount Property

TitleListItemPartCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.PartCount"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short PartCount { get; set; }

Property Value

Int16
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Price Property

TitleListItemPrice Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Price"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public decimal? Price { get; set; }

Property Value

Nullable Decimal
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.PrimaryGenres Property

TitleListItemPrimaryGenres Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.PrimaryGenres"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string[] PrimaryGenres { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.PrimaryNames Property

TitleListItemPrimaryNames Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.PrimaryNames"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string[] PrimaryNames { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.PublishYear Property

TitleListItemPublishYear Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.PublishYear"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? PublishYear { get; set; }

Property Value

Nullable Int16
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.Purchased Property

TitleListItemPurchased Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.Purchased"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? Purchased { get; set; }

Property Value

Nullable DateTime
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.ScanHash Property

TitleListItemScanHash Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.ScanHash"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public long? ScanHash { get; set; }

Property Value

Nullable Int64
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.ScanLabel Property

TitleListItemScanLabel Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.ScanLabel"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string ScanLabel { get; set; }

Property Value

String
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem Methods

The TitleListItem type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleListItem.ToString Method

TitleListItemToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.TitleListItem.ToString"]

See Also

Reference

TitleListItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


TitleSpecialFilter Enumeration

Enumeration of special Title search types for the SpecialFilter.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public enum TitleSpecialFilter
Members
Member name | Value | Description
None | 0 |
NoPictures | 1 |
OnePicture | 2 |
SomePictures | 3 |
MultiplePictures | 4 |
NoContributors | 5 |
OneContributor | 6 |
MultipleContributors | 7 |
Tagged | 8 |
NotTagged | 9 |
HasNote | 10 |
NoNote | 11 |
HasComment | 12 |
NoComment | 13 |
HasInfoUri | 14 |
NoInfoUri | 15 |
HasPrice | 16 |
NoPrice | 17 |
NoLocation | 18 |
NoOwner | 19 |
NoPublishYear | 20 |
HasPublishYear | 21 |
NoEditionYear | 22 |
HasEditionYear | 23 |
HasScanData | 24 |
NoScanData | 25 |
HasCatalog | 26 |
NoCatalog | 27 |
NoTracks | 28 |
HasTracks | 29 |
NoFiles | 30 |
HasFiles | 31 |
HasTracksAndFiles | 32 |
NoTrackSides | 33 |
NoAgateId | 34 |
AddedLastWeek | 35 |
AddedLastMonth | 36 |
AddedLast3Months | 37 |
NotHidden | 38 |
Hidden | 39 |
Discarded | 40 |
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry Class

This class is used in the Web API methods related to listing and updating Visitor Book enties.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOVisitorBookEntry

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class VisitorBookEntry : IEquatable<VisitorBookEntry>

The VisitorBookEntry type exposes the following members.

Constructors
 | Name | Description
Public method | VisitorBookEntry | This class is used in the Web API methods related to listing and updating Visitor Book enties.
Top
Properties
 | Name | Description
Public property | Arrival |
Public property | Comment |
Public property | Email |
Public property | Id |
Public property | Location |
Public property | Name |
Public property | RemoteAddr |
Public property | Time |
Public property | Url |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry Constructor

This class is used in the Web API methods related to listing and updating Visitor Book enties.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public VisitorBookEntry(
    int Id,
    DateTime Time,
    string Name,
    string Comment,
    string Arrival,
    string Email,
    string RemoteAddr,
    string Location,
    string Url
)

Parameters

Id Int32

[Missing <param name="Id"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

Time DateTime

[Missing <param name="Time"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

Name String

[Missing <param name="Name"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

Comment String

[Missing <param name="Comment"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

Arrival String

[Missing <param name="Arrival"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

Email String

[Missing <param name="Email"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

RemoteAddr String

[Missing <param name="RemoteAddr"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

Location String

[Missing <param name="Location"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

Url String

[Missing <param name="Url"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.#ctor(System.Int32,System.DateTime,System.String,System.String,System.String,System.String,System.String,System.String,System.String)"]

See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry Properties

The VisitorBookEntry type exposes the following members.

Properties
 | Name | Description
Public property | Arrival |
Public property | Comment |
Public property | Email |
Public property | Id |
Public property | Location |
Public property | Name |
Public property | RemoteAddr |
Public property | Time |
Public property | Url |
Top
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.Arrival Property

VisitorBookEntryArrival Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.Arrival"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Arrival { get; init; }

Property Value

String
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.Comment Property

VisitorBookEntryComment Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.Comment"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Comment { get; init; }

Property Value

String
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.Email Property

VisitorBookEntryEmail Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.Email"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Email { get; init; }

Property Value

String
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.Id Property

VisitorBookEntryId Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.Id"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Id { get; init; }

Property Value

Int32
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.Location Property

VisitorBookEntryLocation Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.Location"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Location { get; init; }

Property Value

String
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.Name Property

VisitorBookEntryName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.Name"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; init; }

Property Value

String
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.RemoteAddr Property

VisitorBookEntryRemoteAddr Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.RemoteAddr"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string RemoteAddr { get; init; }

Property Value

String
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.Time Property

VisitorBookEntryTime Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.Time"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime Time { get; init; }

Property Value

DateTime
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


VisitorBookEntry.Url Property

VisitorBookEntryUrl Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.VisitorBookEntry.Url"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Url { get; init; }

Property Value

String
See Also

Reference

VisitorBookEntry Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse Class

Encapsulates 'standard' error information returned in the body of any response that is not status 200 (OK). Hoarder only officially returns responses with status codes 200 (OK) and 403 (Unauthorized). A status of 500 (InternalServerError) indicates a server-side unhandled exception, probably a bug. Any response with status other than 200 will contain a serialized instance of this class.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOWebServiceErrorResponse

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class WebServiceErrorResponse : IEquatable<WebServiceErrorResponse>

The WebServiceErrorResponse type exposes the following members.

Constructors
 | Name | Description
Public method | WebServiceErrorResponse | Encapsulates 'standard' error information returned in the body of any response that is not status 200 (OK). Hoarder only officially returns responses with status codes 200 (OK) and 403 (Unauthorized). A status of 500 (InternalServerError) indicates a server-side unhandled exception, probably a bug. Any response with status other than 200 will contain a serialized instance of this class.
Top
Properties
 | Name | Description
Public property | Code | Hoarder defined error code.
Public property | Detail | Optional detailed information about the error.
Public property | Message | A shorter error message.
Public property | Stack | Optional stack trace (only available when debugging).
Public property | Uri | Optional Uri for more information on the error.
Top
Methods
Name | Description
Create(Int32, String) |
Create(Int32, String, String) |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse Constructor

Encapsulates 'standard' error information returned in the body of any response that is not status 200 (OK). Hoarder only officially returns responses with status codes 200 (OK) and 403 (Unauthorized). A status of 500 (InternalServerError) indicates a server-side unhandled exception, probably a bug. Any response with status other than 200 will contain a serialized instance of this class.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public WebServiceErrorResponse(
    int Code,
    string Message,
    string? Detail,
    string? Uri,
    string? Stack
)

Parameters

Code Int32
Hoarder defined error code.
Message String
A shorter error message.
Detail String
Optional detailed information about the error.
Uri String
Optional Uri for more information on the error.
Stack String
Optional stack trace (only available when debugging).
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse Properties

The WebServiceErrorResponse type exposes the following members.

Properties
 | Name | Description
Public property | Code | Hoarder defined error code.
Public property | Detail | Optional detailed information about the error.
Public property | Message | A shorter error message.
Public property | Stack | Optional stack trace (only available when debugging).
Public property | Uri | Optional Uri for more information on the error.
Top
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse.Code Property

WebServiceErrorResponseCode Property

Hoarder defined error code.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Code { get; init; }

Property Value

Int32
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse.Detail Property

WebServiceErrorResponseDetail Property

Optional detailed information about the error.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string? Detail { get; init; }

Property Value

String
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse.Message Property

WebServiceErrorResponseMessage Property

A shorter error message.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Message { get; init; }

Property Value

String
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse.Stack Property

WebServiceErrorResponseStack Property

Optional stack trace (only available when debugging).

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string? Stack { get; init; }

Property Value

String
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse.Uri Property

WebServiceErrorResponseUri Property

Optional Uri for more information on the error.

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string? Uri { get; init; }

Property Value

String
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse Methods

The WebServiceErrorResponse type exposes the following members.

Methods
Name | Description
Create(Int32, String) |
Create(Int32, String, String) |
Top
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse.Create Method

WebServiceErrorResponseCreate Method

Overload List
Name | Description
Create(Int32, String) |
Create(Int32, String, String) |
Top
See Also

Reference

WebServiceErrorResponse Class
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse.Create(Int32, String) Method

WebServiceErrorResponseCreate(Int32, String) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String)"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static WebServiceErrorResponse Create(
    int code,
    string message
)

Parameters

code Int32

[Missing <param name="code"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String)"]

message String

[Missing <param name="message"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String)"]

Return Value

WebServiceErrorResponse

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String)"]

See Also

Reference

WebServiceErrorResponse Class
Create Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


WebServiceErrorResponse.Create(Int32, String, String) Method

WebServiceErrorResponseCreate(Int32, String, String) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String,System.String)"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static WebServiceErrorResponse Create(
    int code,
    string message,
    string? detail
)

Parameters

code Int32

[Missing <param name="code"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String,System.String)"]

message String

[Missing <param name="message"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String,System.String)"]

detail String

[Missing <param name="detail"/> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String,System.String)"]

Return Value

WebServiceErrorResponse

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.WebServiceErrorResponse.Create(System.Int32,System.String,System.String)"]

See Also

Reference

WebServiceErrorResponse Class
Create Overload
Orthogonal.Hoarder.StdLib.DTO Namespace


XrefItem Class

Response child class from the GetDatabaseSummary API method. The DatabaseSummary class contains a collection of XrefItem.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.DTOXrefItem

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class XrefItem

The XrefItem type exposes the following members.

Constructors
 | Name | Description
Public method | XrefItem | Initializes a new instance of the XrefItem class
Top
Properties
 | Name | Description
Public property | Count |
Public property | Side |
Public property | Top |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.DTO Namespace


XrefItem Constructor

Initializes a new instance of the XrefItem class

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public XrefItem()
See Also

Reference

XrefItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


XrefItem Properties

The XrefItem type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Side |
Public property | Top |
Top
See Also

Reference

XrefItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


XrefItem.Count Property

XrefItemCount Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.XrefItem.Count"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Count { get; set; }

Property Value

Int32
See Also

Reference

XrefItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


XrefItem.Side Property

XrefItemSide Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.XrefItem.Side"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Side { get; set; }

Property Value

String
See Also

Reference

XrefItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


XrefItem.Top Property

XrefItemTop Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.DTO.XrefItem.Top"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Top { get; set; }

Property Value

String
See Also

Reference

XrefItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


XrefItem Methods

The XrefItem type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

XrefItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


XrefItem.ToString Method

XrefItemToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.XrefItem.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.DTO
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.DTO.XrefItem.ToString"]

See Also

Reference

XrefItem Class
Orthogonal.Hoarder.StdLib.DTO Namespace


Orthogonal.Hoarder.StdLib.Entity Namespace

Namespace of classes that correspond to database records.
Classes
 | Class | Description
Public class | ConfigBasic | A Configuration2 child document describing a registered Genre, Role, Tag, Contributor and Picture Type.
Public class | ConfigLocation | A Configuration2 child document describing a registered Location.
Public class | ConfigMedia | A Configuration2 child document describing a registered Media.
Public class | ConfigOwner | A Configuration2 child document describing a registered Owner.
Public class | Configuration2 | A single special database document that contains the names of registered child documents such as Location, Genre, Owner, etc. The configuration document acts as a kind of quick lookup for client apps who need to fill pick-lists of child document types. In a relational database, the configuration document would be a set of reference tables joined to the titles. Cosmos DB is not a relational database and does not support joins, so the configuration document is a loose substitute for the same concept.
Public class | Contributor | A Title child document that represents a contributor to a Title. A contributor is typically the name of a person or an entertainment ensemble such as a pop group or orchestra. A Title contains a collection of child Contributor documents.
Public class | File | A Title child document that represents a file stored on digital media such as data CD or DVD. A Title contains a collection of child File documents.
Public class | Genre | A Title child document that represents a genre associated with a Title. A Title contains a collection of child Genre documents.
Public class | Picture | A Title child document that represent a picture associate with a Title. A Title contains a collection of child Picture documents.
Public class | Tag | A Title child document which represents an arbitrary user-defined attribute that can be associated with titles. A Title contains a collection of child Tag documents.
Public class | Title | A Title is the fundamentally important entity (record or document) in the collections database. A Title represents a single identifiable object in the collections database. It may represent a typical multimedia item such as an audio CD, a video DVD, etc. It may also represent other collectible items such as books, magazines, model cars, stamps, mineral samples or vintage toasters (anything you might consider collecting).
Public class | TitleComparer | A utility helper class to compare equality of Titles based upon the id.
Public class | Track | A Title child document describing a track, which typically represents a section within a Title. Most music media such as vinyl records and audio CDs contain traditional tracks. A track can also be used to define sections of printed media such as book chapters. A Title contains a collection of child Track documents.
Interfaces
 | Interface | Description
Public interface | IHoarderDocument | The interface that must be implemented by all POCOs that represent a Cosmos DB document. There are currently only two: Title and Configuration2.
Enumerations
 | Enumeration | Description
Public enumeration | DocumentType | Enumeration of the document 'type' discriminator numbers of records in the database.


ConfigBasic Class

A Configuration2 child document describing a registered Genre, Role, Tag, Contributor and Picture Type.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityConfigBasic

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class ConfigBasic

The ConfigBasic type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigBasic | Initializes a new instance of the ConfigBasic class
Public method | ConfigBasic(String) | Initializes a new instance of the ConfigBasic class
Top
Properties
 | Name | Description
Public property | Name | The Name of the child document.
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigBasic Constructor

Overload List
 | Name | Description
Public method | ConfigBasic | Initializes a new instance of the ConfigBasic class
Public method | ConfigBasic(String) | Initializes a new instance of the ConfigBasic class
Top
See Also

Reference

ConfigBasic Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigBasic Constructor

Initializes a new instance of the ConfigBasic class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigBasic()
See Also

Reference

ConfigBasic Class
ConfigBasic Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigBasic(String) Constructor

Initializes a new instance of the ConfigBasic class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigBasic(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigBasic.#ctor(System.String)"]

See Also

Reference

ConfigBasic Class
ConfigBasic Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigBasic Properties

The ConfigBasic type exposes the following members.

Properties
 | Name | Description
Public property | Name | The Name of the child document.
Top
See Also

Reference

ConfigBasic Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigBasic.Name Property

ConfigBasicName Property

The Name of the child document.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ConfigBasic Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigBasic Methods

The ConfigBasic type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ConfigBasic Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigBasic.ToString Method

ConfigBasicToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigBasic.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigBasic.ToString"]

See Also

Reference

ConfigBasic Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation Class

A Configuration2 child document describing a registered Location.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityConfigLocation

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class ConfigLocation

The ConfigLocation type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigLocation | Initializes a new instance of the ConfigLocation class
Public method | ConfigLocation(String) | Initializes a new instance of the ConfigLocation class
Top
Properties
 | Name | Description
Public property | Comment | Comment for the Location.
Public property | Description | Location description.
Public property | Name | The name of the location.
Public property | PictureBlobName | Name of a blob containing a picture of the Location.
Public property | Sequence | Sort sequence of the Location.
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation Constructor

Overload List
 | Name | Description
Public method | ConfigLocation | Initializes a new instance of the ConfigLocation class
Public method | ConfigLocation(String) | Initializes a new instance of the ConfigLocation class
Top
See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation Constructor

Initializes a new instance of the ConfigLocation class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigLocation()
See Also

Reference

ConfigLocation Class
ConfigLocation Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation(String) Constructor

Initializes a new instance of the ConfigLocation class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigLocation(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigLocation.#ctor(System.String)"]

See Also

Reference

ConfigLocation Class
ConfigLocation Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation Properties

The ConfigLocation type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Comment for the Location.
Public property | Description | Location description.
Public property | Name | The name of the location.
Public property | PictureBlobName | Name of a blob containing a picture of the Location.
Public property | Sequence | Sort sequence of the Location.
Top
See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation.Comment Property

ConfigLocationComment Property

Comment for the Location.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

String
See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation.Description Property

ConfigLocationDescription Property

Location description.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Description { get; set; }

Property Value

String
See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation.Name Property

ConfigLocationName Property

The name of the location.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation.PictureBlobName Property

ConfigLocationPictureBlobName Property

Name of a blob containing a picture of the Location.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string PictureBlobName { get; set; }

Property Value

String
See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation.Sequence Property

ConfigLocationSequence Property

Sort sequence of the Location.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Sequence { get; set; }

Property Value

Int32
See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation Methods

The ConfigLocation type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigLocation.ToString Method

ConfigLocationToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigLocation.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigLocation.ToString"]

See Also

Reference

ConfigLocation Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia Class

A Configuration2 child document describing a registered Media.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityConfigMedia

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class ConfigMedia

The ConfigMedia type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigMedia | Initializes a new instance of the ConfigMedia class
Public method | ConfigMedia(String) | Initializes a new instance of the ConfigMedia class
Top
Properties
 | Name | Description
Public property | Comment |
Public property | Description |
Public property | Name |
Public property | PictureBlobName |
Public property | Sequence |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia Constructor

Overload List
 | Name | Description
Public method | ConfigMedia | Initializes a new instance of the ConfigMedia class
Public method | ConfigMedia(String) | Initializes a new instance of the ConfigMedia class
Top
See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia Constructor

Initializes a new instance of the ConfigMedia class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigMedia()
See Also

Reference

ConfigMedia Class
ConfigMedia Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia(String) Constructor

Initializes a new instance of the ConfigMedia class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigMedia(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigMedia.#ctor(System.String)"]

See Also

Reference

ConfigMedia Class
ConfigMedia Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia Properties

The ConfigMedia type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Description |
Public property | Name |
Public property | PictureBlobName |
Public property | Sequence |
Top
See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia.Comment Property

ConfigMediaComment Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigMedia.Comment"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

String
See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia.Description Property

ConfigMediaDescription Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigMedia.Description"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Description { get; set; }

Property Value

String
See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia.Name Property

ConfigMediaName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigMedia.Name"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia.PictureBlobName Property

ConfigMediaPictureBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigMedia.PictureBlobName"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string PictureBlobName { get; set; }

Property Value

String
See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia.Sequence Property

ConfigMediaSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigMedia.Sequence"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Sequence { get; set; }

Property Value

Int32
See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia Methods

The ConfigMedia type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigMedia.ToString Method

ConfigMediaToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigMedia.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigMedia.ToString"]

See Also

Reference

ConfigMedia Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner Class

A Configuration2 child document describing a registered Owner.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityConfigOwner

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class ConfigOwner

The ConfigOwner type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigOwner | Initializes a new instance of the ConfigOwner class
Public method | ConfigOwner(String, String) | Initializes a new instance of the ConfigOwner class
Top
Properties
 | Name | Description
Public property | Comment |
Public property | Email |
Public property | Initials |
Public property | Name |
Public property | Phone1 |
Public property | Phone2 |
Public property | PictureBlobName |
Public property | Postal |
Public property | Sequence |
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner Constructor

Overload List
 | Name | Description
Public method | ConfigOwner | Initializes a new instance of the ConfigOwner class
Public method | ConfigOwner(String, String) | Initializes a new instance of the ConfigOwner class
Top
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner Constructor

Initializes a new instance of the ConfigOwner class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigOwner()
See Also

Reference

ConfigOwner Class
ConfigOwner Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner(String, String) Constructor

Initializes a new instance of the ConfigOwner class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigOwner(
    string name,
    string initials
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.#ctor(System.String,System.String)"]

initials String

[Missing <param name="initials"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.#ctor(System.String,System.String)"]

See Also

Reference

ConfigOwner Class
ConfigOwner Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner Properties

The ConfigOwner type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Email |
Public property | Initials |
Public property | Name |
Public property | Phone1 |
Public property | Phone2 |
Public property | PictureBlobName |
Public property | Postal |
Public property | Sequence |
Top
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.Comment Property

ConfigOwnerComment Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.Comment"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

String
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.Email Property

ConfigOwnerEmail Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.Email"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Email { get; set; }

Property Value

String
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.Initials Property

ConfigOwnerInitials Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.Initials"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Initials { get; set; }

Property Value

String
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.Name Property

ConfigOwnerName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.Name"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.Phone1 Property

ConfigOwnerPhone1 Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.Phone1"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Phone1 { get; set; }

Property Value

String
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.Phone2 Property

ConfigOwnerPhone2 Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.Phone2"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Phone2 { get; set; }

Property Value

String
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.PictureBlobName Property

ConfigOwnerPictureBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.PictureBlobName"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string PictureBlobName { get; set; }

Property Value

String
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.Postal Property

ConfigOwnerPostal Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.Postal"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Postal { get; set; }

Property Value

String
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.Sequence Property

ConfigOwnerSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.Sequence"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Sequence { get; set; }

Property Value

Int32
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner Methods

The ConfigOwner type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


ConfigOwner.ToString Method

ConfigOwnerToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.ConfigOwner.ToString"]

See Also

Reference

ConfigOwner Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2 Class

A single special database document that contains the names of registered child documents such as Location, Genre, Owner, etc. The configuration document acts as a kind of quick lookup for client apps who need to fill pick-lists of child document types. In a relational database, the configuration document would be a set of reference tables joined to the titles. Cosmos DB is not a relational database and does not support joins, so the configuration document is a loose substitute for the same concept.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityConfiguration2

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class Configuration2 : IHoarderDocument

The Configuration2 type exposes the following members.

Constructors
 | Name | Description
Public method | Configuration2 | Initializes a new instance of the Configuration2 class
Top
Properties
 | Name | Description
Public property | ActorGroups | An array of child documents describing named groups of actors.
Public property | Actors | An array of child documents describing registered actors (people or things appearing in pictures).
Public property | Genres | An array of child documents describing registered genres.
Public property | id | The primary key Id of the configuration document is the hard-coded value "Configuration2". Note that lower-case name is required to allow simple serialization to a Cosmos DB document.
Public property | LastSaveTime | The UTC time the configuration document was last saved.
Public property | Locations | An array of child documents describing registered locations.
Public property | Medias | An array of child documents describing registered media.
Public property | Owners | An array of child documents describing registered owners.
Public property | PictureTypes | An array of child documents describing registered picture types.
Public property | Pk | The Partition Key is the fixed value "P1".
Public property | Roles | An array of child documents describing registered roles.
Public property | Tags | An array of child documents describing registered tags.
Public property | Type | Discriminates different types of documents in the database. There are currently only two types: Title document (Type=2) and Configuration document (Type=3).
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2 Constructor

Initializes a new instance of the Configuration2 class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Configuration2()
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2 Properties

The Configuration2 type exposes the following members.

Properties
 | Name | Description
Public property | ActorGroups | An array of child documents describing named groups of actors.
Public property | Actors | An array of child documents describing registered actors (people or things appearing in pictures).
Public property | Genres | An array of child documents describing registered genres.
Public property | id | The primary key Id of the configuration document is the hard-coded value "Configuration2". Note that lower-case name is required to allow simple serialization to a Cosmos DB document.
Public property | LastSaveTime | The UTC time the configuration document was last saved.
Public property | Locations | An array of child documents describing registered locations.
Public property | Medias | An array of child documents describing registered media.
Public property | Owners | An array of child documents describing registered owners.
Public property | PictureTypes | An array of child documents describing registered picture types.
Public property | Pk | The Partition Key is the fixed value "P1".
Public property | Roles | An array of child documents describing registered roles.
Public property | Tags | An array of child documents describing registered tags.
Public property | Type | Discriminates different types of documents in the database. There are currently only two types: Title document (Type=2) and Configuration document (Type=3).
Top
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.ActorGroups Property

Configuration2ActorGroups Property

An array of child documents describing named groups of actors.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigBasic[] ActorGroups { get; set; }

Property Value

ConfigBasic
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Actors Property

Configuration2Actors Property

An array of child documents describing registered actors (people or things appearing in pictures).

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigBasic[] Actors { get; set; }

Property Value

ConfigBasic
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Genres Property

Configuration2Genres Property

An array of child documents describing registered genres.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigBasic[] Genres { get; set; }

Property Value

ConfigBasic
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.id Property

Configuration2id Property

The primary key Id of the configuration document is the hard-coded value "Configuration2". Note that lower-case name is required to allow simple serialization to a Cosmos DB document.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string id { get; set; }

Property Value

String

Implements

IHoarderDocumentid
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.LastSaveTime Property

Configuration2LastSaveTime Property

The UTC time the configuration document was last saved.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? LastSaveTime { get; set; }

Property Value

Nullable DateTime
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Locations Property

Configuration2Locations Property

An array of child documents describing registered locations.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigLocation[] Locations { get; set; }

Property Value

ConfigLocation
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Medias Property

Configuration2Medias Property

An array of child documents describing registered media.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigMedia[] Medias { get; set; }

Property Value

ConfigMedia
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Owners Property

Configuration2Owners Property

An array of child documents describing registered owners.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigOwner[] Owners { get; set; }

Property Value

ConfigOwner
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.PictureTypes Property

Configuration2PictureTypes Property

An array of child documents describing registered picture types.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigBasic[] PictureTypes { get; set; }

Property Value

ConfigBasic
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Pk Property

Configuration2Pk Property

The Partition Key is the fixed value "P1".

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Pk { get; set; }

Property Value

String

Implements

IHoarderDocumentPk
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Roles Property

Configuration2Roles Property

An array of child documents describing registered roles.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigBasic[] Roles { get; set; }

Property Value

ConfigBasic
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Tags Property

Configuration2Tags Property

An array of child documents describing registered tags.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public ConfigBasic[] Tags { get; set; }

Property Value

ConfigBasic
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.Type Property

Configuration2Type Property

Discriminates different types of documents in the database. There are currently only two types: Title document (Type=2) and Configuration document (Type=3).

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DocumentType Type { get; set; }

Property Value

DocumentType

Implements

IHoarderDocumentType
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2 Methods

The Configuration2 type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Configuration2.ToString Method

Configuration2ToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Configuration2.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Configuration2.ToString"]

See Also

Reference

Configuration2 Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor Class

A Title child document that represents a contributor to a Title. A contributor is typically the name of a person or an entertainment ensemble such as a pop group or orchestra. A Title contains a collection of child Contributor documents.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityContributor

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class Contributor : IEquatable<Contributor>

The Contributor type exposes the following members.

Constructors
 | Name | Description
Public method | Contributor | Initializes a new instance of the Contributor class
Public method | Contributor(String, String) | Initializes a new instance of the Contributor class
Top
Properties
 | Name | Description
Public property | IsPrimary | A flag indicating if this contributor is the primary one on the title.
Public property | Name | Contributor name.
Public property | Role | Name of the role the contributor had on the title.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Contributor) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor Constructor

Overload List
 | Name | Description
Public method | Contributor | Initializes a new instance of the Contributor class
Public method | Contributor(String, String) | Initializes a new instance of the Contributor class
Top
See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor Constructor

Initializes a new instance of the Contributor class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Contributor()
See Also

Reference

Contributor Class
Contributor Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor(String, String) Constructor

Initializes a new instance of the Contributor class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Contributor(
    string name,
    string role
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.#ctor(System.String,System.String)"]

role String

[Missing <param name="role"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.#ctor(System.String,System.String)"]

See Also

Reference

Contributor Class
Contributor Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor Properties

The Contributor type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary | A flag indicating if this contributor is the primary one on the title.
Public property | Name | Contributor name.
Public property | Role | Name of the role the contributor had on the title.
Top
See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.IsPrimary Property

ContributorIsPrimary Property

A flag indicating if this contributor is the primary one on the title.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsPrimary { get; set; }

Property Value

Boolean
See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.Name Property

ContributorName Property

Contributor name.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.Role Property

ContributorRole Property

Name of the role the contributor had on the title.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Role { get; set; }

Property Value

String
See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor Methods

The Contributor type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Contributor) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.Clone Method

ContributorClone Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.Clone"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Contributor Clone()

Return Value

Contributor

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.Clone"]

See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.Equals Method

ContributorEquals Method

Overload List
 | Name | Description
Public method | Equals(Contributor) |
Public method | Equals(Object) |
Top
See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.Equals(Contributor) Method

ContributorEquals(Contributor) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.Equals(Orthogonal.Hoarder.StdLib.Entity.Contributor)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Equals(
    Contributor other
)

Parameters

other Contributor

[Missing <param name="other"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.Equals(Orthogonal.Hoarder.StdLib.Entity.Contributor)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.Equals(Orthogonal.Hoarder.StdLib.Entity.Contributor)"]

Implements

IEquatableTEquals(T)
See Also

Reference

Contributor Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.Equals(Object) Method

ContributorEquals(Object) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.Equals(System.Object)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.Equals(System.Object)"]

See Also

Reference

Contributor Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.GetHashCode Method

ContributorGetHashCode Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.GetHashCode"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.GetHashCode"]

See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Contributor.ToString Method

ContributorToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Contributor.ToString"]

See Also

Reference

Contributor Class
Orthogonal.Hoarder.StdLib.Entity Namespace


DocumentType Enumeration

Enumeration of the document 'type' discriminator numbers of records in the database.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public enum DocumentType
Members
Member name | Value | Description
Title | 2 | Record type is a Title.
Configuration2 | 3 | Record type is the database configuration. A single record of this type must exist in the database.
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


File Class

A Title child document that represents a file stored on digital media such as data CD or DVD. A Title contains a collection of child File documents.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityFile

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class File : IEquatable<File>

The File type exposes the following members.

Constructors
 | Name | Description
Public method | File | Initializes a new instance of the File class
Public method | File(String) | Initializes a new instance of the File class
Top
Properties
 | Name | Description
Public property | Attrs |
Public property | Comment |
Public property | Fullname |
Public property | Length |
Public property | PartSequence |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals(File) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


File Constructor

Overload List
 | Name | Description
Public method | File | Initializes a new instance of the File class
Public method | File(String) | Initializes a new instance of the File class
Top
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File Constructor

Initializes a new instance of the File class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public File()
See Also

Reference

File Class
File Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


File(String) Constructor

Initializes a new instance of the File class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public File(
    string fullname
)

Parameters

fullname String

[Missing <param name="fullname"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.#ctor(System.String)"]

See Also

Reference

File Class
File Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


File Properties

The File type exposes the following members.

Properties
 | Name | Description
Public property | Attrs |
Public property | Comment |
Public property | Fullname |
Public property | Length |
Public property | PartSequence |
Top
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.Attrs Property

FileAttrs Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.File.Attrs"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Attrs { get; set; }

Property Value

String
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.Comment Property

FileComment Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.File.Comment"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

String
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.Fullname Property

FileFullname Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.File.Fullname"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Fullname { get; set; }

Property Value

String
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.Length Property

FileLength Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.File.Length"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public long? Length { get; set; }

Property Value

Nullable Int64
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.PartSequence Property

FilePartSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.File.PartSequence"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int PartSequence { get; set; }

Property Value

Int32
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File Methods

The File type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals(File) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.Clone Method

FileClone Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.Clone"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public File Clone()

Return Value

File

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.Clone"]

See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.Equals Method

FileEquals Method

Overload List
 | Name | Description
Public method | Equals(File) |
Public method | Equals(Object) |
Top
See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.Equals(File) Method

FileEquals(File) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.Equals(Orthogonal.Hoarder.StdLib.Entity.File)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Equals(
    File other
)

Parameters

other File

[Missing <param name="other"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.Equals(Orthogonal.Hoarder.StdLib.Entity.File)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.Equals(Orthogonal.Hoarder.StdLib.Entity.File)"]

Implements

IEquatableTEquals(T)
See Also

Reference

File Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


File.Equals(Object) Method

FileEquals(Object) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.Equals(System.Object)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.Equals(System.Object)"]

See Also

Reference

File Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


File.GetHashCode Method

FileGetHashCode Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.GetHashCode"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.GetHashCode"]

See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


File.ToString Method

FileToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.File.ToString"]

See Also

Reference

File Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre Class

A Title child document that represents a genre associated with a Title. A Title contains a collection of child Genre documents.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityGenre

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class Genre : IEquatable<Genre>

The Genre type exposes the following members.

Constructors
 | Name | Description
Public method | Genre | Initializes a new instance of the Genre class
Public method | Genre(String) | Initializes a new instance of the Genre class
Top
Properties
 | Name | Description
Public property | IsPrimary |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Genre) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


Genre Constructor

Overload List
 | Name | Description
Public method | Genre | Initializes a new instance of the Genre class
Public method | Genre(String) | Initializes a new instance of the Genre class
Top
See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre Constructor

Initializes a new instance of the Genre class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Genre()
See Also

Reference

Genre Class
Genre Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre(String) Constructor

Initializes a new instance of the Genre class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Genre(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.#ctor(System.String)"]

See Also

Reference

Genre Class
Genre Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre Properties

The Genre type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary |
Public property | Name |
Top
See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre.IsPrimary Property

GenreIsPrimary Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Genre.IsPrimary"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsPrimary { get; set; }

Property Value

Boolean
See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre.Name Property

GenreName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Genre.Name"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre Methods

The Genre type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Genre) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre.Clone Method

GenreClone Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.Clone"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Genre Clone()

Return Value

Genre

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.Clone"]

See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre.Equals Method

GenreEquals Method

Overload List
 | Name | Description
Public method | Equals(Genre) |
Public method | Equals(Object) |
Top
See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre.Equals(Genre) Method

GenreEquals(Genre) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.Equals(Orthogonal.Hoarder.StdLib.Entity.Genre)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Equals(
    Genre other
)

Parameters

other Genre

[Missing <param name="other"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.Equals(Orthogonal.Hoarder.StdLib.Entity.Genre)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.Equals(Orthogonal.Hoarder.StdLib.Entity.Genre)"]

Implements

IEquatableTEquals(T)
See Also

Reference

Genre Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre.Equals(Object) Method

GenreEquals(Object) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.Equals(System.Object)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.Equals(System.Object)"]

See Also

Reference

Genre Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre.GetHashCode Method

GenreGetHashCode Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.GetHashCode"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.GetHashCode"]

See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Genre.ToString Method

GenreToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Genre.ToString"]

See Also

Reference

Genre Class
Orthogonal.Hoarder.StdLib.Entity Namespace


IHoarderDocument Interface

The interface that must be implemented by all POCOs that represent a Cosmos DB document. There are currently only two: Title and Configuration2.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public interface IHoarderDocument

The IHoarderDocument type exposes the following members.

Properties
 | Name | Description
Public property | id | The primary key Id of a document. Note that the property name is lower-case because there is currently no attribute that can map a property name of 'Id' to the mandatory Cosmos DB document primary key property name of 'id'.
Public property | Pk | The partition key is always the fixed value "P1".
Public property | Type | The type discriminator of the database document.
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


IHoarderDocument Properties

The IHoarderDocument type exposes the following members.

Properties
 | Name | Description
Public property | id | The primary key Id of a document. Note that the property name is lower-case because there is currently no attribute that can map a property name of 'Id' to the mandatory Cosmos DB document primary key property name of 'id'.
Public property | Pk | The partition key is always the fixed value "P1".
Public property | Type | The type discriminator of the database document.
Top
See Also

Reference

IHoarderDocument Interface
Orthogonal.Hoarder.StdLib.Entity Namespace


IHoarderDocument.id Property

IHoarderDocumentid Property

The primary key Id of a document. Note that the property name is lower-case because there is currently no attribute that can map a property name of 'Id' to the mandatory Cosmos DB document primary key property name of 'id'.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
string id { get; set; }

Property Value

String
See Also

Reference

IHoarderDocument Interface
Orthogonal.Hoarder.StdLib.Entity Namespace


IHoarderDocument.Pk Property

IHoarderDocumentPk Property

The partition key is always the fixed value "P1".

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
string Pk { get; set; }

Property Value

String
See Also

Reference

IHoarderDocument Interface
Orthogonal.Hoarder.StdLib.Entity Namespace


IHoarderDocument.Type Property

IHoarderDocumentType Property

The type discriminator of the database document.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
DocumentType Type { get; set; }

Property Value

DocumentType
See Also

Reference

IHoarderDocument Interface
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture Class

A Title child document that represent a picture associate with a Title. A Title contains a collection of child Picture documents.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityPicture

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class Picture : IEquatable<Picture>

The Picture type exposes the following members.

Constructors
 | Name | Description
Public method | Picture | Initializes a new instance of the Picture class
Public method | Picture(String) | Initializes a new instance of the Picture class
Top
Properties
 | Name | Description
Public property | BlobName |
Public property | IsPrimary |
Public property | Sequence |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | Equals(Picture) |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


Picture Constructor

Overload List
 | Name | Description
Public method | Picture | Initializes a new instance of the Picture class
Public method | Picture(String) | Initializes a new instance of the Picture class
Top
See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture Constructor

Initializes a new instance of the Picture class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Picture()
See Also

Reference

Picture Class
Picture Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture(String) Constructor

Initializes a new instance of the Picture class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Picture(
    string blobName
)

Parameters

blobName String

[Missing <param name="blobName"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.#ctor(System.String)"]

See Also

Reference

Picture Class
Picture Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture Properties

The Picture type exposes the following members.

Properties
 | Name | Description
Public property | BlobName |
Public property | IsPrimary |
Public property | Sequence |
Top
See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.BlobName Property

PictureBlobName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Picture.BlobName"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string BlobName { get; set; }

Property Value

String
See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.IsPrimary Property

PictureIsPrimary Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Picture.IsPrimary"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsPrimary { get; set; }

Property Value

Boolean
See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.Sequence Property

PictureSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Picture.Sequence"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Sequence { get; set; }

Property Value

Int32
See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture Methods

The Picture type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | Equals(Picture) |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.Clone Method

PictureClone Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.Clone"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Picture Clone()

Return Value

Picture

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.Clone"]

See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.Equals Method

PictureEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) |
Public method | Equals(Picture) |
Top
See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.Equals(Object) Method

PictureEquals(Object) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.Equals(System.Object)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.Equals(System.Object)"]

See Also

Reference

Picture Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.Equals(Picture) Method

PictureEquals(Picture) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.Equals(Orthogonal.Hoarder.StdLib.Entity.Picture)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Equals(
    Picture other
)

Parameters

other Picture

[Missing <param name="other"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.Equals(Orthogonal.Hoarder.StdLib.Entity.Picture)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.Equals(Orthogonal.Hoarder.StdLib.Entity.Picture)"]

Implements

IEquatableTEquals(T)
See Also

Reference

Picture Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.GetHashCode Method

PictureGetHashCode Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.GetHashCode"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.GetHashCode"]

See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Picture.ToString Method

PictureToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Picture.ToString"]

See Also

Reference

Picture Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag Class

A Title child document which represents an arbitrary user-defined attribute that can be associated with titles. A Title contains a collection of child Tag documents.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityTag

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class Tag : IEquatable<Tag>

The Tag type exposes the following members.

Constructors
 | Name | Description
Public method | Tag | Initializes a new instance of the Tag class
Public method | Tag(String) | Initializes a new instance of the Tag class
Top
Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | Equals(Tag) |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


Tag Constructor

Overload List
 | Name | Description
Public method | Tag | Initializes a new instance of the Tag class
Public method | Tag(String) | Initializes a new instance of the Tag class
Top
See Also

Reference

Tag Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag Constructor

Initializes a new instance of the Tag class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Tag()
See Also

Reference

Tag Class
Tag Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag(String) Constructor

Initializes a new instance of the Tag class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Tag(
    string name
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.#ctor(System.String)"]

See Also

Reference

Tag Class
Tag Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag Properties

The Tag type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

Tag Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag.Name Property

TagName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Tag.Name"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

Tag Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag Methods

The Tag type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | Equals(Tag) |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Tag Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag.Clone Method

TagClone Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.Clone"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Tag Clone()

Return Value

Tag

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.Clone"]

See Also

Reference

Tag Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag.Equals Method

TagEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) |
Public method | Equals(Tag) |
Top
See Also

Reference

Tag Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag.Equals(Object) Method

TagEquals(Object) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.Equals(System.Object)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.Equals(System.Object)"]

See Also

Reference

Tag Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag.Equals(Tag) Method

TagEquals(Tag) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.Equals(Orthogonal.Hoarder.StdLib.Entity.Tag)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Equals(
    Tag other
)

Parameters

other Tag

[Missing <param name="other"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.Equals(Orthogonal.Hoarder.StdLib.Entity.Tag)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.Equals(Orthogonal.Hoarder.StdLib.Entity.Tag)"]

Implements

IEquatableTEquals(T)
See Also

Reference

Tag Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag.GetHashCode Method

TagGetHashCode Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.GetHashCode"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.GetHashCode"]

See Also

Reference

Tag Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Tag.ToString Method

TagToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Tag.ToString"]

See Also

Reference

Tag Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title Class

A Title is the fundamentally important entity (record or document) in the collections database. A Title represents a single identifiable object in the collections database. It may represent a typical multimedia item such as an audio CD, a video DVD, etc. It may also represent other collectible items such as books, magazines, model cars, stamps, mineral samples or vintage toasters (anything you might consider collecting).

Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityTitle

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class Title : IHoarderDocument

The Title type exposes the following members.

Constructors
 | Name | Description
Public method | Title | Constructs a Title. This empty constructor only exists to allow serialization as JSON over the Hoarder Web API.
Public method | Title(String, String, String) | Constructs a Title with basic required property values.
Top
Properties
Name | Description
Public property | Catalog | Catalogue identifier associated with the title.
Public property | Comment | Longer comment for the title.
Public property | Company | Company name associated with the title.
Public property | Contributors | A non-null array of Contributor documents associated with the title
Public property | Created | UTC time the title was created.
Public property | EditionYear | Year that this edition of the title was published.
Public property | Files | A non-null array of File documents associated with the title
Public property | Genres | A non-null array of Genre documents associated with the title
Public property id

The id uniquely identifies a Title in the collection database. The id is used as the database primary key. The id string has the format T-XXXXXXXXXXXX where the 12 X characters are strongly random and taken from a pool of 34 easily identifiable alphanumeric uppercase characters. There are therefore about 2.4×1018 possible Ids assuming a flat distribution, which is about 61 bits of entropy. The chance of a birthday collision rises to 0.1% at around 68 million, and rises to 1% at around 215 million. Since the total number of titles in the database is around 6700, the probability of a collision is about 10-11 (see Birthday Attack).

Note that the default id value is the special sentinel value UnassignedId so that this class can be passed into the web service and pass validation on the property. The service layer will recognise the special value and convert it into a valid random id before the Title is saved.

Public property | InfoUri | Uri for information about the title.
Public property | IsDiscarded | A flag indicating if a title has been discarded and is no longer physically present in the collection.
Public property | IsHidden | A flag indicating if a title is hidden from unauthorized access for privacy reasons.
Public property | LegacyId | A legacy SQL database IDENTITY Int32 primary key from a Title that was once stored in the Agate database.
Public property | LegacyKey | A legacy primary key from a Title that was once stored in the Nimbus datbase.
Public property | LegacyUid | A legacy SQL database GUID from a Title that was once stored in the Agate database.
Public property | Location | The name of the location where the title is stored.
Public property | Media | The required name of the media holding the title. The value is a short name like "CD", "Book", "Model Car", etc.
Public property | Name | The public Name of the title. This important value is the commonly spoken and recognised name of the title.
Public property | Note | Short note for the title.
Public property | Owner | Name of the title's owner.
Public property | PartCount | Number of identifiable distinct parts inside the title. A typical example is a "boxed set" of audio discs where the whole box has a title, but it may contain multiple disc 'parts'.
Public property | Pictures | A non-null array of Picture documents associated with the title
Public property | Pk | The Partition Key is the fixed value "P1". The Partition Key is intended to be used in Cosmos databases for horizontal scaling of very large numbers of records to improve query performance. Since the Hoarder database only contains several thousand documents, the use of a Partition Key is of no value, so it's set to a fixed value.
Public property | Price | Purchase price of the title ($AUD).
Public property | PublishYear | Year the title was originally published.
Public property | Purchased | Date the title was purchased.
Public property | SaveTime | The UTC time the title document was last saved.
Public property | ScanHash | Hash of the label, full file names and file lengths of a digital data disc with a file system.
Public property | ScanLabel | Label detected by scanning a digital data disc.
Public property | SourceId | The optional id of a 'Source Title' that can be used as the source of information to complete this title. The concept of a 'Source Title' exists to help avoid duplicating information in many possible duplicate entries in the collection. This is an experimental property and feature that is not recognised by an client applications yet.
Public property | Tags | A non-null array of Tag documents associated with the title
Public property | Tracks | A non-null array of Track documents associated with the title
Public property | Type | Discriminates different types of documents in the database. There are currently only two types: Title document (Type=2) and Configuration document (Type=3).
Top
Methods
 | Name | Description
 | IsValidTitleId | Validates a string as being a valid Title id.
 | MakeTitleId | Generates a random Title 'id' which acts as the database primary key. For more information see id.
Public method | ToString | (Overrides ObjectToString)
Top
Fields
Name | Description
IdRandChars | The set of all possible characters that can be used to compose a Title key. The character set is chosen from digits and a reduced set of upper-case characters to avoid visual confusion between characters like '0' and 'O', and '1' and 'I'.
IdRandLen | The length of a Title id (primary key) random characters that follow the prefix.
TitleIdPrefix | The prefix of all title id (primary key) strings.
UnassignedId | A special default value for the id property to indicate that it has not been assigned a value. Null can't be used because this project is compiled with nullable=true and an attempt to pass a null id into the web service generates a validation error. There is a [ValidateNever] attribute to workaround this problem, but it exists in the Microsoft.AspNetCore.App package which is too heavy for this shared library.
Top
Remarks

The Title class corresponds exactly to the schema of a Title document as it is stored in the Cosmos database. Cosmos DB internally stores documents as indexed serializable JSON documents, and the Title class is in fact serialized to-and-from a database JSON document.

A Title document can have collections of child documents associated with it, each providing additional information about the Title. Child documents include genres, contributor names and roles, tracks, files, pictures and arbitrary tags.

See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


Title Constructor

Overload List
 | Name | Description
Public method | Title | Constructs a Title. This empty constructor only exists to allow serialization as JSON over the Hoarder Web API.
Public method | Title(String, String, String) | Constructs a Title with basic required property values.
Top
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title Constructor

Constructs a Title. This empty constructor only exists to allow serialization as JSON over the Hoarder Web API.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Title()
See Also

Reference

Title Class
Title Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Title(String, String, String) Constructor

Constructs a Title with basic required property values.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Title(
    string id,
    string name,
    string media
)

Parameters

id String
The unique primary database id of the Title. Providing a null id value is the same as providing the special value UnassignedId. A null value is internally converted into the special value which allows serialization of the Title to proceed without validation errors. The special value is recognised on the server-side when the Title is saved to the database and the id is replaced with a valid random id.
name String
The required name of the Title.
media String
The required short name of the Title's media.
See Also

Reference

Title Class
Title Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Title Properties

The Title type exposes the following members.

Properties
Name | Description
Public property | Catalog | Catalogue identifier associated with the title.
Public property | Comment | Longer comment for the title.
Public property | Company | Company name associated with the title.
Public property | Contributors | A non-null array of Contributor documents associated with the title
Public property | Created | UTC time the title was created.
Public property | EditionYear | Year that this edition of the title was published.
Public property | Files | A non-null array of File documents associated with the title
Public property | Genres | A non-null array of Genre documents associated with the title
Public property id

The id uniquely identifies a Title in the collection database. The id is used as the database primary key. The id string has the format T-XXXXXXXXXXXX where the 12 X characters are strongly random and taken from a pool of 34 easily identifiable alphanumeric uppercase characters. There are therefore about 2.4×1018 possible Ids assuming a flat distribution, which is about 61 bits of entropy. The chance of a birthday collision rises to 0.1% at around 68 million, and rises to 1% at around 215 million. Since the total number of titles in the database is around 6700, the probability of a collision is about 10-11 (see Birthday Attack).

Note that the default id value is the special sentinel value UnassignedId so that this class can be passed into the web service and pass validation on the property. The service layer will recognise the special value and convert it into a valid random id before the Title is saved.

Public property | InfoUri | Uri for information about the title.
Public property | IsDiscarded | A flag indicating if a title has been discarded and is no longer physically present in the collection.
Public property | IsHidden | A flag indicating if a title is hidden from unauthorized access for privacy reasons.
Public property | LegacyId | A legacy SQL database IDENTITY Int32 primary key from a Title that was once stored in the Agate database.
Public property | LegacyKey | A legacy primary key from a Title that was once stored in the Nimbus datbase.
Public property | LegacyUid | A legacy SQL database GUID from a Title that was once stored in the Agate database.
Public property | Location | The name of the location where the title is stored.
Public property | Media | The required name of the media holding the title. The value is a short name like "CD", "Book", "Model Car", etc.
Public property | Name | The public Name of the title. This important value is the commonly spoken and recognised name of the title.
Public property | Note | Short note for the title.
Public property | Owner | Name of the title's owner.
Public property | PartCount | Number of identifiable distinct parts inside the title. A typical example is a "boxed set" of audio discs where the whole box has a title, but it may contain multiple disc 'parts'.
Public property | Pictures | A non-null array of Picture documents associated with the title
Public property | Pk | The Partition Key is the fixed value "P1". The Partition Key is intended to be used in Cosmos databases for horizontal scaling of very large numbers of records to improve query performance. Since the Hoarder database only contains several thousand documents, the use of a Partition Key is of no value, so it's set to a fixed value.
Public property | Price | Purchase price of the title ($AUD).
Public property | PublishYear | Year the title was originally published.
Public property | Purchased | Date the title was purchased.
Public property | SaveTime | The UTC time the title document was last saved.
Public property | ScanHash | Hash of the label, full file names and file lengths of a digital data disc with a file system.
Public property | ScanLabel | Label detected by scanning a digital data disc.
Public property | SourceId | The optional id of a 'Source Title' that can be used as the source of information to complete this title. The concept of a 'Source Title' exists to help avoid duplicating information in many possible duplicate entries in the collection. This is an experimental property and feature that is not recognised by an client applications yet.
Public property | Tags | A non-null array of Tag documents associated with the title
Public property | Tracks | A non-null array of Track documents associated with the title
Public property | Type | Discriminates different types of documents in the database. There are currently only two types: Title document (Type=2) and Configuration document (Type=3).
Top
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Catalog Property

TitleCatalog Property

Catalogue identifier associated with the title.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Catalog { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Comment Property

TitleComment Property

Longer comment for the title.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Company Property

TitleCompany Property

Company name associated with the title.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Company { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Contributors Property

TitleContributors Property

A non-null array of Contributor documents associated with the title

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Contributor[] Contributors { get; set; }

Property Value

Contributor
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Created Property

TitleCreated Property

UTC time the title was created.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime Created { get; set; }

Property Value

DateTime
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.EditionYear Property

TitleEditionYear Property

Year that this edition of the title was published.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? EditionYear { get; set; }

Property Value

Nullable Int16
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Files Property

TitleFiles Property

A non-null array of File documents associated with the title

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public File[] Files { get; set; }

Property Value

File
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Genres Property

TitleGenres Property

A non-null array of Genre documents associated with the title

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Genre[] Genres { get; set; }

Property Value

Genre
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.id Property

Titleid Property

The id uniquely identifies a Title in the collection database. The id is used as the database primary key. The id string has the format T-XXXXXXXXXXXX where the 12 X characters are strongly random and taken from a pool of 34 easily identifiable alphanumeric uppercase characters. There are therefore about 2.4×1018 possible Ids assuming a flat distribution, which is about 61 bits of entropy. The chance of a birthday collision rises to 0.1% at around 68 million, and rises to 1% at around 215 million. Since the total number of titles in the database is around 6700, the probability of a collision is about 10-11 (see Birthday Attack).

Note that the default id value is the special sentinel value UnassignedId so that this class can be passed into the web service and pass validation on the property. The service layer will recognise the special value and convert it into a valid random id before the Title is saved.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string id { get; set; }

Property Value

String

Implements

IHoarderDocumentid
Remarks
The id property name is lowercase to conform to a requirement of the underlying Cosmos database. The lowercase property name id has special treatment in the database and is used as the primary key. There are no built-in .NET attributes that can map different cased property names, so the class property name is lowercase to allow direct serialization.
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.InfoUri Property

TitleInfoUri Property

Uri for information about the title.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string InfoUri { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.IsDiscarded Property

TitleIsDiscarded Property

A flag indicating if a title has been discarded and is no longer physically present in the collection.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsDiscarded { get; set; }

Property Value

Boolean
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.IsHidden Property

TitleIsHidden Property

A flag indicating if a title is hidden from unauthorized access for privacy reasons.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool IsHidden { get; set; }

Property Value

Boolean
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.LegacyId Property

TitleLegacyId Property

A legacy SQL database IDENTITY Int32 primary key from a Title that was once stored in the Agate database.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? LegacyId { get; set; }

Property Value

Nullable Int32
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.LegacyKey Property

TitleLegacyKey Property

A legacy primary key from a Title that was once stored in the Nimbus datbase.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string LegacyKey { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.LegacyUid Property

TitleLegacyUid Property

A legacy SQL database GUID from a Title that was once stored in the Agate database.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Guid? LegacyUid { get; set; }

Property Value

Nullable Guid
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Location Property

TitleLocation Property

The name of the location where the title is stored.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Location { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Media Property

TitleMedia Property

The required name of the media holding the title. The value is a short name like "CD", "Book", "Model Car", etc.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Media { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Name Property

TitleName Property

The public Name of the title. This important value is the commonly spoken and recognised name of the title.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Note Property

TitleNote Property

Short note for the title.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Note { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Owner Property

TitleOwner Property

Name of the title's owner.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Owner { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.PartCount Property

TitlePartCount Property

Number of identifiable distinct parts inside the title. A typical example is a "boxed set" of audio discs where the whole box has a title, but it may contain multiple disc 'parts'.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short PartCount { get; set; }

Property Value

Int16
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Pictures Property

TitlePictures Property

A non-null array of Picture documents associated with the title

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Picture[] Pictures { get; set; }

Property Value

Picture
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Pk Property

TitlePk Property

The Partition Key is the fixed value "P1". The Partition Key is intended to be used in Cosmos databases for horizontal scaling of very large numbers of records to improve query performance. Since the Hoarder database only contains several thousand documents, the use of a Partition Key is of no value, so it's set to a fixed value.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Pk { get; set; }

Property Value

String

Implements

IHoarderDocumentPk
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Price Property

TitlePrice Property

Purchase price of the title ($AUD).

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public decimal? Price { get; set; }

Property Value

Nullable Decimal
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.PublishYear Property

TitlePublishYear Property

Year the title was originally published.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public short? PublishYear { get; set; }

Property Value

Nullable Int16
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Purchased Property

TitlePurchased Property

Date the title was purchased.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? Purchased { get; set; }

Property Value

Nullable DateTime
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.SaveTime Property

TitleSaveTime Property

The UTC time the title document was last saved.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DateTime? SaveTime { get; set; }

Property Value

Nullable DateTime
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.ScanHash Property

TitleScanHash Property

Hash of the label, full file names and file lengths of a digital data disc with a file system.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public long? ScanHash { get; set; }

Property Value

Nullable Int64
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.ScanLabel Property

TitleScanLabel Property

Label detected by scanning a digital data disc.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string ScanLabel { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.SourceId Property

TitleSourceId Property

The optional id of a 'Source Title' that can be used as the source of information to complete this title. The concept of a 'Source Title' exists to help avoid duplicating information in many possible duplicate entries in the collection. This is an experimental property and feature that is not recognised by an client applications yet.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string SourceId { get; set; }

Property Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Tags Property

TitleTags Property

A non-null array of Tag documents associated with the title

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Tag[] Tags { get; set; }

Property Value

Tag
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Tracks Property

TitleTracks Property

A non-null array of Track documents associated with the title

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Track[] Tracks { get; set; }

Property Value

Track
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.Type Property

TitleType Property

Discriminates different types of documents in the database. There are currently only two types: Title document (Type=2) and Configuration document (Type=3).

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public DocumentType Type { get; set; }

Property Value

DocumentType

Implements

IHoarderDocumentType
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title Methods

The Title type exposes the following members.

Methods
 | Name | Description
 | IsValidTitleId | Validates a string as being a valid Title id.
 | MakeTitleId | Generates a random Title 'id' which acts as the database primary key. For more information see id.
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.IsValidTitleId Method

TitleIsValidTitleId Method

Validates a string as being a valid Title id.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static bool IsValidTitleId(
    string id
)

Parameters

id String

[Missing <param name="id"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Title.IsValidTitleId(System.String)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Title.IsValidTitleId(System.String)"]

See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.MakeTitleId Method

TitleMakeTitleId Method

Generates a random Title 'id' which acts as the database primary key. For more information see id.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public static string MakeTitleId()

Return Value

String
A random and probably globally unique Title 'id'.
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.ToString Method

TitleToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Title.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Title.ToString"]

See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title Fields

The Title type exposes the following members.

Fields
Name | Description
IdRandChars | The set of all possible characters that can be used to compose a Title key. The character set is chosen from digits and a reduced set of upper-case characters to avoid visual confusion between characters like '0' and 'O', and '1' and 'I'.
IdRandLen | The length of a Title id (primary key) random characters that follow the prefix.
TitleIdPrefix | The prefix of all title id (primary key) strings.
UnassignedId | A special default value for the id property to indicate that it has not been assigned a value. Null can't be used because this project is compiled with nullable=true and an attempt to pass a null id into the web service generates a validation error. There is a [ValidateNever] attribute to workaround this problem, but it exists in the Microsoft.AspNetCore.App package which is too heavy for this shared library.
Top
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.IdRandChars Field

TitleIdRandChars Field

The set of all possible characters that can be used to compose a Title key. The character set is chosen from digits and a reduced set of upper-case characters to avoid visual confusion between characters like '0' and 'O', and '1' and 'I'.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string IdRandChars = "0123456789ABCDEFGHJKLMNPQRSTUVWXYZ"

Field Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.IdRandLen Field

TitleIdRandLen Field

The length of a Title id (primary key) random characters that follow the prefix.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const int IdRandLen = 12

Field Value

Int32
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.TitleIdPrefix Field

TitleTitleIdPrefix Field

The prefix of all title id (primary key) strings.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string TitleIdPrefix = "T-"

Field Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Title.UnassignedId Field

TitleUnassignedId Field

A special default value for the id property to indicate that it has not been assigned a value. Null can't be used because this project is compiled with nullable=true and an attempt to pass a null id into the web service generates a validation error. There is a [ValidateNever] attribute to workaround this problem, but it exists in the Microsoft.AspNetCore.App package which is too heavy for this shared library.

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public const string UnassignedId = "_unassigned_id"

Field Value

String
See Also

Reference

Title Class
Orthogonal.Hoarder.StdLib.Entity Namespace


TitleComparer Class

A utility helper class to compare equality of Titles based upon the id.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityTitleComparer

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public sealed class TitleComparer : IEqualityComparer<Title>

The TitleComparer type exposes the following members.

Constructors
 | Name | Description
Public method | TitleComparer | Initializes a new instance of the TitleComparer class
Top
Methods
 | Name | Description
Public method | Equals |
Public method | GetHashCode |
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


TitleComparer Constructor

Initializes a new instance of the TitleComparer class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public TitleComparer()
See Also

Reference

TitleComparer Class
Orthogonal.Hoarder.StdLib.Entity Namespace


TitleComparer Methods

The TitleComparer type exposes the following members.

Methods
 | Name | Description
Public method | Equals |
Public method | GetHashCode |
Top
See Also

Reference

TitleComparer Class
Orthogonal.Hoarder.StdLib.Entity Namespace


TitleComparer.Equals Method

TitleComparerEquals Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.TitleComparer.Equals(Orthogonal.Hoarder.StdLib.Entity.Title,Orthogonal.Hoarder.StdLib.Entity.Title)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Equals(
    Title x,
    Title y
)

Parameters

x Title

[Missing <param name="x"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.TitleComparer.Equals(Orthogonal.Hoarder.StdLib.Entity.Title,Orthogonal.Hoarder.StdLib.Entity.Title)"]

y Title

[Missing <param name="y"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.TitleComparer.Equals(Orthogonal.Hoarder.StdLib.Entity.Title,Orthogonal.Hoarder.StdLib.Entity.Title)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.TitleComparer.Equals(Orthogonal.Hoarder.StdLib.Entity.Title,Orthogonal.Hoarder.StdLib.Entity.Title)"]

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

TitleComparer Class
Orthogonal.Hoarder.StdLib.Entity Namespace


TitleComparer.GetHashCode Method

TitleComparerGetHashCode Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.TitleComparer.GetHashCode(Orthogonal.Hoarder.StdLib.Entity.Title)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int GetHashCode(
    Title obj
)

Parameters

obj Title

[Missing <param name="obj"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.TitleComparer.GetHashCode(Orthogonal.Hoarder.StdLib.Entity.Title)"]

Return Value

Int32

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.TitleComparer.GetHashCode(Orthogonal.Hoarder.StdLib.Entity.Title)"]

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

TitleComparer Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track Class

A Title child document describing a track, which typically represents a section within a Title. Most music media such as vinyl records and audio CDs contain traditional tracks. A track can also be used to define sections of printed media such as book chapters. A Title contains a collection of child Track documents.
Inheritance Hierarchy
SystemObject
Orthogonal.Hoarder.StdLib.EntityTrack

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
[SerializableAttribute]
public class Track : IEquatable<Track>

The Track type exposes the following members.

Constructors
 | Name | Description
Public method | Track | Initializes a new instance of the Track class
Public method | Track(String, Int32) | Initializes a new instance of the Track class
Top
Properties
 | Name | Description
Public property | Comment |
Public property | Name |
Public property | PartSequence |
Public property | Seconds |
Public property | Sequence |
Public property | Side |
Public property | Stars |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | Equals(Track) |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Orthogonal.Hoarder.StdLib.Entity Namespace


Track Constructor

Overload List
 | Name | Description
Public method | Track | Initializes a new instance of the Track class
Public method | Track(String, Int32) | Initializes a new instance of the Track class
Top
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track Constructor

Initializes a new instance of the Track class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Track()
See Also

Reference

Track Class
Track Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Track(String, Int32) Constructor

Initializes a new instance of the Track class

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Track(
    string name,
    int sequence
)

Parameters

name String

[Missing <param name="name"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.#ctor(System.String,System.Int32)"]

sequence Int32

[Missing <param name="sequence"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.#ctor(System.String,System.Int32)"]

See Also

Reference

Track Class
Track Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Track Properties

The Track type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Name |
Public property | PartSequence |
Public property | Seconds |
Public property | Sequence |
Public property | Side |
Public property | Stars |
Top
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Comment Property

TrackComment Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Track.Comment"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

String
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Name Property

TrackName Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Track.Name"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Name { get; set; }

Property Value

String
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.PartSequence Property

TrackPartSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Track.PartSequence"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int PartSequence { get; set; }

Property Value

Int32
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Seconds Property

TrackSeconds Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Track.Seconds"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Seconds { get; set; }

Property Value

Nullable Int32
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Sequence Property

TrackSequence Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Track.Sequence"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int Sequence { get; set; }

Property Value

Int32
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Side Property

TrackSide Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Track.Side"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public string Side { get; set; }

Property Value

String
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Stars Property

TrackStars Property

[Missing <summary> documentation for "P:Orthogonal.Hoarder.StdLib.Entity.Track.Stars"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public int? Stars { get; set; }

Property Value

Nullable Int32
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track Methods

The Track type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object))
Public method | Equals(Track) |
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | ToString | (Overrides ObjectToString)
Top
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Clone Method

TrackClone Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.Clone"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public Track Clone()

Return Value

Track

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.Clone"]

See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Equals Method

TrackEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) |
Public method | Equals(Track) |
Top
See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Equals(Object) Method

TrackEquals(Object) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.Equals(System.Object)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj Object

[Missing <param name="obj"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.Equals(System.Object)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.Equals(System.Object)"]

See Also

Reference

Track Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.Equals(Track) Method

TrackEquals(Track) Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.Equals(Orthogonal.Hoarder.StdLib.Entity.Track)"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public bool Equals(
    Track other
)

Parameters

other Track

[Missing <param name="other"/> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.Equals(Orthogonal.Hoarder.StdLib.Entity.Track)"]

Return Value

Boolean

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.Equals(Orthogonal.Hoarder.StdLib.Entity.Track)"]

Implements

IEquatableTEquals(T)
See Also

Reference

Track Class
Equals Overload
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.GetHashCode Method

TrackGetHashCode Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.GetHashCode"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Int32

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.GetHashCode"]

See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace


Track.ToString Method

TrackToString Method

[Missing <summary> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.ToString"]

Namespace: Orthogonal.Hoarder.StdLib.Entity
Assembly: Orthogonal.Hoarder.StdLib (in Orthogonal.Hoarder.StdLib.dll) Version: 8.0.9
Syntax
C#
Copy
public override string ToString()

Return Value

String

[Missing <returns> documentation for "M:Orthogonal.Hoarder.StdLib.Entity.Track.ToString"]

See Also

Reference

Track Class
Orthogonal.Hoarder.StdLib.Entity Namespace